LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   How do I get my email client to change to my browser as the active window? (http://www.linuxquestions.org/questions/fedora-35/how-do-i-get-my-email-client-to-change-to-my-browser-as-the-active-window-814705/)

hscast 06-17-2010 07:43 AM

How do I get my email client to change to my browser as the active window?
 
I have installed Fedora 13 x86_64. I use the Gnome Desktop (which uses Metacity as it's default window manager), with Firefox 3.6.3 and Thunderbird 3.0.4. I have Firefox and Thunderbird set as my Preferred apps for web browser and email client. When I click on a web link in an email message the focus stays on Thunderbird as the active window and Firefox stays minimized, although the button on the task panel is flashing and I could tell that it did open the URL in a new tab, my default action. On Fedora 12 when I did the above, Firefox would come forward as the active window on top of Thunderbird with the URL opened in a new tab. I want this behavior to happen with F13. I can't find any settings in either app that impact this action and through Config Editor have not found any settings either. Am I missing something?

bathory 06-17-2010 08:25 AM

Hi,

In firefox write "about:config" in the address bar, search for the keyword "browser.tabs.loadDivertedInBackground" and set it to false

Regards

hscast 06-17-2010 11:47 AM

It was already set that way. Do you know of any other settings?

I just tried closing firefox and then from T'bird clicking on an embedded link and it did launch Firefox with that window as the active one on top of T'Bird. But if I try it with it already running the tab on the task panel will flash and when I click on it Firefox pops up with the link launced in a new tab and that tab being the active tab. I don't know what else to change. The same option in T'Bird is also set to false so it's not that. Also I'm using the same profiles from F12 where it worked correctly.

bathory 06-17-2010 12:09 PM

No, this is the setting you want.
To test, set it to true by double-clicking on it, try a link from an email and see if it opens with the browser in the background or minimized.
Then set it to false and try again.
Just tested on my Slackware64, running FF 3.6.3 and TB 3.0.4 and it works as expected.

DrLove73 06-17-2010 12:47 PM

It might be setting specific to GNOME or distro specific. What should GNOME do when program from background tries to get focus.

hscast 06-17-2010 01:21 PM

Quote:

Originally Posted by bathory (Post 4006724)
No, this is the setting you want.
To test, set it to true by double-clicking on it, try a link from an email and see if it opens with the browser in the background or minimized.
Then set it to false and try again.
Just tested on my Slackware64, running FF 3.6.3 and TB 3.0.4 and it works as expected.

Actually that is what I had done. I had misread your post somehow thinking you said to set to "True". I then went to T'Bird and tried it, with no effect on Firefox. I then switched it back to "False" where it returned to the behaviour that I had in my OP.

bathory 06-17-2010 01:37 PM

It should work and I don't think it's related to the Desktop Environment or Window Manager.
Do you by any chance have an extension that changes the FF behavior about opening links in new tabs?

hscast 06-17-2010 02:16 PM

Quote:

Originally Posted by bathory (Post 4006797)
It should work and I don't think it's related to the Desktop Environment or Window Manager.
Do you by any chance have an extension that changes the FF behavior about opening links in new tabs?

Okay it just suddenly started working partly. If I minimize FF to the Task Panel and leave T'Bird at full window and click on the link it does switch to FF with the site opened in a new tab. However if I just switch to T'Bird by clicking on its window (I normally have T'Bird at full window and FF is vertically full height but not full width so if it is on top of T'Bird it doesn't completely cover it), it will not switch just stay on T'Bird and the tab for FF will be flashing with the name of the link. I had seen another option similar name to the one you pointed out and it was set to "True" which I went ahead and changed to "False". Maybe it's a new feature and behaves slightly different than 3.5.9?


All times are GMT -5. The time now is 07:32 AM.