LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 10-30-2007, 02:52 PM   #1
martinr
Member
 
Registered: Mar 2006
Location: Stockholm, Sweden
Distribution: FC10 x86_64, RHEL4/5 x86_64
Posts: 87

Rep: Reputation: 15
Question How do I disable the startup screen?


Hello,

I have some problem with the graphics driver (nvidia from livna), which seems to be starting "too late". When The startup screen is supposed to show up the screen complains of wrong frequencies. Then the computer then either freezes or continues to the login screen when the nvidia logo shows up and everything works fine. So my question is, how do I disable the grapics during the startup period? Offcourse it would be preferable if I instead can make it work.

Any idears?
 
Old 10-30-2007, 03:23 PM   #2
shafty023
Member
 
Registered: Oct 2007
Distribution: OSX
Posts: 248

Rep: Reputation: 31
So the startup screen when Fedora is booting up prior to login screen? You can comment that out in /etc/rc.sysinit on line 346.
Should look like this
# Start the graphical boot, if necessary; /usr may not be mounted yet, so we
# may have to do this again after mounting
346:RHGB_STARTED=0
347:mount -n /dev/pts >/dev/null 2>&1
348:[ -n "$SELINUX_STATE" ] && restorecon /dev/pts >/dev/null 2>&1
349:if strstr "$cmdline" rhgb && ! strstr "$cmdline" early-login && [ "$BOOTUP" = "color" -a "$GRAPHICAL" = "yes" -a -x /usr/bin/rhgb ]; then
350: ( . /etc/sysconfig/i18n 2>/dev/null ; /usr/bin/rhgb )
351: RHGB_STARTED=1
352:fi

So just taking a guess you could comment out line 350 & 351 and put in it's place this -> echo "Disabled graphical boot".
I've added the line numbers on the left just to make it easier on you, you won't see these when you open the file of course.
If you're using "vi" to open the file, once open type :350 and hit enter and it will take you to line 350
So like this
# Start the graphical boot, if necessary; /usr may not be mounted yet, so we
# may have to do this again after mounting
346:RHGB_STARTED=0
347:mount -n /dev/pts >/dev/null 2>&1
348:[ -n "$SELINUX_STATE" ] && restorecon /dev/pts >/dev/null 2>&1
349:if strstr "$cmdline" rhgb && ! strstr "$cmdline" early-login && [ "$BOOTUP" = "color" -a "$GRAPHICAL" = "yes" -a -x /usr/bin/rhgb ]; then
350: echo "Disabled graphical boot"
351: #( . /etc/sysconfig/i18n 2>/dev/null ; /usr/bin/rhgb )
352: #RHGB_STARTED=1
353:fi
 
Old 10-30-2007, 06:53 PM   #3
martinr
Member
 
Registered: Mar 2006
Location: Stockholm, Sweden
Distribution: FC10 x86_64, RHEL4/5 x86_64
Posts: 87

Original Poster
Rep: Reputation: 15
Thanks for the reply. I will try this at once. Do you (or anyone else) have any idear how to get the graphical bootup to work? It would be so much nicer

Thanks,
 
Old 10-31-2007, 05:41 PM   #4
martinr
Member
 
Registered: Mar 2006
Location: Stockholm, Sweden
Distribution: FC10 x86_64, RHEL4/5 x86_64
Posts: 87

Original Poster
Rep: Reputation: 15
Unhappy It doesn't work

Hi again,

The "fix" you describe sadly doesn't work. The message shows up like seven or 8 green "OKs" before the screen frequency goes haywire. Is there anywhere later in the file you would suggest to write something similar? Are you sure it won't screw up the bootup totally?

I'm really thankful for you efforts!
 
Old 10-31-2007, 08:14 PM   #5
stoat
Member
 
Registered: May 2007
Distribution: LFS
Posts: 484

Rep: Reputation: 133Reputation: 133
Try removing the rhgb parameter from the kernel line in your grub.conf file. That will prevent the blue splashscreen background for GRUB menu and the blue progress bar screen. But the log in screen will still be the graphical log in. Maybe that will help.
 
Old 11-01-2007, 10:26 AM   #6
martinr
Member
 
Registered: Mar 2006
Location: Stockholm, Sweden
Distribution: FC10 x86_64, RHEL4/5 x86_64
Posts: 87

Original Poster
Rep: Reputation: 15
Smile

Offcourse!! That should really do the trick! I can't wait to get home and try it.

I actually think that is how I solved the problem years ago. Talking about re-inventing the wheel

Thanks in advance (knock on wood)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to disable Lock Screen when close laptop screen? amosbatto Linux - Laptop and Netbook 2 01-17-2006 12:12 AM
Disable PCMCIA on startup Peanutman Fedora 3 08-12-2005 05:58 AM
disable x in fc1 on startup ngophat Linux - Software 3 07-31-2004 07:12 PM
How do I disable the "attractive," graphical startup screen? 3line Linux - Software 16 10-31-2003 12:23 AM
How do I disable proftpd on startup amp2000 Linux - General 9 02-12-2002 04:47 PM


All times are GMT -5. The time now is 03:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration