LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 02-25-2006, 03:49 PM   #1
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,151

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
How can I tell Fedora to activate a non-standard logical volume during boot?


I had a disk crash, and installed a new FC4 on a new disk before I figured out how to run fsck on a logical volume. (You have to do it through /dev/mapper since the mapper "exposes" the ext3 file system "hidden" in the logical volume.)

So, O.K., now I had a new FC4 and an old one. But, since they both used the same "logical volume" name, only one could be accessed at a time. So I renamed the new logical volume to FC4_00.

But now I can't boot the new system. When Fedora initialized the logical volumes during the boot, it found both of them, but it only activated VolGroup00, the old volume group.

My grub.conf looks (in part) like this:
Code:
title Old Fedora Core 4 (2.6.15-1.1831)
  root (hd1,1)
  kernel /vmlinuz-2.6.15-1.1831_FC4smp ro root=/dev/VolGroup00/LogVol00 rhgb quiet
  initrd /initrd-2.6.15-1.1831_FC4smp.img
title New Fedora Core 4 (2.6.15-1.1831)
  root (hd1,1)
  kernel /vmlinuz-2.6.15-1.1831_FC4smp ro root=/dev/FC4_00/LogVol00 rhgb quiet
  initrd /initrd-2.6.15-1.1831_FC4smp.img
So, my question is: "How do I tell the boot process to activate FC4_00?"

Edit: Oh, I just realized I hadn't described the specific symptom. Because the FC4_00 is not activated, the boot process can't write to /dev, and so it can't create any /dev/tty, thus causing a "kernel panic" and halt. Note that this seems to imply that the root= line in the load command was processed. Just prior to the "panic," there's a message that the mount of root failed with a error 6, and that's preceded by the message I mentioned that LVM found two logical volumes, but activated the wrong one. (Um, all that is seen when the "quiet" option is removed from the 'kernel" line, above.)

Last edited by PTrenholme; 02-25-2006 at 04:18 PM.
 
Old 02-26-2006, 08:55 AM   #2
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,151

Original Poster
Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
Smile Solved it!

The problem is that VolGrp00 is hardcoded in the nash init script (inside the initrd...img compressed file. (See this note for details of editing.)

The solution is to remove VolGrp00 from the end of the vgchange line, so nash will "activate" all the volume groups, since the volume group name is optional in the vgchange command. (If you have some groups that you don't want activated, deactivated them in /etc/rc.local later.)

Edit: Fixed URL

Last edited by PTrenholme; 03-13-2006 at 03:55 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
swapping on a logical volume garba Linux - General 1 06-28-2005 06:36 PM
cloning both partitions, dual boot system, master boot record, logical volume manager saranga2000 Linux - Hardware 3 01-10-2005 11:04 AM
Logical Volume Manager sidmark-2850 Linux - General 3 01-02-2004 01:25 PM
Logical Volume Management jatimon Linux - General 0 04-17-2002 02:57 PM
Logical Volume Groups concoran Linux - General 3 06-03-2001 06:29 AM


All times are GMT -5. The time now is 10:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration