LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   hi i tried to build LTIB 2008 on fedora 12 , am got error regarding endianess (http://www.linuxquestions.org/questions/fedora-35/hi-i-tried-to-build-ltib-2008-on-fedora-12-am-got-error-regarding-endianess-930671/)

sreeharsha 02-22-2012 06:27 AM

hi i tried to build LTIB 2008 on fedora 12 , am got error regarding endianess
 
error detail is

ftl_format.c:63:3: error: #error cannot detect endianess
ftl_format.c: In function 'build_header':
ftl_format.c:109: warning: implicit declaration of function 'TO_LE32'
ftl_format.c:110: warning: implicit declaration of function 'TO_LE16'
make: *** [ftl_format.o] Error 1
make: Leaving directory `/opt/freescale/ltib/usr/src/rpm/BUILD/mtd/util'
error: Bad exit status from /home/himagni/ltib-m5475evb-20080808/tmp/rpm-tmp.73027 (%build)


RPM build errors:
Bad exit status from /home/himagni/ltib-m5475evb-20080808/tmp/rpm-tmp.73027 (%build)
Build time for mtd-utils: 0 seconds

Failed building mtd-utils
Died at ./ltib line 1225.
traceback:
main::build_host_rpms:1225
main::host_checks:1279
main:489


Started: Wed Feb 22 15:04:15 2012
Ended: Wed Feb 22 15:04:15 2012
Elapsed: 0 seconds

These packages failed to build:
mtd-utils

Build Failed

please send the solution for this...............

corp769 02-22-2012 11:30 PM

What RPM are you using to try to install it? Have a look at the following link, and make sure you have the latest version of it - http://ltib.org/resources-download

Also, Fedora 12 is not being developed anymore, I highly recommend that you upgrade to the latest version of Fedora as well from the Fedora site; Fedora 16 is the latest stable release.


All times are GMT -5. The time now is 01:27 AM.