LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
LinkBack Search this Thread
Old 04-03-2006, 05:16 PM   #1
Linsnake
LQ Newbie
 
Registered: Mar 2006
Posts: 6

Rep: Reputation: 0
GRUB error 15


When I have first time rebooted Fedora 5(during the installation process) error 15 occur and the system did't load(any system because i'have also Windows XP on another physical disk).And I don't know what it means?
 
Old 04-03-2006, 05:24 PM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,165
Blog Entries: 4

Rep: Reputation: 426Reputation: 426Reputation: 426Reputation: 426Reputation: 426
Quote:
From the Gentoo Forums
Grub error 15
After hitting return in the grub prompt you get something similar to this one?
Code:
Booting 'gentoo Linux'

root (hd0,0)
Filesystem type is ext2fs, partition type 0x83
kernel (hd0,0)/boot/kernel-2.4.20 root=/dev/hda3 vga=792

Error 15: File not found
Press any key to continue...
info grub wrote:
15 : File not found
This error is returned if the specified file name cannot be found, but everything else (like the disk/partition info) is OK.

If it's the kernel that it's missing (bzImage, kernel...):make sure that the file it is referring to exists on your boot partition.

To find out what the exact name of your kernel is, first boot from the live-cd or into your existing linux installation. Then mount /boot if you've got a seperate partition, or mount / if you don't. Then do the following:
Code:
cd /boot
ls
This will list all the kernels that you've got on your boot partition.

If your kernel is missing make sure that you compiled a kernel either with genkernel or make menuconfig
Code:
 cd /usr/src/linux/
make menuconfig
and you copied it to your boot partition.
Code:
cp /usr/src/linux/arch/[your architecture, e.g. i386]/boot/bzImage /boot/
However if this error is caused while trying to install grub. And is similar to this one:
Code:
grub> root (hd0,0)
 Filesystem type is xfs, partition type 0x83

grub> setup (hd0)
 Checking if "/boot/grub/stage1" exists... no
 Checking if "/grub/stage1" exists... no

Error 15: File not found
First of all make sure that you changed root(hd0,0) and setup (hd0) according to your systems specifications.

It may also be possible that grub uses other numbers for your drives than your kernel. So although it may be hda it could be that it is not hd0. However usually this is not the case.

Or else give this line a try provided by dirtboy
Code:
grub-install /dev/bootdevice

If all else fails make sure that your partition is not somehow corrupt. Be sure that you are able to great symbolic links.
Hope this helps.
 
Old 04-04-2006, 05:34 PM   #3
Linsnake
LQ Newbie
 
Registered: Mar 2006
Posts: 6

Original Poster
Rep: Reputation: 0
Thank for help but maybe I have wrongly describe my problem and I have manage this problem in another way.Because my structure of HDD is as follows:
/dev/hda
/dev/hda1 ntfs (windows XP)
/dev/hdb
/dev/hdb1 /boot
/dev/hdb3 VolGroup00
/dev/hdb2
/dev/hdb5 vfat
First I have change IDE-0 to IDE1 in BIOS then I have changed in installation the order of disk(in advanced Boot ladder options) (because first was hda than hdb) and next I have entered form to option hdb and hdb1 the second one. And the system works proprely BUT!!!
I can't boot Windows

My grub.conf is as follows:


# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,1)
# kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
# initrd /initrd-version.img
#boot=/dev/hda
default=0
timeout=10
splashimage=(hd0,1)/grub/splash.xpm.gz
hiddenmenu
title Fedora Core 5 (2.6.15-1.2054_FC5)
root (hd0,1)
kernel /vmlinuz-2.6.15-1.2054_FC5 ro root=/dev/VolGroup00/LogVol00
initrd /initrd-2.6.15-1.2054_FC5.img
title Windows XP
rootnoverify (hd1,0)
chainloader +1
I have made all the polsibillities of "rootnoverify (hd1,0)" line especially the content of bracket and always the system prints the massage that some error occure or just stop and do nothing.

Maybe you could help me with this problem.
 
Old 04-05-2006, 06:07 AM   #4
Gethyn
Member
 
Registered: Aug 2003
Location: UK
Distribution: (X)Ubuntu 10.04/10.10, Debian 5, CentOS 5
Posts: 900

Rep: Reputation: 32
I seem to remember reading somewhere that Windows likes to be on the first hard drive. Perhaps you could try asking grub to swap the drive labels for booting? I can't remember the exact command but it's definitely been posted on this site before.
 
Old 04-13-2006, 11:50 AM   #5
R0nni3
LQ Newbie
 
Registered: Apr 2006
Posts: 1

Rep: Reputation: 0
the subject morphed :|
XavierP ... Linsnake wrote
Quote:
When I have first time rebooted Fedora 5(during the installation process) error 15 occur and the system did't load(any system because i'have also Windows XP on another physical disk).And I don't know what it means?
and that's it.
You replied
Quote:
Grub error 15
After hitting return in the grub prompt you get something similar to this one?
Code:

Booting 'gentoo Linux' root (hd0,0) Filesystem type is ext2fs, partition type 0x83 kernel (hd0,0)/boot/kernel-2.4.20 root=/dev/hda3 vga=792 Error 15: File not found Press any key to continue... info grub wrote: 15 : File not found
But i assume that Linsnake didn't get to hit return...neither did I I think that Linsnake and I have the same problem. I have 2 hdds : first, primary master, hosts 2 ntfs partitions (on first, winxp, on second-> storage). Second hdd : primary slave : fedora core 5 . While installing Fedora 5 the installer offered 2 options : install GRUB on hda1 (first hdd xp partition ) or hdb (linux hdd) i selected hda1. When it boots it says : Loading GRUB Grub loading...... error 15 . :| I don't even get to see grub. :| I hope someone knows how to solve this. I think i will use some 3rd party bootloader because i have always had problems with GRUB with various PCs i have owned over the years and various linux distros . Since then i used lilo. But last night i didn't see lilo available . If i figure this out, Linsnake you'll be the first to know :P
 
Old 04-14-2006, 05:14 AM   #6
Linsnake
LQ Newbie
 
Registered: Mar 2006
Posts: 6

Original Poster
Rep: Reputation: 0
one more thing see http://www.geocities.com/epark/linux...w2k-HOWTO.html and
make form point 3. You should manage (If I have managed)
 
Old 04-14-2006, 05:32 AM   #7
Linsnake
LQ Newbie
 
Registered: Mar 2006
Posts: 6

Original Poster
Rep: Reputation: 0
I thing before you will make the steps form this page you should first install one more time your windows xp because (on the master partition as previously)I think chosing in GRUB during your previous instalation of Linux hda1 you have overwritten some booting files form windows XP and because of that it don't want to run.What's more:
make 4 partition on the slave hdd

in order :
/boot ext3 112MB
/ ext3 (calculate it free space-(2*your RAM)-1GB)
swap 2*your RAM
/osshare vfat 1GB will be enough (this is to exchange the files between two os systems win and linux without any cd-roms)

And in GRUB instal set "first sector of boot partition" and the booting files of linux will be instal on slave HDD in /boot on hdb1 partition I think.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Grub error 17, and wont reinstall using grub-install! chiefreborn Linux - General 6 06-06-2007 10:29 AM
Grub Error 17: Cannot mount selected partition and other Grub problems Sebastian Naitsabes Linux - General 1 07-05-2005 08:33 AM
GRUB bootloader spits out "GRUB hard disk error" Crampedson Linux - Software 2 01-26-2005 06:34 PM
GRUB Section2 load error, partition error. Ryle Linux - General 1 06-27-2004 02:55 PM
GRUB error? DriveReady SeekComplete DataRequest Error sth Linux - Hardware 3 02-26-2003 05:10 PM


All times are GMT -5. The time now is 09:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration