LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 01-16-2008, 05:46 PM   #1
Lindy
Member
 
Registered: Nov 2001
Location: Manistique, MI
Distribution: SUSE 12.1
Posts: 136

Rep: Reputation: 15
Gnome/ KDE Conflicts


I'm having some conflicts between Gnome and KDE that I'm not quite sure how to cure. After installing the rss screensavers I noticed that they would'nt work in KDE but would in Gnome. I selected one to run in Gnome, and when I'm in KDE it will run instead of the screensaver that I selected for KDE. When I logout from a KDE session it sometime goes to the default Gnome background, or black with just a cursor. CTRL + ALT + backspace will either take me back to the login screen or dump me to a command prompt. Anybody have an idea where to start?
 
Old 01-17-2008, 09:13 AM   #2
bgoodr
Member
 
Registered: Dec 2006
Location: Oregon
Distribution: RHEL[45] {x86,x86_64}, Debian "testing" {x86,x86_64}
Posts: 219

Rep: Reputation: 36
Things to try

Hi Lindy,

Disclaimer: I usually turn off fancy screensavers and just use a blank page as the screen saver, since historically I have found that screen savers had problems with older versions of these window managers and X servers (not the least of which is questionable coding practices by some screen savers). I run F7 running the latest GNOME (latest w.r.t. what the standard updates provide, not compiled from latest source).

Things to try that might shed some light on the problem.
  1. Is the behavior the same when you hit CTRL+ALT+BACKSPACE while running KDE and also from GNOME?
  2. How did you install the rss screensavers?
  3. Is the behavior the same when you hit CTRL+ALT+BACKSPACE from either KDE or GNOME after you have uninstalled the rss screensavers?

bgoodr
 
Old 01-17-2008, 06:42 PM   #3
Lindy
Member
 
Registered: Nov 2001
Location: Manistique, MI
Distribution: SUSE 12.1
Posts: 136

Original Poster
Rep: Reputation: 15
Hi bgoodr,

1. The behavior is specific to KDE.
2. The screensavers were installed via yum.
3. I was having logout problems with KDE before the screensavers were installed, and am still having after
uninstalling them.

The only problem I'm having with Gnome is that I have two trash cans, and any desktop icon that I have in KDE appears in Gnome and is labeled no name.
 
Old 01-17-2008, 10:36 PM   #4
bgoodr
Member
 
Registered: Dec 2006
Location: Oregon
Distribution: RHEL[45] {x86,x86_64}, Debian "testing" {x86,x86_64}
Posts: 219

Rep: Reputation: 36
Quote:
Originally Posted by Lindy View Post
The only problem I'm having with Gnome is that I have two trash cans, and any desktop icon that I have in KDE appears in Gnome and is labeled no name.
Wow. That is indeed bizarre. I'm using GNOME with the Metacity window manager which is the default AFAIK, and I don't see that behavior.

Is there a reason why you need to switch between two different window managers instead of getting one to work and saying with that one?

I'm not really opposed to KDE, other than the fact that the format of the files in $HOME/.kde directory were not interoperable between different KDE versions, so I had to ditch them (affected me at work where I have to deal with multiple revisions of both KDE and GNOME desktop versions).

One thing you can try is to move aside your $HOME/.kde directory from within a console terminal, and then restart your X server with CTRL-ALT-DELETE.

Alternatively, since you stated you had problems with CTRL-ALT-DELETE, you may want to play it safe and do the move of the $HOME/.kde directory when the X server is not running. The way I do that is as follows:
  1. Logout of the window manager
  2. At the X login prompt (GDM/XDM/whatever), press CTRL-ALT-F1 to get to a console (X will still be running at this point)
  3. At the login prompt in the console, login as root
  4. Enter in "init 3" at the shell prompt. This will kill the X server, along with KDE or GNOME processes
  5. After you get to another shell prompt, cd into your users $HOME directory (not $HOME of root)
  6. Move the .kde directory aside with the mv command
  7. Enter in "init 5" to restart X and get back to the X login prompt
  8. Log back in as your user account (not as root)
  9. Examine your icons to see if they still persist, and retry CTRL-ALT-BACKSPACE to see if the behavior improves.

The theory is that perhaps the installation/de-installation of the screen savers left some stale data in the $HOME/.kde directory, and moving it aside while X is not running will cause the behavior to correct itself.

bgoodr
 
Old 01-18-2008, 02:14 PM   #5
Lindy
Member
 
Registered: Nov 2001
Location: Manistique, MI
Distribution: SUSE 12.1
Posts: 136

Original Poster
Rep: Reputation: 15
Well poo... No effect
 
Old 01-19-2008, 01:11 PM   #6
bgoodr
Member
 
Registered: Dec 2006
Location: Oregon
Distribution: RHEL[45] {x86,x86_64}, Debian "testing" {x86,x86_64}
Posts: 219

Rep: Reputation: 36
Quote:
Originally Posted by Lindy View Post
Well poo... No effect
If you are logging into KDE, and not GNOME, and you have moved your .kde directory aside, and you still see duplicate icons, then I'm really puzzled as to where KDE could be reading its settings for that. Sorry I couldn't be of more help.
 
Old 01-19-2008, 08:40 PM   #7
Lindy
Member
 
Registered: Nov 2001
Location: Manistique, MI
Distribution: SUSE 12.1
Posts: 136

Original Poster
Rep: Reputation: 15
The duplicated icons are in Gnome, but as it is I think I'll load Fedora8
up on a VM and pound on till it breaks and see if I can shake out any answers.
 
Old 01-20-2008, 11:43 AM   #8
bgoodr
Member
 
Registered: Dec 2006
Location: Oregon
Distribution: RHEL[45] {x86,x86_64}, Debian "testing" {x86,x86_64}
Posts: 219

Rep: Reputation: 36
If this is GNOME, and you are using the Metacity window manager, then I guess that the $HOME/.metacity directory would be where that icon state would be stored. You could play with moving that directory aside to see if the behavior changes.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gaim conflicts with kde in unstable! ValidiusMaximus Debian 8 07-15-2005 04:30 AM
IceWM with KDE: panel conflicts tek1024 Linux - General 0 09-13-2004 12:53 PM
Package Conflicts with KDE JohnRChick Linux - Software 1 08-24-2004 02:10 AM
vte-0.11.10-1.i386.rpm conflicts its older version and gnome-terminal sybatter Linux - Software 0 12-06-2003 07:47 PM
Sound conflicts on rh7.3 kde 10dedfish Linux - Software 1 08-26-2003 07:47 PM


All times are GMT -5. The time now is 12:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration