LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 07-23-2009, 02:54 PM   #1
nicky7
LQ Newbie
 
Registered: Jul 2009
Distribution: Fedora/CentOS
Posts: 7

Rep: Reputation: 0
Gnome = no sound, but aplay/firefox/vlc work w/ alsa


History: (tldr below)

Started with fresh install of F11. Audio initially worked, however I couldn't do multiple streams. Also the 1/8" audio jacks weren't working. Hoping that pulseaudio had improved since F10, I installed a bunch of pulseaudio packages which killed my sound output. Pulse audio meter was showing sound for gnome events, but without actual output. Attempting to use pulseaudio mixer would crash pulse server within a few seconds. Interestingly, firefox was still using alsa and I could hear audio from it (still no multiple streams), but was NOT showing in the pulseaudio meter. I could set vlc to pulseaudio and it'd show up on the meter, but no sound. Setting vlc output to ALSA produced sound (provided it was the only stream) but would not show up on pulseaudio meter. The gnome-volume-control-applet was set to control pulseaudio so wouldn't actually adjust the sound I was hearing. I then ran 'yum remove pulseaudio' to revert back to alsa only and lost gnome-volume-control with the error "Waiting for sound system to respond.", so no volume control in gnome's notification area. Suddenly I found multiple streams were working under alsa, but gnome seems to still be stuck on pulseaudio. I've spent several hours trying to search and rescue my audio to no avail. This is the first time I'm asking a community for help. How do I get gnome to use alsa instead of pulse (I'm assuming this will also bring back my volume control)?

TLDR:
Gnome using broken/uninstalled pulseaudio instead of the working ALSA. How do I configure gnome to use ALSA.

aplay and speaker-test both produce sound.

Code:
$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: STAC92xx Digital [STAC92xx Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
Code:
$ cat /etc/asound.conf
@hooks [
  {
    func load
    files [
      "/etc/alsa/pulse-default.conf"
    ]
    errors false
  }
]
/etc/alsa/pulse-default.conf doesn't exist (but old f10 has same setup here and was working fine)

Code:
$ lspci | grep -i audio
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
01:05.1 Audio device: ATI Technologies Inc RS780 Azalia controller
Opening 'System > Preferences > Sound' produces "Waiting for sound system to respond."
 
Old 07-24-2009, 11:18 AM   #2
John VV
Guru
 
Registered: Aug 2005
Posts: 12,916

Rep: Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715
there is a bug in fedora 11 and pulse audio .
the current updates " should " have fixed that .

well seeing as fedora IS a testing distro ... things will break.

just remove pulseaudio and use alsa.
 
Old 07-24-2009, 11:46 AM   #3
nicky7
LQ Newbie
 
Registered: Jul 2009
Distribution: Fedora/CentOS
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
just remove pulseaudio and use alsa.
That's exactly what I did.

Quote:
I then ran 'yum remove pulseaudio'...
The problem is that gnome is still trying to use pulseaudio, and I can't find where I can change this setting. Everything else works. I think I can do this with /etc/asound.conf or ~/.asoundrc, but I haven't been able to determine what should go in there.

Last edited by nicky7; 07-24-2009 at 11:50 AM.
 
Old 07-29-2009, 01:58 PM   #4
zoltrix
Member
 
Registered: Oct 2004
Distribution: Fedora 11, Ubuntu 9.04, RHEL 4,5 ,Centos 5.1
Posts: 45

Rep: Reputation: 15
I have exactly the same issue . I have removed Pulseaudio as it doesnt behave well with skype. But now, gnome cant output any sound. KDE is fine. I am not getting any sound for notifications from Empathy messenger. Any way we can make Gnome talk to ALSA in fedora 11??
 
Old 08-21-2009, 08:03 AM   #5
nicky7
LQ Newbie
 
Registered: Jul 2009
Distribution: Fedora/CentOS
Posts: 7

Original Poster
Rep: Reputation: 0
There's a python script on fedoraforum that added an alsa capable volume control in the systray, but I'm still having no luck getting gnome to use alsa. http://forums.fedoraforum.org/showthread.php?t=226581
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how can i get sound out of firefox on redhat EL3 with ALSA java Linux - Newbie 4 06-06-2008 08:24 AM
ALSA Sound delay with Flash in Firefox Rikra Debian 2 05-11-2005 09:28 AM
alsa ; compiling aplay.c vose Programming 0 01-13-2005 01:42 AM
New email sound Thunderbird with aplay? Moloko Linux - Software 0 01-02-2005 02:34 PM
firefox lost sound after installing alsa kidicarus Linux - Software 3 12-30-2004 09:48 PM


All times are GMT -5. The time now is 05:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration