LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 11-08-2003, 01:12 PM   #1
wampfler
Member
 
Registered: Nov 2003
Location: switzerland
Distribution: Fedora Core 1.0/Gentoo
Posts: 35

Rep: Reputation: 15
gdm: choose window manager


fedora core 1.0: how can i add a window manager (e.g. windowmaker) to the GDM login menu? an entry in /etc/X11/gdm/Sessions/WindowMaker (RedHat 9 style) doesn't help!!
 
Old 11-08-2003, 03:38 PM   #2
lupin_the_3rd
Member
 
Registered: Oct 2003
Location: Memphis, TN
Distribution: Slackware current
Posts: 485

Rep: Reputation: 30
check out /et/X11/dm/Sessions

This is where they go now... use the ones in there as a template and save as wm.desktop with wm being the name of the wm
 
Old 11-09-2003, 03:07 AM   #3
wampfler
Member
 
Registered: Nov 2003
Location: switzerland
Distribution: Fedora Core 1.0/Gentoo
Posts: 35

Original Poster
Rep: Reputation: 15
thx, it works
 
Old 11-09-2003, 10:15 AM   #4
lupin_the_3rd
Member
 
Registered: Oct 2003
Location: Memphis, TN
Distribution: Slackware current
Posts: 485

Rep: Reputation: 30
I can't figure out how to add it to the switchdesk menu to set other wms as default. Anyone had any luck with this?
 
Old 11-09-2003, 10:41 AM   #5
wampfler
Member
 
Registered: Nov 2003
Location: switzerland
Distribution: Fedora Core 1.0/Gentoo
Posts: 35

Original Poster
Rep: Reputation: 15
i think /etc/X11/gdm/Sessions/mywm should fix this. i can choose now.
 
Old 11-09-2003, 11:08 AM   #6
lupin_the_3rd
Member
 
Registered: Oct 2003
Location: Memphis, TN
Distribution: Slackware current
Posts: 485

Rep: Reputation: 30
Ok solved the default manager bit...

create a file named .Xclients-default tor edit the existing file

/path/to/your/wm/executable

make the script executable...

this is now the default wm.
 
Old 11-12-2003, 01:37 PM   #7
madmaxx
LQ Newbie
 
Registered: Sep 2003
Posts: 1

Rep: Reputation: 0
Quote:
Originally posted by lupin_the_3rd
check out /et/X11/dm/Sessions

This is where they go now... use the ones in there as a template and save as wm.desktop with wm being the name of the wm
Thanx man works like a charm....

how in the world did u find out about it???

 
Old 11-12-2003, 02:39 PM   #8
lupin_the_3rd
Member
 
Registered: Oct 2003
Location: Memphis, TN
Distribution: Slackware current
Posts: 485

Rep: Reputation: 30
I googled forever... ended up finding on a freebsd site...
 
Old 01-08-2004, 06:41 PM   #9
justmedric
LQ Newbie
 
Registered: Jan 2004
Location: New Jersey
Posts: 3

Rep: Reputation: 0
that does not work for me

okay i have one called garnome.desktop but that does not work it does not come up as an option during start up

can you walk me throught it from start to finnish so i can see if i got it right
 
Old 01-08-2004, 07:47 PM   #10
lupin_the_3rd
Member
 
Registered: Oct 2003
Location: Memphis, TN
Distribution: Slackware current
Posts: 485

Rep: Reputation: 30
is it executable?
 
Old 01-09-2004, 08:14 AM   #11
Butterbroetchen
Member
 
Registered: Jan 2004
Posts: 57

Rep: Reputation: 15
Hi

This does not seem to work. I am using Fedora core 1.0 and would like to use sawfish as my windows manager under gnome but this seems to be an impossible task to configure.

I do not need to be able to choose it on the gdm login screen (would be nice though, but I would just like to be able to use sawfish instead of metacity for now)

How can I change this setting. It used to be very simple (RH8.0).

I have spent almost the whole day searching but no success

Please help me.

This forum is the closest I have found to helping me.
But the advise further up has not worked for me I don't know what else to do

Thanks
 
Old 01-09-2004, 09:06 AM   #12
lupin_the_3rd
Member
 
Registered: Oct 2003
Location: Memphis, TN
Distribution: Slackware current
Posts: 485

Rep: Reputation: 30
Login in to GNOME
open up a terminal and type:
killall metacity & sawfish
(you may have to do this a couple of times)
Log out once the sawfish window manager starts and choose to save the session.
Log back in and see if it works

You can also use the gconf editor:

I think it's under system>gnome>apps>windowmanager

Last edited by lupin_the_3rd; 01-09-2004 at 09:07 AM.
 
Old 01-09-2004, 10:02 AM   #13
Butterbroetchen
Member
 
Registered: Jan 2004
Posts: 57

Rep: Reputation: 15
Hi lupin_the_3rd

Thanks the killall bit worked You are a star

The gconf one (I tried that first did not work )
by the way the path is "desktop--gnome--applications--windows manager"


Thanks again

Butterbroetchen
 
Old 01-09-2004, 10:08 AM   #14
lupin_the_3rd
Member
 
Registered: Oct 2003
Location: Memphis, TN
Distribution: Slackware current
Posts: 485

Rep: Reputation: 30
no problem
 
Old 01-09-2004, 05:35 PM   #15
glock19
Member
 
Registered: Aug 2001
Distribution: Debian Etch
Posts: 510

Rep: Reputation: 31
Quote:
Originally posted by lupin_the_3rd
Ok solved the default manager bit...

create a file named .Xclients-default tor edit the existing file

/path/to/your/wm/executable

make the script executable...

this is now the default wm.
In what directory do I create the ".Xclients-default" file?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Playing games without a Window Manager!! GDM problem aquarius_kasuia Linux - General 4 10-09-2005 10:43 AM
gdm add window manager el_pajaro! Debian 2 04-30-2005 08:16 PM
gdm default window manager kodon Slackware 2 08-27-2004 08:22 PM
How do I add another window manager to my GDM session list? RoaCh Of DisCor Linux - Software 0 07-08-2004 05:57 PM
Adding an alternative window manager to the gdm login? glock19 Fedora 5 01-09-2004 06:16 PM


All times are GMT -5. The time now is 07:47 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration