LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   Fresh Fedora install and BIND (http://www.linuxquestions.org/questions/fedora-35/fresh-fedora-install-and-bind-407369/)

Jamesk5 01-24-2006 09:47 AM

Fresh Fedora install and BIND
 
Hey, I'm a linux semi-noob and am going cold turkey and learning to configure a server without the use of a GUI. I've start off trying to configure BIND and have come across a problem.
I've got the named deamon running, and I can ping and run dig commands on domain names from my linux box, and they return results, but when I set my windows box to use my linux server as its rimary DNS server the windows box won't resolve any domain names!
My config files are below:


/etc/resolv.conf
# nameserver 127.0.0.1
nameserver 59.167.250.99
# search localdomain


/var/named/chroot/etc/named.conf
//
// named.conf for Red Hat caching-nameserver
//

options {
directory "/var/named";
dump-file "/var/named/data/cache_dump.db";
statistics-file "/var/named/data/named_stats.txt";
/*
* If there is a firewall between you and nameservers you want
* to talk to, you might need to uncomment the query-source
* directive below. Previous versions of BIND always asked
* questions using port 53, but BIND 8.1 uses an unprivileged
* port by default.
*/
// query-source address * port 53;
};

//
// a caching only nameserver config
//
controls {
inet 127.0.0.1 allow { localhost; } keys { rndckey; };
};

zone "." IN {
type hint;
file "named.ca";
};


zone "localdomain" IN {
type master;
file "localdomain.zone";
allow-update { none; };
};

zone "localhost" IN {
type master;
file "localhost.zone";
allow-update { none; };
};

zone "0.0.127.in-addr.arpa" IN {
type master;
file "named.local";
allow-update { none; };
};

zone "0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa" IN {
type master;
file "named.ip6.local";
allow-update { none; };
};

zone "255.in-addr.arpa" IN {
type master;
file "named.broadcast";
allow-update { none; };
};

zone "0.in-addr.arpa" IN {
type master;
file "named.zero";
allow-update { none; };
};


include "/etc/rndc.key";

As I said, I'm a n00b so any help with this will be really appreciated. All I wan't to do is use it as a chaching server (for now, I'll use it to do zones and stuff later). I've been using this tutorial: http://www.brennan.id.au/ - but I get really lost :(

Thanks heaps!

brianthegreat 01-24-2006 07:31 PM

Are you using a default gateway?? What are your windows settings?

I have not used Bind lately and forget the config options. You might want to ask another question in the networking forum (even though your not suppose to double post).

Or ask a question over here:

www.justlinux.com

They are very good! Or at least in the past. I have not been on the board for quite sometime.

Jamesk5 02-05-2006 09:32 PM

Yea, I'm using a default gateway which is a machine running WindowsXP Pro, with the dialup connection (Australian communications suck) and DHCP running even though I've given my server a static IP.
I've given my machine (also WinXP Pro) the following settings:
IP (STATIC) - 192.168.0.52
Subnet - 255.255.255.0
Default Gateway - 192.168.0.1 (WindowsXP machine)
DNS - 192.168.0.1

When I set the DNS to 192.168.0.5 (the linux box running BIND) - all DNS queries can't be resolved, so I have to set it back to 192.168.0.1 (WinXP Pro 'server') to be able to use the internet and resolve domains.


All times are GMT -5. The time now is 10:30 PM.