LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 06-20-2007, 11:40 PM   #1
RonOot
LQ Newbie
 
Registered: Jun 2007
Posts: 2

Rep: Reputation: 0
Fresh Fedora 7 install - Please walk me thru wireless 1390 configuration


I have a brand new Dell Inspiron 1501 running a fresh install of Fedora 7. Everything is configured and working, except for my wireless, which is the seemingly infamous 1390 card. I've read many forums, and there appear to be many ways to get this working, but I want to do it as cleanly as possibly. Please point me in the right direction. I understand that ndiswrapper is one route, but it feels like too much of a hack for me to be comfortable with. Maybe it really is the best way to go? In any case, it would be really helpful to me and others in my shoes if we could get a thorough walkthrough, starting from the point of a fresh install.

All help is thoroughly appreciated!
 
Old 06-22-2007, 05:58 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Using ndiswrapper is not that hard, all you need are a few rpm packages.

Step one:

rpm -ivh http://ftp.freshrpms.net/pub/freshrp....fc.noarch.rpm

Step two:

yum install dkms dkms-ndiswrapper

Step three:

modprobe ndiswrapper
ndiswrapper -i <the windows inf file>


Step four:
Create a new file in the /etc/sysconfig/network-scripts directory called ifcfg-wlan0 which looks something like:

TYPE=Wireless
DEVICE=wlan0
HWADDR=
BOOTPROTO=dhcp
IPADDR=
NETMASK=255.255.255.0
GATEWAY=
DOMAIN=
ONBOOT=yes
ONHOTPLUG=yes
USERCTL=yes
IPV6INIT=no
PEERDNS=yes
ESSID=
CHANNEL=
MODE=
RATE=


Step five: service network restart
 
Old 06-22-2007, 09:10 PM   #3
RonOot
LQ Newbie
 
Registered: Jun 2007
Posts: 2

Original Poster
Rep: Reputation: 0
Thank you, this is where I am at:

/usr/sbin/ndiswrapper -l
bcmwl5 : driver installed
device (14E4:4311) present (alternate driver: bcm43xx-mac80211)

/sbin/iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:""
Mode:Managed Channel:0 Access Point: Not-Associated
Retry min limit:7 RTS thrff Fragment thr=2346 B
Encryption keyff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

/sbin/service network restart
Shutting down interface eth0: [ OK ]
Shutting down loopback interface: [ OK ]
Bringing up loopback interface: [ OK ]
Bringing up interface eth0:
Determining IP information for eth0... done.
[ OK ]
Bringing up interface wlan0: SIOCSIFFLAGS: No such file or directory

Determining IP information for wlan0...SIOCSIFFLAGS: No such file or directory
SIOCSIFFLAGS: No such file or directory
failed.
[FAILED]
 
Old 06-23-2007, 06:10 AM   #4
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
What does the output from the typed command 'iwlist wlan0 scan' show??? Your wireless access point???

What does the /etc/sysconfig/network-scripts/ifcfg-wlan0 file look like??

Is the wired interface (eth0) connected to the same network? If yes then you might to shutdown this interface, as root type: ifdown eth0

You might want to also edit the /etc/sysconfig/network-scripts/ifcfg-eth0 file so the wired interface does not start on boot, change the line entry to be: ONBOOT=no


Both the bcm43xx-mac80211 and ndiswrapper drivers cannot be loaded at the same time, one needs to be removed or blacklisted. Check:
cat /proc/modules | grep ndis
cat /proc/modules | grep bcm43

If both are loaded then remove the bcm43xx-mac80211 module: modprobe -r bcm43xx-mac80211
and blacklist the module be editing the /etc/modprobe.d/blacklist file adding to the end of the file;

# wireless
blacklist bcm43xx-mac80211

Do you have a file named something like ifcfg-wmaster0 in the /etc/sysconfig/network-scripts directory? If yes then also check your /etc/modprobe.conf file for a line entry with wmaster0 as part of the line, if it exists then add a comment(#) to the beginning of the line.

Example: # alias wmaster0 bcm43x-mac80211
 
Old 06-23-2007, 09:26 AM   #5
zjman
LQ Newbie
 
Registered: Jun 2007
Posts: 1

Rep: Reputation: 0
Hi, I was in the exact same place as RonOot with, after following the last set of directions, I get the following:

/sbin/service network restart
Shutting down interface eth0: [ OK ]
Shutting down loopback interface: [ OK ]
SIOCGIFFLAGS: No such device
Bringing up loopback interface: [ OK ]
Bringing up interface eth0:
Determining IP information for eth0... done.
[ OK ]
Bringing up interface wlan0: Device wlan0 does not seem to be present, delaying initialization.
[FAILED]
 
Old 06-23-2007, 10:39 AM   #6
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Then as a suggestion remove ndiswrapper and use the built-in bcm43xx-mac80211 module. Be sure to edit the files(/etc/modprobe.conf, ifcfg-wlan0 and so forth) as needed. Also you will need the firmware files for the wireless interface in the /lib/firmware directory. Use the suggested drivers (with instructions) from:

http://www.redhat.com/archives/fedor.../msg01009.html
 
Old 06-23-2007, 11:38 AM   #7
GregLee
Member
 
Registered: Feb 2004
Location: Waimanalo, HI
Distribution: Slackware 10, Fedora 6
Posts: 308

Rep: Reputation: 30
Quote:
Originally Posted by RonOot
wlan0 IEEE 802.11g ESSID:""
Mode:Managed Channel:0 Access Point: Not-Associated
Hopefully at this point you can get wlan0 to associate with the access point by a series of calls "iwconfig wlan0 ..." to give information about the network you're trying to join. What's the SSID? What's the WEP encryption key (if any)? What's the mode? Channel? Keep checking "iwconfig wlan0" to see whether you're making progress.
 
Old 07-01-2007, 09:12 PM   #8
mikntwd
LQ Newbie
 
Registered: Jul 2007
Posts: 3

Rep: Reputation: 0
Problems with BCM43 on Fedora 7

I followed the directions as previously indicated above.

My problem upon activating Wireless is:
Error for wireless request "Set Mode" (8B06) :
SET failed on device wlan0 ; Invalid argument.

Determining IP information for wlan0... failed; no link present. Check cable?

Here is my settings:

NDISWRAPPER;
[root@jamnz ~]# ndiswrapper -l
bcmwl5 : driver installed
device (14E4:4320) present (alternate driver: bcm43xx-mac80211)
[root@jamnz ~]#
 
Old 07-01-2007, 09:45 PM   #9
mikntwd
LQ Newbie
 
Registered: Jul 2007
Posts: 3

Rep: Reputation: 0
Cannot Set ESSID via Terminal

While trying to make my wireless card work in terminal mode,
I encounter this problem.

I cannot manually assign ESSD.

I use the following command:
iwconfig wlan0 essid jamnz

wlan0 IEEE 802.11g ESSIDff/any Nickname:"n"
Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
Bit Rate=54 Mb/s Tx-Power:32 dBm
RTS thr=2347 B Fragment thr=2346 B
Encryption key:56EA-2AB6-B2CB-6938-10EA-F688-68 Security mode:restricted
Power Managementff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
 
Old 07-01-2007, 11:22 PM   #10
GregLee
Member
 
Registered: Feb 2004
Location: Waimanalo, HI
Distribution: Slackware 10, Fedora 6
Posts: 308

Rep: Reputation: 30
The ssid may not be accepted until you've gotten it to associate with the access point. Try "ifconfig wlan0 up" before issuing iwconfig commands. And check that the security mode is right -- try "iwconfig wlan0 key open".
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless 1390 card not working properly JoeLinux117 Fedora 32 05-26-2008 03:33 PM
dell wireless 1390 on kubuntu 6.08 dranas Linux - Newbie 2 06-19-2007 10:09 AM
Dell 1390 wireless authentication problem with WPA-SK Michael_aust Linux - Wireless Networking 3 05-25-2007 08:02 AM
HP dv2210us - Broadcom Wireless 1390 tosszafer Linux - Laptop and Netbook 1 02-21-2007 01:29 PM
SuSE 10.2 and ndiswrapper for Dell 1390 Wireless card TheFnN3WGuy Linux - Wireless Networking 10 02-08-2007 12:34 PM


All times are GMT -5. The time now is 02:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration