Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Fedora This forum is for the discussion of the Fedora Project.


  Search this Thread
Old 03-18-2004, 10:23 AM   #1
LQ Newbie
Registered: Mar 2004
Distribution: Archlinux
Posts: 18

Rep: Reputation: 0
Font rendering ugly without antialiasing

Hi everybody...
Firstly i would ask you to forgive me if i'm posting a question already asked many times...but i've been searching around for a solution to my problem without finding any

I've got, obviously, fedora core 1. Everybody like antialiasing, probably with a good reason, but i really can't...i've been trying to live with it without succes
The problem is that if i'm disabling it the font rendering is damn bad...the only font displaying good is Helvetica with a size less than 10(with greater sizes no way to show it nicely).
On previous rh distros there was the pretty and easy option ":unscaled" to put after a font path in XFree86.config, with which i was used to solve the, even putting it in the xml file "local.conf" there ain't any way to get it work!

I'm near to desperation
Thanks for your (eventual) help and for your patience
Old 03-18-2004, 09:37 PM   #2
LQ Newbie
Registered: Mar 2004
Posts: 4

Rep: Reputation: 0
First and foremost, if you haven't already read the Fedora Core 1 release notes, let me suggest you read the paragraph on fonts (under the heading "General Notes"), at least, to be aware of the two differing font subsystems.

Regarding your problem, one thing you could try is rebuilding the FreeType package from the corresponding source RPM, with the TrueType bytecode interpreter enabled. The latter is disabled in the distributed package due to patent reasons.

Before building the package, you should install a "non-root" RPM build environment for your user. Example instructions can be found here; if you use the first method from that page, you should amend your user's RPM configuration using the following commands afterwards:
mkdir -p ~/rpmbuild/tmp
echo '%_tmppath %(echo $HOME)/rpmbuild/tmp' >> ~/.rpmmacros
In any case, the rpm-build package is required to be installed.

Now, install the FreeType source RPM via rpm -ihv /path/to/freetype*.src.rpm. Near the beginning of the file ~/rpmbuild/SPECS/freetype.spec (file pathes may vary depending on your RPM configuration), there is a line beginning with %define without_bytecode_interpreter. Change the numeric value at the end of line from 1 to 0.

Make sure the XFree86-devel package is installed (check using, e. g., rpm -q XFree86-devel), and start the build process as follows: rpmbuild -bb --clean ~/rpmbuild/SPECS/freetype.spec

If all goes well, you'll be able to install the new FreeType package(s) using rpm -Fvh --replacepkgs --replacefiles ~/rpmbuild/RPMS/i386/freetype*.rpm. In case there is an error, please post the complete message here.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
font antialiasing gone after installing a new theme venkatrao Linux - General 1 05-07-2005 01:07 AM
ugly font eeyoree Slackware 1 10-16-2004 11:32 PM
Ugly Truetype font in GTK apps kvzrock Linux - General 0 02-08-2004 10:35 PM
ugly font !! princeware Red Hat 5 12-29-2003 02:01 AM
Mozilla Font Antialiasing? Crickit Linux - Software 3 04-10-2003 05:35 AM

All times are GMT -5. The time now is 08:34 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration