LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   floppy not found in fedora 8? (http://www.linuxquestions.org/questions/fedora-35/floppy-not-found-in-fedora-8-a-615299/)

tibbitts 01-21-2008 04:37 PM

floppy not found in fedora 8?
 
I have a very standard computer: Dell Optiplex GX1 400 P2, running Fedora 8 with the latest updates. Sometime in the past few months (maybe worked in FC7, I don't recall) my floppy drive seems to have gone away. I see no floppy device files, no mention of the floppy or controller in any hardware diags (lshw, etc.)

When I stick an old Tom's rootboot diskette in the drive and boot, the floppy works just fine and dmesg shows:

FDC0 is a National Semiconductor PC87306

I'm going to experiment with some other Linux distros now, just wanted to post and see if I was missing something obvious (usually the case.)

Thanks

Paul

PS: Please, no need to ask why I'm using a floppy :-)

aus9 01-21-2008 06:17 PM

can you post floppy line in your /etc/fstab

eg my line is
/dev/fd0 /media/floppy auto umask=0022,users,iocharset=utf8,noauto,exec,flush 0 0

2)

go into /boot/config (if you run more than one kernel choose the same version number)
use control and f to find the following text
(a)
# DOS/FAT/NT Filesystems
and its contents....only half dozen lines?
this will show if normal floppy formatted disks are readable...they use fat system

then search for this line
(b)
CONFIG_BLK_DEV_IDEFLOPPY
and post it contents....

3)
if that floppy line ended with =m then

Code:

su
lsmod |grep floppy

and you may get something like this....post the result pls
floppy 54052 0

this indicates my kernel has floppy has a module and module is loaded.

tibbitts 01-21-2008 08:19 PM

config file info
 
That's what so strange: these are the "stock" Fedora kernels, installed with yum from the usual repositories. No customization. And yet, there are no fd* device files, and no string "FLOP" anywhere in the /boot/config* files for either "recent" kernel.

Take for example this computer I'm on now, with FC6. I have this:

config-2.6.22.14-72.fc6:CONFIG_BLK_DEV_IDEFLOPPY=y

But on the Fedora 8 computer, there is no mention (yes, no, module, etc.) of CONFIG_BLK_DEV_IDEFLOPPY. I guess I'm assuming that if floppies were gone completely from everybody's kernel config there would be some kind of huge outcry (since most people don't build their own kernels), but I haven't noticed that in searching so far. On the other hand, I'm wondering if I've managed to trigger some "feature", perhaps by how I did my install (upgrade, in this case), that has resulted in only me having no floppy support.

Thanks.

Paul

aus9 01-22-2008 04:33 AM

weird...but can you post your fat stuff as well....

2) try scrolling to this section and post all of its contents should be only a few lines pls

#Block devices

3) sometimes its the bios itself....I turn off plugnplay system....and force linux to do its magic....see if you have such an option in your bios......or it may be called windows?

aus9 01-22-2008 04:36 AM

google suggests fedora may use /etc/sysconfig/modules/udev-stw.modules, which basically only loads the floppy module

aus9 01-22-2008 04:45 AM

there are 2 likely bugs you may want to look at
https://bugzilla.redhat.com/show_bug.cgi?id=200910

https://bugzilla.redhat.com/show_bug.cgi?id=427007

Spascticus 05-11-2008 06:55 AM

I'm running Fedora 8. I'm quite new to Linux. I don't know how to access my floppy drive. I've seen reference made to /dev/fd0 in /etc/fstab. My fstab file contains no such reference. Here it is:

/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0

Can anybody tell me how to proceed? Thanks.

aus9 05-11-2008 07:59 AM

since the OP has not replied I assume that matter is resolved or he has given up in disgust.

Spascticus

assuming you have such a beast in /dev/

but distro may not have a /media/floppy or a /mnt/floppy

if you have no preferences make a folder

Code:

su
mkdir /media/floppy

you can just add a line to your fstab with root powers

eg

/dev/fd0 /media/floppy auto users,rw 0 0

2) the auto means mount will try vfat and other formats to try and mount any loaded media

users means you can have normal permissions instead of having to be root for rw powers

Spascticus 05-11-2008 02:47 PM

aus9,

Thanks for the speedy reply. After trying all day to sort it out, I've found out what I needed to do, by typing "man MAKEDEV" in the terminal and following the instructions for a floppy disk.

For anyone with the same problem, I typed "sbin/MAKEDEV fd0H1440" in the terminal when logged on as root, then
I specified the type of the floppy disk as you described but with /dev/fd0H1440 in /etc/fstabs, instead of just /dev/fd0.

Who is the OP?

aus9 05-11-2008 06:48 PM

the original poster...in this thread tibbitts


All times are GMT -5. The time now is 11:22 AM.