LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   File browsers Nautilus, Dolphin not showing RAID sets, but member disks on Fedora 16 (http://www.linuxquestions.org/questions/fedora-35/file-browsers-nautilus-dolphin-not-showing-raid-sets-but-member-disks-on-fedora-16-a-944680/)

Polo_Talnir 05-12-2012 11:47 PM

File browsers Nautilus, Dolphin not showing RAID sets, but member disks on Fedora 16
 
Running Fedora 16 fully updated to 5/5/2012.
My desktop has 3 fakeraid RAID1 sets, i.e. 6 disks paired in mirroring pairs.
Nautilus and Dolphin show the individual disks, in addition to the RAID sets. I don't dare to open the disks shown, perhaps risking to modify
a member disk directly, causing a time-consuming recovery of the mirrored set, or perhaps corrupting the file system, so that I am not sure what really these triplicate entries mean (same disk label appearing three times - I *presume* that once for each physical disk and once for the RAID set - I don't know which is which).

I consider this a severe bug, as one is not supposed to access directly
individual disks of RAID sets. But before I post a bug report, is there some kind of 'configuration' for these file browsers to make them behave reasonably?

Thanks,
-Polo

stoggy 06-04-2012 07:26 PM

dolphin and nautilus are showing the disks that the OS knows about. same as doing `fdisk -l` will. I have had this problem before but i forget how i fixed it.


Try adding the partition to the /etc/fstab file with a mount path other than /media/xxx, use something like /mnt/xxx and add the noauto option to prevent these partitions being auto mounted during boot.


so add something like: (i showed ext2 here it has the fewest options. Hopefully it wont work for mounting at all, since you dont want these to mount) Added ro, read-only, so if they do get mounted they wouldn't be writeable. This setting wont affect the drive just the affect when mounting. The nouser option will forbid normal users from mounting these. If you dont make the mount point and try to mount these the mount command will fail, So dont make the mount point. 0 0 so it wont allow backup and fscks to run on the individual partitions.

/dev/sdb1 /mnt/hide/part1 ext2 noauto,nouser,ro 0 0
/dev/sdc1 /mnt/hide/part2 ext2 noauto,nouser,ro 0 0


All times are GMT -5. The time now is 05:09 PM.