LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 03-11-2004, 08:19 AM   #1
jeffreybluml
Member
 
Registered: Mar 2004
Location: Minnesota
Distribution: Fedora Core 1, Mandrake 10
Posts: 405

Rep: Reputation: 30
Fedora wont boot, displays nvidia splash screen over and over


Hello,

I am a total newbie here, so bear with me...and my apologies for the length of this thread...

I am running Fedora Core, with kernel 2.4.22-1.2174.nptl. I installed the Nvidia drivers for my GeForce card back when running 2.4.22-1.2149, and since then have updated the kernal twice with no problems. The other day, however, everything went wrong...

Linux inexplicably froze at 4:44 AM, and at 5:10 I attempted a reboot. Everything appears fine, right up until the Nvidia splash screen appears. Instead of leaving the splash screen and going to the screen which shows everthing starting (with the progress bar and all that, just before you'd get to the login screen), it loops over and over into the nvidia splash screen. This will not stop.

I tried to use interactive startup, and once it worked (which 80% of the time it doesn't...I hit "I" and it just ignores it and tries to boot normally) I chose not to load the nvidia driver. All this did was stop the splash screen from appearing, but it still looped endlessly on a black screen, and the monitor clikced like it does when going in and out of the nvidia screen.

I finally used putty from another computer (while it was looping), and set my runlevel to 3 in the /etc/inittab file, and now I can at least get to a command shell. Below is a portion of the /var/log/messages file in which you can see the error I expect is causing this...


Mar 10 05:10:37 localhost atd: atd startup succeeded
Mar 10 05:10:38 localhost messagebus: messagebus startup succeeded
Mar 10 05:10:38 localhost nvidia: Checking for nvidia kernel module succeeded
Mar 10 05:10:38 localhost nvidia: Enabling nvidia driver succeeded
Mar 10 05:10:39 localhost kdm_config[5342]: Unrecognized section name [Desktop0] at /usr/sha
re/config/kdm/kdmrc:42
Mar 10 05:10:40 localhost kernel: 0: nvidia: loading NVIDIA Linux x86 NVIDIA Kernel Module
1.0-5336 Wed Jan 14 18:29:26 PST 2004
Mar 10 05:10:40 localhost insmod: Warning: loading /lib/modules/2.4.22-1.2174.nptl/kernel/dr
ivers/video/nvidia/nvidia.o will taint the kernel: non-GPL license - NVIDIA
Mar 10 05:10:40 localhost insmod: See "this was a url but I had to remove it to post this"
ion about tainted modules
Mar 10 05:10:40 localhost insmod: Module nvidia loaded, with warnings
Mar 10 05:10:43 localhost kernel: Linux agpgart interface v0.99 (c) Jeff Hartmann
Mar 10 05:10:43 localhost kernel: agpgart: Maximum main memory to use for agp memory: 439M
Mar 10 05:10:43 localhost kernel: agpgart: Detected Via Apollo Pro KT266 chipset
Mar 10 05:10:43 localhost kernel: agpgart: AGP aperture is 64M @ 0xe8000000
Mar 10 05:10:51 localhost kdm[5344]: IO Error in XOpenDisplay
Mar 10 05:10:51 localhost kdm[5329]: Display :0 cannot be opened
Mar 10 05:11:01 localhost kdm[5349]: IO Error in XOpenDisplay
Mar 10 05:11:01 localhost kdm[5329]: Display :0 cannot be opened
Mar 10 05:11:10 localhost kdm[5352]: IO Error in XOpenDisplay
Mar 10 05:11:10 localhost kdm[5329]: Display :0 cannot be opened
Mar 10 05:11:20 localhost kdm[5355]: IO Error in XOpenDisplay
Mar 10 05:11:20 localhost kdm[5329]: Display :0 cannot be opened
Mar 10 05:11:20 localhost kdm[5329]: Display :0 is being disabled (restarting too fast)
Mar 10 05:11:20 localhost kdm_config[5371]: Unrecognized section name [Desktop0] at /usr/sha
re/config/kdm/kdmrc:42
Mar 10 05:11:30 localhost kdm[5373]: IO Error in XOpenDisplay
Mar 10 05:11:30 localhost kdm[5358]: Display :0 cannot be opened
Mar 10 05:11:40 localhost kdm[5376]: IO Error in XOpenDisplay
Mar 10 05:11:40 localhost kdm[5358]: Display :0 cannot be opened
Mar 10 05:11:41 localhost shutdown: shutting down for system reboot
Mar 10 05:11:41 localhost init: Switching to runlevel: 6
Mar 10 05:11:45 localhost shutdown: shutting down for system reboot
Mar 10 05:11:45 localhost nvidia: Disabling nvidia driver succeeded
Mar 10 05:11:45 localhost messagebus: messagebus -TERM succeeded
Mar 10 05:11:45 localhost atd: atd shutdown succeeded
Mar 10 05:15:47 localhost syslogd 1.4.1: restart.
Mar 10 05:15:47 localhost syslog: syslogd startup succeeded

And here is my XF86Config file:

# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules/extensions/nvidia"
ModulePath "/usr/X11R6/lib/modules/extensions"
ModulePath "/usr/X11R6/lib/modules"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "KDS Visual Sensations VS-190is"
DisplaySize 320 270
HorizSync 30.0 - 96.0
VertRefresh 50.0 - 160.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 2 MX (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1600x1200" "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768
" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection



So, can somebody please help me out here? What do I do next? As I mentioned, I am quite the newbie still. It took me forever to correctly install the nvidia drivers, and I honestly dont even remember everything I did. Any help here is GREATLY appreciated.

Thanks,
 
Old 03-11-2004, 09:41 AM   #2
forrestt
Senior Member
 
Registered: Mar 2004
Location: Cary, NC, USA
Distribution: Fedora, Kubuntu, RedHat, CentOS, SuSe
Posts: 1,288

Rep: Reputation: 99
My suggestion is to get back to a command line and reinstall the nvidia drivers. Here are the instructions from the nvidia site:

To download and install the drivers, follow the steps below:

STEP 1: Review the NVIDIA Software License. You will need to accept this license prior to downloading any files.

README - Text Version

STEP 2: Download the Driver File
Download - NVIDIA-Linux-x86-1.0-5336-pkg1.run

SuSE users: please read the SuSE NVIDIA Installer before downloading the driver.

STEP 3: Install
Type "sh NVIDIA-Linux-x86-1.0-5336-pkg1.run" to install the driver, then edit your X86Config file as appropriate. See the text README for more detailed instructions.

If you have any questions or problems, please check the linux discussion forum. If you don't find an answer to your question there, you can send email (in English) to linux-bugs@nvidia.com.

If you have wget installed, you can get the driver by typing:

% wget htttp://download.nvidia.com/XFree86/Linux-x86/1.0-5336/NVIDIA-Linux-x86-1.0-5336-pkg1.run

Hope this helps,

Forrest
 
Old 03-11-2004, 12:20 PM   #3
jeffreybluml
Member
 
Registered: Mar 2004
Location: Minnesota
Distribution: Fedora Core 1, Mandrake 10
Posts: 405

Original Poster
Rep: Reputation: 30
Unhappy still nothing...

Thanks for the quick reply forrest. I used wget to d.l. the driver...no problems there. (I should mention I was doing all this from work via ssh)

cd'd to the directory where the new driver is, su'd to root and chmod'd the file to 777, and typed sh NVIDIA....blah blah blah.

Hit enter and it returned immediately, with no messages or confirmations or anything. So, I changed the /etc/inittab runlevel back to 5 and typed reboot. Long story short...

It still looped on the splash screen! Ugh...

Quick question, is there a quicker way to change runlevels from 3 to 5 (and perhaps from 5 to 3) without editing the inittabh file and rebooting?

So, any other ideas?
 
Old 03-11-2004, 12:43 PM   #4
jeffreybluml
Member
 
Registered: Mar 2004
Location: Minnesota
Distribution: Fedora Core 1, Mandrake 10
Posts: 405

Original Poster
Rep: Reputation: 30
whoa, I was on the wrong track it seems

Okay, I just noticed an error message when typing startx from the command line. It had said:

Could not init font path element unix/:7100, removing from list!

Fatal server error:
could not open default font 'fixed'


So I commented out the line

#FontPath "unix/:7100"

in XF86Config and typed startx. Now, the splash screen comes on for only a moment (as it used to) and then it goes the the black X cursor that you see when booting right before you see the boot progress. I almost jumped out of my seat, as I though it was fixed. But after about two seconds it went back to command line, and shows the following error:

Could not init font path element /usr/X11R6/lib/X11/fonts/Speedo/, removing from list!

/root/.Xclients: line 8: /root/.Xclients-default: No such file or directory
/root/.Xclients: line 8: exec: /root/.Xclients-default: cannot execute: No such file or directory

So, what does this tell you anything? I think I will start a new thread with this subject, but feel free to reply to either.

Thanks!
 
Old 03-11-2004, 01:16 PM   #5
flyfishin
Member
 
Registered: Aug 2003
Location: KC, MO
Distribution: CentOS, RHEL, SuSE, Fedora
Posts: 243

Rep: Reputation: 30
You mentioned that you have upgraded your kernel but didn't mention anything about recompiling the nvidia drivers. You have to redo rerun the nvidia-installer script and recreate the kernel modules each time you upgrade your kernel. When you say you upgraded your kernel twice and it all worked I'm assuming that you rebooted after upgrading/updating your kernel? Since you are using the nvidia-installer from nvidia it wants the kernel source installed so it can create its own modules. Do you have the kernel source installed? If you have the kernel source installed and currently have nvidia drivers installed you should be able to type nvidia-install --update as root at a command prompt and it should run you through the process and indicate a success at the end of the process.
 
Old 03-11-2004, 01:38 PM   #6
jeffreybluml
Member
 
Registered: Mar 2004
Location: Minnesota
Distribution: Fedora Core 1, Mandrake 10
Posts: 405

Original Poster
Rep: Reputation: 30
fixed!

Thanks for helping everyone.

It turns out it was related either to the font path element or the "/root/.Xclients: line 8: /root/.Xclients-default: No such file or directory" error, because I commented out the 'FontPath "unix/:7100" ' from the XF86Config file, and copied my existing .Xclients-localhost..... file to .Xclients-default and EVERYTHING is fine again!!

Still dont understand what happened to cause all this, or what "all this" even was about, but for now I'm glad it's fixed.

This forum is such a great resource! What a lifesaver it has been for a guy trying to dump windows, but who has NO programming experience. Thanks to all!
 
Old 03-11-2004, 02:08 PM   #7
forrestt
Senior Member
 
Registered: Mar 2004
Location: Cary, NC, USA
Distribution: Fedora, Kubuntu, RedHat, CentOS, SuSe
Posts: 1,288

Rep: Reputation: 99
Quick question, is there a quicker way to change runlevels from 3 to 5 (and perhaps from 5 to 3) without editing the inittabh file and rebooting?

From a command line:

% /sbin/init <run-level>

Where <run-level> is the level you want to go to.

Hope this helps,

Forrest
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to change the nvidia logo splash screen Furlinastis Linux - Software 4 11-24-2006 09:20 PM
9.3 Nvidia No Splash Screen CPU3000 Suse/Novell 9 11-08-2005 11:21 AM
nvidia splash screen and kde davidsrsb Slackware 2 12-22-2004 08:44 AM
Removing Nvidia splash screen... DraaX Linux - Software 3 11-28-2004 03:42 PM
X server hangs on nvidia splash screen Rnd227 Mandriva 3 11-23-2004 07:14 AM


All times are GMT -5. The time now is 10:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration