LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   Fedora very slow..... (http://www.linuxquestions.org/questions/fedora-35/fedora-very-slow-127440/)

noviceuser 12-19-2003 10:24 PM

Fedora very slow.....
 
Hello,

Just installed my first linux os, just because I was curious. I know the machine I installed on does not perfectly fit the requirements, but its the only spare machine I have. Its an AMD K62 350mhz, 256mb pc100sdram, Diamond viper 550, 5gb hdd. Built it in 98.

Installed Fedora, and for some reason its very, very slow. Opening Mozilla, from the click to the window being open takes approximately 5 minutes. A little on the ridiculous side.

I checked system resources, and found that with nothing open, 240mb of memory is used. Is this normal? Are there any processes that I can terminate to free up memory? Or do I just need to install on a pentium based system?

Thanx in advance,


Tod

Thetargos 12-19-2003 11:59 PM

The system will always cache to memory as much data as possible to have it readily available. The problem (the way I see it) is that you have a very limited processor for the GUI FC1 has (GNOME 2.4 & KDE 3.1) you could overcome this problem with a light weight GUI like fluxbox, blackbox, Xface or ICE. It would be comparable to running WinXP on a 450-500 Mhz machine...

ferossandon 12-23-2003 07:02 PM

Not agree, I am jsut runing a K6 - 233Mhz (not K6-2) with only 128Mb ram under Gnome dafult GUI and Mozilla takes just 4 seconds to be ready.
Something else must be happening in your system.

F.

wiraone 12-24-2003 04:48 AM

Quote:

Originally posted by ferossandon
Not agree, I am jsut runing a K6 - 233Mhz (not K6-2) with only 128Mb ram under Gnome dafult GUI and Mozilla takes just 4 seconds to be ready.
Something else must be happening in your system.

F.

You kidding me .. even my AMD Athlon 1700+ with 768MB RAM takes more than 30 seconds to be ready. Oh yes, I do have network card and some other services running.

Skyline 12-24-2003 09:51 AM

As Thetargos mentioned - use a lighter WM - and yes, there's probably lots of uneeded services - after a quick Google for descriptions - in an xterm, su to Root user with

su -

(su with a space then a dash)

root password

then

chkconfig --list | grep 5:on

to see which services are set to start in graphical mode - and then to stop a service from starting ( for example)

chkconfig httpd off

moravia 12-24-2003 04:10 PM

It shouldn't be *that* slow! I have an AMD K6-2 350 w/ 256 MB RAM also. Opening Mozilla is slower than it was before I upgraded to Fedora, but I haven't bothered troubleshooting (it could just be the new GUI.) I haven't timed it, but I'm sure it's less than one minute to load.

I was just about to append a complaint about slow menus, but I see that is no longer a problem.

So instead of "me too" I ask what kernel you are running? I just noticed I wasn't running the latest kernel I had installed (which I now realize isn't even the latest) so I rebooted. It's much faster now!

Old: kernel-2.4.22-1.2115.nptl
Current: kernel-2.4.22-1.2129.nptl
Next: kernel-2.4.22-1.2135

wiraone 12-24-2003 05:44 PM

Opss.. I guess I misunderstood the 2nd poster .. firing Mozilla surely takes less than 4 secs .. was talking about from booting up until the desktop is ready may take more than 30 secs.

jcouball 12-28-2003 05:42 PM

Tod:

I have seen this happen when networking is not configured correctly... everything takes forever to load (not just Mozilla as you have mentioned)... I can't remember exactly what was my problem, but I think it was either my gateway or dns was not configured correctly.

Good luck.

James.

Shade 12-30-2003 09:53 PM

It's the hostname setting, and I haven't found a way around it.

Changing the hostname to anything but localhost.localdomain killed gnome for my fedora setup, and I couldn't really find a way around it.

Even adding the IP (booth loopback at 127.0.0.1 or my real IP) to the resolv.conf file didn't fix it.

Strange problem, because I Hated seeing "user@localhost" in the prompt and not being able to change localhost the normal way without my gui being all whacked out !

-Shade

MiscGeek 01-09-2004 06:01 AM

Quote:

Originally posted by Shade
It's the hostname setting, and I haven't found a way around it.

Changing the hostname to anything but localhost.localdomain killed gnome for my fedora setup, and I couldn't really find a way around it.

Even adding the IP (booth loopback at 127.0.0.1 or my real IP) to the resolv.conf file didn't fix it.

Strange problem, because I Hated seeing "user@localhost" in the prompt and not being able to change localhost the normal way without my gui being all whacked out !

-Shade

You don't want to replace the localhost.localdomain entry in host that will cause you all kinds of problems as you've found out :)

Just add a new host name after localhost.localdomain like so...

127.0.0.1 localhost.localdoman <newhostname>

You can then set your hostname to <newhostname> and all prompts etc.. that use hostname will use your new host name.

friendly_guy 01-09-2004 05:07 PM

Quote:

Just installed my first linux os, just because I was curious.
Distro's like Fedora are easier to install. When you get the hang of linux a bit try Slackware. It runs really well on slower machines (like my P2 400Mhz). At the mo I have Fedora on my faster machine & Slack on the slower one.

beatupbilly 01-10-2004 03:06 PM

Just multi-partition on your primary pc and try Linux on that. Also be sure to check your DMA settings. If Fedora set everything to PIO mode that would explain why its running slow. Did you install everything? that would mean your HD is almost full which would also limit performance. Did you automatically partition? reinstall and repartion and be sure to use at least 500MB for a swap. Good luck!

beatupbilly 01-10-2004 03:09 PM

Also, why don't you check out a distro called Knoppix. It runs completely from CD. This way you can get the maximum space out of your HD. I run it sometimes. Good look and feel. Anyways that's all. (Incidentally, you can run the knoppix CD on any pc including your windows box without altering your partition. Oh and if you choose to have a dual boot machine, use Partition magic 8.0 which you can find on Kazaa Lite (48.9Mb))


:D:rolleyes: :jawa: :jawa: :rolleyes: :D


All times are GMT -5. The time now is 06:01 PM.