LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
LinkBack Search this Thread
Old 04-05-2010, 08:26 PM   #1
foottuns
Member
 
Registered: Nov 2009
Location: London
Distribution: Fedora 16
Posts: 92

Rep: Reputation: 17
fedora Packages skipped because of dependency problems: rpmforge error


Hello there, i have a problem with rmpforge repo, as you can see i run "yum update --skip broken" command and i got this output, i cannot update my system because rpmforge is not working,

what should i do now? how i can update my system?

i have a problem wu
Code:
Packages skipped because of dependency problems:
    libICE-devel-1.0.6-1.fc12.i686 from fedora
    libSM-devel-1.1.0-7.fc12.i686 from fedora
    libXdamage-devel-1.1.2-1.fc12.i686 from fedora
    libXt-devel-1.0.7-1.fc12.i686 from fedora
    libXv-devel-1.0.5-1.fc12.i686 from fedora
    libXvMC-devel-1.0.4-8.fc12.i686 from fedora
    libXxf86vm-devel-1.1.0-1.fc12.i686 from fedora
    libdrm-devel-2.4.17-1.fc12.i686 from updates
    libdvdcss-1.2.10-1.el5.rf.i386 from rpmforge
    libfame-0.9.1-14.fc11.i586 from rpmfusion-free
    mesa-libGL-devel-7.7-4.fc12.i686 from updates
    mesa-libGLU-devel-7.7-4.fc12.i686 from updates
    x264-0.0.0-0.26.20091026gitec46ace7.fc12.i686 from rpmfusion-free
    xine-lib-1.1.18.1-1.el5.rf.i386 from rpmforge
    xine-lib-devel-1.1.18.1-1.el5.rf.i386 from rpmforge
 
Old 04-06-2010, 12:55 AM   #2
DCOH
Member
 
Registered: Oct 2006
Location: Ohio
Distribution: Fedora 13/14/15KDE/PclinuxOS
Posts: 95

Rep: Reputation: 16
Fedora doesn't use RPMFORGE it uses rpmfusion-free and rpmfusion-non-free
 
Old 04-06-2010, 03:38 AM   #3
Glennzo
Member
 
Registered: May 2003
Location: Salem, Mass USA
Distribution: Fedora
Posts: 389

Rep: Reputation: 46
As a temporary solution try
Code:
su -c 'yum --disablerepo=rpmforge update'
To permanently disable the rpmforge repo open /etc/yum.repos.d/rpmforge.repo, find enabled=1 and change it to enabled=0, or just delete the file from the disk.
 
Old 04-06-2010, 07:38 AM   #4
foottuns
Member
 
Registered: Nov 2009
Location: London
Distribution: Fedora 16
Posts: 92

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by Glennzo View Post
As a temporary solution try
Code:
su -c 'yum --disablerepo=rpmforge update'
To permanently disable the rpmforge repo open /etc/yum.repos.d/rpmforge.repo, find enabled=1 and change it to enabled=0, or just delete the file from the disk.


I have used your command and I got this output now, In the end I deleted the file from my harddisk but I still have to update system. Also if I run the update, I get this error too..

"No transaction to process"

I really don't know what is this.....

Any clues how to sort this error?

Thanks.

Code:
[root@localhost bogdan]# yum --disablerepo=rpmforge update
Loaded plugins: changelog, presto, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: libx264.so.68 for package: libquicktime-1.1.4-1.el5.rf.i386
---> Package x264.i686 0:0.0.0-0.26.20091026gitec46ace7.fc12 set to be updated
--> Finished Dependency Resolution
Error: Package: libquicktime-1.1.4-1.el5.rf.i386 (@rpmforge)
           Requires: libx264.so.68
           Removing: x264-0.0.0-0.4.20090708.el5.rf.i386 (@rpmforge)
 You could try using --skip-broken to work around the problem
msttcorefonts-2.0-1.noarch has missing requires of /usr/sbin/chkfontpath

Last edited by foottuns; 04-06-2010 at 07:40 AM.
 
Old 04-07-2010, 03:51 AM   #5
Glennzo
Member
 
Registered: May 2003
Location: Salem, Mass USA
Distribution: Fedora
Posts: 389

Rep: Reputation: 46
What does yum repolist show now?
Code:
yum repolist
You can try
Code:
yum --exclude=libquicktime* update
How does one manage to enable the rpmforge repositories for something like Fedora 12 ???

Last edited by Glennzo; 04-07-2010 at 04:18 AM.
 
Old 04-07-2010, 07:54 PM   #6
foottuns
Member
 
Registered: Nov 2009
Location: London
Distribution: Fedora 16
Posts: 92

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by Glennzo View Post
What does yum repolist show now?
Code:
yum repolist
You can try
Code:
yum --exclude=libquicktime* update
How does one manage to enable the rpmforge repositories for something like Fedora 12 ???
when i run the yum repolist i got this


Code:
[root@localhost bogdan]# yum repolist
Loaded plugins: changelog, presto, refresh-packagekit
repo id                    repo name                                      status
adobe-linux-i386           Adobe Systems Incorporated                         17
fedora                     Fedora 12 - i386                               15,366
livna                      rpm.livna.org for 12 - i386                         3
rpmfusion-free             RPM Fusion for Fedora 12 - Free                   383
rpmfusion-free-updates     RPM Fusion for Fedora 12 - Free - Updates         831
rpmfusion-nonfree          RPM Fusion for Fedora 12 - Nonfree                124
rpmfusion-nonfree-updates  RPM Fusion for Fedora 12 - Nonfree - Updates      345
skype                      Skype Repository                                    1
updates                    Fedora 12 - i386 - Updates                      5,590
repolist: 22,660
When I run the other command which I will exclude the quicktime update I got this error

Code:
[root@localhost bogdan]# yum --exclude=libquicktime* update
Loaded plugins: changelog, presto, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: libx264.so.68 for package: libquicktime-1.1.4-1.el5.rf.i386
---> Package x264.i686 0:0.0.0-0.26.20091026gitec46ace7.fc12 set to be updated
--> Finished Dependency Resolution
Error: Package: libquicktime-1.1.4-1.el5.rf.i386 (@rpmforge)
           Requires: libx264.so.68
           Removing: x264-0.0.0-0.4.20090708.el5.rf.i386 (@rpmforge)
 You could try using --skip-broken to work around the problem
msttcorefonts-2.0-1.noarch has missing requires of /usr/sbin/chkfontpath
[root@localhost bogdan]#
This is after I remove the rpmforge repo, before I remove it I had 3 updates now I have only one....


Thanks.

Regards Dan,
 
Old 04-07-2010, 08:33 PM   #7
John VV
Guru
 
Registered: Aug 2005
Posts: 12,081

Rep: Reputation: 1575Reputation: 1575Reputation: 1575Reputation: 1575Reputation: 1575Reputation: 1575Reputation: 1575Reputation: 1575Reputation: 1575Reputation: 1575Reputation: 1575
it looks like you fell into the "rmpforge" TRAP
if you use that then YOU CAN ONLY use it
you can not use the standard fedora repo
THIS is very well documented in the fedora docs

remove ALL rf rpm's then try "yum clean all" and " rpm --rebuilddb "

now "some" rpm's from rf will not kill fedora but -- this is a big but
There is NO way to tell what ones .It is a crap shoot .
 
Old 04-08-2010, 12:30 PM   #8
foottuns
Member
 
Registered: Nov 2009
Location: London
Distribution: Fedora 16
Posts: 92

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by John VV View Post
it looks like you fell into the "rmpforge" TRAP
if you use that then YOU CAN ONLY use it
you can not use the standard fedora repo
THIS is very well documented in the fedora docs

remove ALL rf rpm's then try "yum clean all" and " rpm --rebuilddb "

now "some" rpm's from rf will not kill fedora but -- this is a big but
There is NO way to tell what ones .It is a crap shoot .

thanks, I will try to do that and let u know what happen....

regards dan,
 
Old 04-23-2010, 02:15 PM   #9
foottuns
Member
 
Registered: Nov 2009
Location: London
Distribution: Fedora 16
Posts: 92

Original Poster
Rep: Reputation: 17
thanks for your help... it did help me out.

regards dan,
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 11 Missing Dependency issue with rpmforge guysmiley Linux - Software 17 11-17-2009 01:40 AM
freeNX should have dependency with xorg-x11-fonts* packages in fedora 10 adadxbus Linux - Desktop 0 12-09-2008 01:14 PM
Dependency Problems in Fedora 8 brisbin33 Linux - Software 5 03-26-2008 05:26 PM
Building "no development" LFS - which packages can be skipped? midiox Linux From Scratch 1 05-16-2006 03:35 PM
Up2date packages flagged to be skipped 60s TV Batman Fedora 2 04-04-2005 01:54 AM


All times are GMT -5. The time now is 07:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration