LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 11-20-2003, 09:23 AM   #1
jmboris
LQ Newbie
 
Registered: Aug 2003
Location: spain
Distribution: Red hat 9/fedora 1
Posts: 4

Rep: Reputation: 0
Angry fedora+nvidia=i lost my console


hi;

i have fedora core 1 and i did install nvidia drivers.
the problem is that i ctrl+alt+f1 y dont see anything, my console has gone!!!!!!!!!!
then i alt+f7 and i return to graphic mode, and works perfect!!!!!!!!
can anybody help me to rescue my console ...

look this

[root@localhost jmboris]# glxinfo | grep OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce4 MX 440/AGP/SSE/3DNOW!
OpenGL version string: 1.4.0 NVIDIA 44.96
OpenGL extensions:
--------------------------------------
athlon 1600+
ecs k7s5a (motherboard)
fedora core 1
512 mb Ram
40 gb HD
geforce 4 mx440


thanks
 
Old 11-20-2003, 11:45 AM   #2
aqoliveira
Member
 
Registered: Dec 2001
Location: Portugal
Distribution: /Red Hat/Fedora/Solaris
Posts: 620

Rep: Reputation: 30
Howzit

Under a console in your GUI enviroment check /etc/inittab file and see if u have the following entries.

# Run gettys in standard runlevels

1:2345:respawn:/sbin/mingetty tty1
1:2345:respawn:/sbin/mingetty tty2
1:2345:respawn:/sbin/mingetty tty3
1:2345:respawn:/sbin/mingetty tty4
1:2345:respawn:/sbin/mingetty tty5
1:2345:respawn:/sbin/mingetty tty6

I this is OK try disabling your Gui mode and enter into text mode to see if everything is OK if u unable to runlevel 3 then your inittab file is corrupt and needs replacing.

To change to runlevel change /etc/inittab line id:5:initdefault: change 5 to 3.

Give these things a bash

chow
 
Old 11-20-2003, 03:18 PM   #3
jmboris
LQ Newbie
 
Registered: Aug 2003
Location: spain
Distribution: Red hat 9/fedora 1
Posts: 4

Original Poster
Rep: Reputation: 0
i think is resolution my problem

when i start linux i can see console, then automatically goes to graphic mode, then when i ctrl+alt+f1 (to go to console) i can not see anything...i alt+f7 and go back to graphic mode...

i think its something whit console resolution .but why ar the start the resolution it ok??

thanks

# Run gettys in standard runlevels
1:2345:respawn:/sbin/mingetty tty1
2:2345:respawn:/sbin/mingetty tty2
3:2345:respawn:/sbin/mingetty tty3
4:2345:respawn:/sbin/mingetty tty4
5:2345:respawn:/sbin/mingetty tty5
6:2345:respawn:/sbin/mingetty tty6

# Run xdm in runlevel 5
x:5:respawn:/etc/X11/prefdm -nodaemon
 
Old 11-20-2003, 05:30 PM   #4
aqoliveira
Member
 
Registered: Dec 2001
Location: Portugal
Distribution: /Red Hat/Fedora/Solaris
Posts: 620

Rep: Reputation: 30
howzit

did u try changing the runlevels from 3 to 5 and in your lilo or grub have u set a ftrame buffer of some sort?

chow
 
Old 12-03-2003, 07:06 AM   #5
nexx_au
Member
 
Registered: Dec 2003
Distribution: Fedora Core 1
Posts: 69

Rep: Reputation: 15
i have this exact same problem, it happend after i installed some older nvidia drivers because i thought the latest ones were causing games to crash. Now i cant get back to text mode to install different drivers!

im pretty sure the console is still there, but my monitor says 'frequency over range' so perhaps some setting is giving me the wrong resolution/refresh rate and my monitor is unable to display it.
 
Old 12-03-2003, 07:16 AM   #6
nexx_au
Member
 
Registered: Dec 2003
Distribution: Fedora Core 1
Posts: 69

Rep: Reputation: 15
ok i did what aqoliveira said and was able to boot in text mode and install the latest drivers. Now to get my games running at anything higher than 640x480 hehe..

thanks.
 
Old 12-04-2003, 04:19 PM   #7
jmboris
LQ Newbie
 
Registered: Aug 2003
Location: spain
Distribution: Red hat 9/fedora 1
Posts: 4

Original Poster
Rep: Reputation: 0
i resolve it using ....

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 (generic)"
Option "IgnoreDisplayDevices" "TV"
EndSection


see the ignoreDisplay line, that is the clue to recover the console.....


i hope it helps....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
nVidia TV out w/ X = unreadable console KPOM Linux - General 1 10-24-2005 11:15 AM
Cosmetic feature lost in the console Influx Slackware 1 10-02-2005 05:25 PM
Nvidia Drivers lost everytime I reboot? vidski Debian 2 01-17-2005 01:38 AM
NVIDIA and console stevemad Slackware 4 12-29-2004 05:40 PM
a bit lost with nvidia 3d support... yanik Fedora 5 01-23-2004 01:53 PM


All times are GMT -5. The time now is 10:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration