LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 12-02-2006, 04:04 PM   #1
fdahl_009
Member
 
Registered: Oct 2005
Location: NORWAY
Posts: 144

Rep: Reputation: 16
Fedora Core 6 and samba


Hi all!

I am trying to mount an sambashare from my fc6 computer.
The sambashare is served by an slackware server.
The share is user / password protected.

When mounting the share from an another slack computer I use this command as root:

mount -t smbfs -o username=xxx,password=xxx //ipaddr/share /home/user/mountpoint

In slack it askes for an another password confirmation, that is the password for the share.
Because I am not allowed to run mount as regular user I made an script that does this as root and because of the username and password option for samba it mounts it all correctly. But here comes fedora 6!

First of all, not allowed to run the command as regular user, ok.
Then, not any filesystem as smbfs it states, ok, trying cifs instead.
Ok, that mounts but now I can only view / write to the root of the share (as regular user), not in any of the underlaying folders..

Anyone got ideas for how to get this working?

EDIT:
I did try an chmod 777 /bin/mount now. That only changed the errormessage to must be super user

How can I get the right permissions back for this file?

Last edited by fdahl_009; 12-02-2006 at 04:17 PM.
 
Old 12-29-2006, 06:29 AM   #2
dombrowsky
Member
 
Registered: Dec 2005
Location: New York
Distribution: Debian/GNU
Posts: 235

Rep: Reputation: 31
your last question doesn't make much sense. Permissions back for _what_ file?

For the issues you're having with samba, good luck. Setting up a read-only samba share is easy; setting up a read-write samba share that you can only write to as root, is not very difficult; setting up read-write samba share that any user can write to with a user-mapping between linux and windows-share users without a domain controller? IMPOSSIBLE.

If this is just your desktop, either start hacking, or deal with having to 'su' to root every time you need to write to a share.
 
Old 12-29-2006, 07:41 AM   #3
fdahl_009
Member
 
Registered: Oct 2005
Location: NORWAY
Posts: 144

Original Poster
Rep: Reputation: 16
The file for the permission question is
Code:
/bin/mount
, sorry for the "now" after..

But it does not matter, this works without any problems in slackware 11, so I switched back to slack..

But, why does this command not work in fedora 6?

Code:
mount -t smbfs -o username=xxx,password=xxx //ipaddr/share /home/user/mountpoint
Even changing it to cifs instead of smbfs did not work..

The sambashare is mapped with an user and pass. When mounting this in slack with the correct user / pass I do get writepermissions for the folder this is mounted to (the share).

But when mounting it in fedora 6, I do not get write permissions for the mount, even still I have spessified user / pass for the share.. This is something I found a bit strange, but, it works in slack 11, so I do not see any reason to continiue working on this with fedora 6!
 
Old 12-29-2006, 10:16 AM   #4
dombrowsky
Member
 
Registered: Dec 2005
Location: New York
Distribution: Debian/GNU
Posts: 235

Rep: Reputation: 31
1) I don't know what CIFS is. That's some filesystem I've never heard of. It probably doesn't have anything to do with what we're doing here.

2) slackware, as I understand, is a pretty insecure and shakey operating system if its not configured correctly. They have pretty lax rules for setuid executables and other things, which may explain why this worked in slackware and not in fedora core. But this is not a feature of slackware, its a bug.

3) looking at my system, my /bin/mount is setuid root, so you may have broken it when you did 'chmod 777 /bin/mount'. You can fix that with this command (assuming /bin/mount is owned by root):

# chmod 4755 /bin/mount
# ls -l /bin/mount
-rwsr-xr-x 1 root root 77120 Nov 3 22:47 /bin/mount

(note the 's')

after that try mounting the share again. If it works and you get read/write access to the share as root, then you're at square one. You'll then have to figure out how to get the user access correct later.
 
Old 12-29-2006, 10:57 AM   #5
fdahl_009
Member
 
Registered: Oct 2005
Location: NORWAY
Posts: 144

Original Poster
Rep: Reputation: 16
Hmm.. Do not understand this..

If I use "smb://ipaddr/share" then it askes for an user / pass, when I input that correctly I get access..

I want fc6 to have that access for the same user, but in an folder in the users "home"

I can then use the "copy-to" command via kde-rightclick to move files around.. (to the share!)
 
Old 01-21-2007, 01:12 PM   #6
fraz
Member
 
Registered: Nov 2004
Location: Edinburgh, Scotland
Distribution: Ubuntu
Posts: 148

Rep: Reputation: 15
I'm having problems with fedora core 6 and samba shares too.
It is only "samba" shares, i.e. shares coming from a linux machine running a samba server and not a windows machine. As smbfs has been replaced with CIFS (common internet file system for dombrowsky) in the mount command in fedora there are issues. The cifs mounter works fine with windows but not samba servers it would seem.
Use of smbclient allows connection to samba servers and in my case the samba server is a NAS HDD so I can't simply chose another distro for it. It's very frustrating and all because the fedora guys thought cifs was working perfectly, as far as I can tell it's not!
 
Old 01-21-2007, 02:39 PM   #7
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Check to see if an SELinux problem in FC. Try

setenforce 0

to turn in off, and

setenforce 1

to turn it back on. If SELinux is the problem, you can turn it off for ambd in security settings
 
Old 01-21-2007, 03:03 PM   #8
fraz
Member
 
Registered: Nov 2004
Location: Edinburgh, Scotland
Distribution: Ubuntu
Posts: 148

Rep: Reputation: 15
I never use SELinux, causes too many problems for me
 
Old 01-26-2007, 01:09 PM   #9
toracat
LQ Newbie
 
Registered: Nov 2003
Location: California, US
Distribution: RHEL/Scientific Linux/CentOS
Posts: 6

Rep: Reputation: 2
cifs bugs are being worked on by samba/cifs programmers. At least one known bug was fixed recently. But it will take a while before the patch is included in Fedora kernels. If you don't mind compiling the kernel, you can apply the patch to your running kernel to get going. See this Bugzilla:

https://bugzilla.redhat.com/bugzilla....cgi?id=211672
 
  


Reply

Tags
chmod, mount, permissions, samba


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Core 5, Samba and Windows 98 lbclinux Linux - Networking 1 05-28-2006 10:04 AM
Samba in Fedora Core 4 arew264 Linux - Networking 5 10-27-2005 04:28 PM
samba and fedora core 2 l32 Linux - Networking 5 08-28-2004 11:17 AM
samba and fedora core icone Linux - Networking 3 06-15-2004 01:39 PM
Samba And Fedora Core 2 ikenbonnie Linux - Newbie 5 06-05-2004 11:29 AM


All times are GMT -5. The time now is 03:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration