LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   Fedora Core 5 on Dell Poweredge 700 xserver/display crashing (http://www.linuxquestions.org/questions/fedora-35/fedora-core-5-on-dell-poweredge-700-xserver-display-crashing-531202/)

loopy69 02-21-2007 10:42 PM

Fedora Core 5 on Dell Poweredge 700 xserver/display crashing
 
Hi,

I have a Dell Poweredge 700 setup as a fully fledged mail server.

After the machine is booted and the display has been up awhile, the screen will go black (with the monitor still seeing a signal) but the machine keeps working.

I had a hunch that the power management might be involved so I turned all the power options off in gnome. I've tried disabling ACPI in the bios but the bios doesn't give me the option.

The kernel I am running is 2.6.18-1.2257.fc5smp.

Does anyone have an idea how to fix this? I can still ssh into the box but I would like to solve the problem.

Thanks,
Brett

mjmwired 02-23-2007 06:13 PM

Did you try booting with noacpi or acpi=no ?

Curious: what type of video card is it?

loopy69 02-25-2007 05:00 AM

Good suggestion
 
No I haven't and I'm not sure how to do so.

Do I stop grub and supply the option there? If that works how can I set the flag for future boots?

Thanks

mjmwired 02-25-2007 10:52 AM

Here are the kernel parameters I was referring to:
kernel-parameters.txt

When you see grub, scroll to the kernel you wish to boot. Hit 'e', then scroll to the kernel line, and attach the parameter at the end of the line. Hit, enter, then 'b' to boot that.

If you wish to make these changes permanent. Edit '/boot/grub/grub.conf' and make the edits to the proper line.

Did you check your logs to see if they reveal any clues?

loopy69 02-25-2007 03:48 PM

kernel options setup
 
OK I have passed acpi=off to the kernel and will monitor how the server goes.

I did check the logs around the time of a crash and couldn't find anything related to the Xorg server or power management.

Fingers crossed we'll see if the acpi option stops it crashing...

Thanks,
Brett

loopy69 02-25-2007 05:15 PM

Video still died
 
Unfortunately the video still died and the acpi=off option did not fix the problem. The type of video card is an Embedded ATI Rage XL with 8MB memory (straight from the Dell poweredge 700 specs).

I scoured the logs and found this in /var/log/gdm/:0.log

X Window System Version 7.0.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 7.0
Build Operating System:Linux 2.6.9-34.ELsmp i686Red Hat, Inc.
Current Operating System: Linux mailserv.iii.net.au 2.6.18-1.2257.fc5smp #1 SMP Fri Dec 15 16:33:51 EST 2006 i686
Build Date: 09 January 2007
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Feb 26 08:47:04 2007
(==) Using config file: "/etc/X11/xorg.conf"
FATAL: Module mach64 not found.
[drm] failed to load kernel module "mach64"
(EE) ATI(0): [dri] DRIScreenInit Failed

All these messages are present on bootup and before the video crashes.

Since its a onboard video card I thought I'd check the BIOS version, the machine is running Dell's A00 and there is a A06 version available off dell.com.

I have applied the BIOS upgrade and will see how that goes, I have removed the acpi option as well...

Thanks,
Brett

loopy69 02-25-2007 07:36 PM

No luck
 
The problem still happens so I am at an odds as to how I could fix it.

loopy69 02-27-2007 08:52 PM

Seems fixed at the moment
 
I'll hold my breath but the problem appears to be fixed.

In system -> preferences -> screensaver I disabled 'activate screensaver when session is idle' to turn off the screensaver all together.

Apparently the screensaver was causing the problems to occur as I have not yet seen it crash for a day and a half. This is much longer than before and I'm hopeful the problem wont happen again.

Hope this helps someone else!

Brett


All times are GMT -5. The time now is 06:53 AM.