LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 10-29-2005, 08:53 AM   #1
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Rep: Reputation: 47
Fedora Core 4 --Package manager crashes.


Whenever I try to install any software, the Package Manager crashes after I put in a New CD.

Whenever I try to install Packages using the Add/Remove Applications option, then usually, the installation wants more than One cd.

So when I put in a new CD, the package manager crashes!!
I simply closes down. No errors or anything.


Why is that?
Any bug?
 
Old 10-29-2005, 10:56 AM   #2
jcliburn
Member
 
Registered: Dec 2003
Location: Mississippi, USA
Distribution: Fedora
Posts: 435

Rep: Reputation: 33
I'm not quite sure what you're trying to do. (1) Are you attempting to install base packages from the distribution CDs? (2) Or are you trying to install new packages you downloaded from somewhere and burned to a CD? (3) Or are you trying to install updates to existing packages?

If (1), try running /usr/sbin/system-config-packages from the command line.

If (2), please provide more detail on a particular package you're trying to install (is it an rpm? a tarball? a source package? a shell script?).

If (3), use yum from the command line, or yumex if you prefer a gui.
 
Old 10-29-2005, 11:01 AM   #3
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Original Poster
Rep: Reputation: 47
>Whenever I try to install Packages using the Add/Remove Applications option, then usually, the installation wants more than One cd.

I thought that this refers to ...only installing packages from the Fedora COre CDs.

OK. Just to make it a bit precise.
I want to install the software from the Fedora Core 4 CDs.
But while doing so....the Package manager wants to install from more than a Cd.
So when I insert the next CD...in the specified sequence....Package manager is what suddently disappears.

Last edited by duffmckagan; 10-29-2005 at 11:16 AM.
 
Old 10-29-2005, 11:09 AM   #4
jcliburn
Member
 
Registered: Dec 2003
Location: Mississippi, USA
Distribution: Fedora
Posts: 435

Rep: Reputation: 33
Okay, thanks for the clarification.

Instead of starting system-config-packages (Package Manager) from the menu, try launching it from the command line so you can see any output it might generate to stdout/stderr.
 
Old 10-29-2005, 11:17 AM   #5
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Original Poster
Rep: Reputation: 47
Ok. I will try that.

But I am not in Fedora right now. SO it will take some time.
 
Old 11-02-2005, 09:50 AM   #6
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Original Poster
Rep: Reputation: 47
Okay. Sorry for replying after so long. Unfortunately I did not have time to access Fedora.

I tried accessing the Package management tool from command line saying system-config-packages.

It generated the following output:

Code:
[root@copperskull ~]# system-config-packages
hal devs is {'/dev/hdc': '/media/cdrom'}
* setting Icelandic Support to not installed
* setting ISO8859-9 Support to not installed
* setting Slovak Support to not installed
* setting Malay Support to not installed
* setting Czech Support to not installed
* fonts-korean-0:1.0.11-4.noarch not installed in group Korean Support
* setting Hindi Support to not installed
* setting PostgreSQL Database to not installed
* base references package cryptsetup which doesn't exist
* base references package openCryptoki which doesn't exist
* base references package prctl which doesn't exist
* setting Hungarian Support to not installed
* setting Bulgarian Support to not installed
* setting GNOME to not installed
* fonts-chinese-0:2.15-2.noarch not installed in group Chinese Support
* taipeifonts-0:1.2-26.noarch not installed in group Chinese Support
* eclipse-platform-1:3.1.0_fc-0.M6.22.i386 not installed in group Eclipse
* libswt3-gtk2-1:3.1.0_fc-0.M6.22.i386 not installed in group Eclipse
* setting Turkish Support to not installed
* setting Spanish Support to not installed
* fonts-hebrew-0:0.100-4.noarch not installed in group Hebrew Support
* setting Breton Support to not installed
* setting Finnish Support to not installed
* kdebase-6:3.4.0-5.i386 not installed in group KDE (K Desktop Environment)
* htdig-3:3.2.0b6-5.i386 not installed in group KDE (K Desktop Environment)
* setting Thai Support to not installed
* setting Zulu Support to not installed
* setting Portuguese Support to not installed
* libpng-devel-2:1.2.8-2.i386 not installed in group X Software Development
* xorg-x11-devel-0:6.8.2-31.i386 not installed in group X Software Development
* libungif-devel-0:4.1.3-3.i386 not installed in group X Software Development
* gd-devel-0:2.0.33-2.i386 not installed in group X Software Development
* libjpeg-devel-0:6b-34.i386 not installed in group X Software Development
* freetype-devel-0:2.1.9-2.i386 not installed in group X Software Development
* netpbm-devel-0:10.27-3.i386 not installed in group X Software Development
* libmng-devel-0:1.0.9-1.i386 not installed in group X Software Development
* Xaw3d-devel-0:1.5E-4.i386 not installed in group X Software Development
* libtiff-devel-0:3.7.1-6.i386 not installed in group X Software Development
* lockdev-devel-0:1.0.1-7.i386 not installed in group Development Libraries
* krbafs-devel-0:1.2.2-7.i386 not installed in group Development Libraries
* cyrus-sasl-devel-0:2.1.20-5.i386 not installed in group Development Libraries
* gpm-devel-0:1.20.1-71.i386 not installed in group Development Libraries
* pciutils-devel-0:2.1.99.test8-10.i386 not installed in group Development Libraries
* kudzu-devel-0:1.1.116.2-2.i386 not installed in group Development Libraries
* openldap-devel-0:2.2.23-5.i386 not installed in group Development Libraries
* slang-devel-0:1.4.9-17.i386 not installed in group Development Libraries
* db4-devel-0:4.3.27-3.i386 not installed in group Development Libraries
* gmp-devel-0:4.1.4-6.i386 not installed in group Development Libraries
* bzip2-devel-0:1.0.2-16.i386 not installed in group Development Libraries
* python-devel-0:2.4.1-2.i386 not installed in group Development Libraries
* openssl-devel-0:0.9.7f-7.i386 not installed in group Development Libraries
* curl-devel-0:7.13.1-3.i386 not installed in group Development Libraries
* rpm-devel-0:4.4.1-21.i386 not installed in group Development Libraries
* libtermcap-devel-0:2.0.8-41.i386 not installed in group Development Libraries
* zlib-devel-0:1.2.2.2-3.i386 not installed in group Development Libraries
* ncurses-devel-0:5.4-17.i386 not installed in group Development Libraries
* swig-0:1.3.24-2.i386 not installed in group Development Libraries
* dbus-devel-0:0.33-3.i386 not installed in group Development Libraries
* libcap-devel-0:1.10-22.i386 not installed in group Development Libraries
* gdbm-devel-0:1.8.0-25.i386 not installed in group Development Libraries
* readline-devel-0:5.0-3.i386 not installed in group Development Libraries
* krb5-devel-0:1.4-3.i386 not installed in group Development Libraries
* libuser-devel-0:0.53.7-1.i386 not installed in group Development Libraries
* hesiod-devel-0:3.0.2-31.i386 not installed in group Development Libraries
* expat-devel-0:1.95.8-6.i386 not installed in group Development Libraries
* db4-utils-0:4.3.27-3.i386 not installed in group Development Libraries
* dialog-0:1.0.20050306-1.i386 not installed in group Development Libraries
* libusb-devel-0:0.1.10a-1.i386 not installed in group Development Libraries
* newt-devel-0:0.51.6-7.i386 not installed in group Development Libraries
* libxml2-devel-0:2.6.19-1.i386 not installed in group Development Libraries
* pam-devel-0:0.79-8.i386 not installed in group Development Libraries
* gcc-java-0:4.0.0-8.i386 not installed in group Java
* vsftpd-0:2.0.3-1.i386 not installed in group FTP Server
* setting Brazilian Portuguese Support to not installed
* setting Faeroese Support to not installed
* setting Catalan Support to not installed
* setting Engineering and Scientific to not installed
* setting Slovenian Support to not installed
* setting Russian Support to not installed
* qt-devel-1:3.3.4-14.i386 not installed in group KDE Software Development
* kdbg-1:1.2.10-2.i386 not installed in group KDE Software Development
* kdepim-devel-6:3.4.0-4.i386 not installed in group KDE Software Development
* kdesdk-0:3.4.0-3.i386 not installed in group KDE Software Development
* qt-designer-1:3.3.4-14.i386 not installed in group KDE Software Development
* PyQt-devel-0:3.14.1-1.i386 not installed in group KDE Software Development
* kdelibs-devel-6:3.4.0-6.i386 not installed in group KDE Software Development
* kdesdk-devel-0:3.4.0-3.i386 not installed in group KDE Software Development
* sane-backends-devel-0:1.0.15-9.i386 not installed in group KDE Software Development
* cups-devel-1:1.1.23-15.i386 not installed in group KDE Software Development
* cdparanoia-devel-0:alpha9.8-25.i386 not installed in group KDE Software Development
* arts-devel-8:1.4.0-1.i386 not installed in group KDE Software Development
* kdenetwork-devel-7:3.4.0-3.i386 not installed in group KDE Software Development
* kdeutils-devel-6:3.4.0-1.i386 not installed in group KDE Software Development
* kdegraphics-devel-7:3.4.0-2.i386 not installed in group KDE Software Development
* libxslt-devel-0:1.1.14-2.i386 not installed in group KDE Software Development
* sip-devel-0:4.2.1-1.i386 not installed in group KDE Software Development
* kdebase-devel-6:3.4.0-5.i386 not installed in group KDE Software Development
* pilot-link-devel-1:0.12.0-0.pre2.0.i386 not installed in group KDE Software Development
* ruby-libs-0:1.8.2-7.i386 not installed in group Ruby
* ruby-0:1.8.2-7.i386 not installed in group Ruby
* setting Workstation Common to not installed
* setting German Support to not installed
* samba-0:3.0.14a-2.i386 not installed in group Windows File Server
* setting Server to not installed
* compat-libstdc++-296-0:2.96-132.fc4.i386 not installed in group Legacy Software Development
* legacy-software-development references package compat-libstdc++-devel which doesn't exist
* legacy-software-development references package compat-gcc-c++ which doesn't exist
* legacy-software-development references package compat-gcc-295 which doesn't exist
* legacy-software-development references package compat-gcc-296 which doesn't exist
* legacy-software-development references package compat-gcc which doesn't exist
* compat-gcc-32-0:3.2.3-47.fc4.i386 not installed in group Legacy Software Development
* legacy-software-development references package compat-libstdc++ which doesn't exist
* legacy-software-development references package compat-libstdc++-295 which doesn't exist
* legacy-software-development references package compat-libstdc++-32 which doesn't exist
* legacy-software-development references package compat-gcc-c++-32 which doesn't exist
* setting Welsh Support to not installed
* setting Assamese Support to not installed
* inn-0:2.4.2-3.i386 not installed in group News Server
* setting Language Support to not installed
* setting Estonian Support to not installed
* setting Serbian Support to not installed
* setting Ukrainian Support to not installed
* compat-arch-support references package libtool-libs which doesn't exist
* compat-arch-support references package openCryptoki which doesn't exist
* compat-arch-support references package libf2c which doesn't exist
* setting Tamil Support to not installed
* compat-db-0:4.2.52-2.i386 not installed in group Legacy Software Support
* compat-libgcc-296-0:2.96-132.fc4.i386 not installed in group Legacy Software Support
* compat-libstdc++-33-0:3.2.3-47.fc4.i386 not installed in group Legacy Software Support
* legacy-software-support references package compat-pwdb which doesn't exist
* compat-libstdc++-296-0:2.96-132.fc4.i386 not installed in group Legacy Software Support
* setting French Support to not installed
* emacs-0:21.4-5.i386 not installed in group Emacs
* setting Lithuanian Support to not installed
* setting Norwegian Support to not installed
* java-development references package jakarta-commons-daemon which doesn't exist* java-development references package beecrypt-java which doesn't exist
* java-development references package jakarta-commons-daemon-javadoc which doesn't exist
* java-1.4.2-gcj-compat-devel-0:1.4.2.0-40jpp_31rh.i386 not installed in group Java Development
* ant-0:1.6.2-3jpp_8fc.i386 not installed in group Java Development
* libgcj-devel-0:4.0.0-8.i386 not installed in group Java Development
* eclipse-ecj-1:3.1.0_fc-0.M6.22.i386 not installed in group Java Development
* gnome-desktop references package gnome-backgrounds which doesn't exist
* core references package yaboot which doesn't exist
* core references package iprutils which doesn't exist
* core references package elilo which doesn't exist
* core references package s390utils which doesn't exist
* core references package ppc64-utils which doesn't exist
* setting KDE to not installed
* fonts-ISO8859-2-0:1.0-14.noarch not installed in group ISO8859-2 Support
* setting Punjabi Support to not installed
* setting Romanian Support to not installed
* setting Gujarati Support to not installed
* setting Bengali Support to not installed
* fonts-arabic-0:1.5-3.noarch not installed in group Arabic Support
* japanese-support references package jcode.pl which doesn't exist
* fonts-japanese-0:0.20050222-3.noarch not installed in group Japanese Support
* kon2-fonts-0:0.3.9b-26.i386 not installed in group Japanese Support
* kon2-0:0.3.9b-26.i386 not installed in group Japanese Support
* fonts-KOI8-R-100dpi-0:1.0-7.noarch not installed in group Cyrillic Support
* fonts-KOI8-R-0:1.0-7.noarch not installed in group Cyrillic Support
* setting Danish Support to not installed
* setting Dutch Support to not installed
* mysql-0:4.1.11-2.i386 not installed in group MySQL Database
* docbook-utils-0:0.6.14-4.noarch not installed in group Authoring and Publishing
* docbook-simple-0:1.0-2.noarch not installed in group Authoring and Publishing
* tetex-afm-0:3.0-4.i386 not installed in group Authoring and Publishing
* xmlto-0:0.0.18-6.i386 not installed in group Authoring and Publishing
* docbook-slides-0:3.3.1-2.noarch not installed in group Authoring and Publishing
* linuxdoc-tools-0:0.9.21-5.i386 not installed in group Authoring and Publishing* docbook-utils-pdf-0:0.6.14-4.noarch not installed in group Authoring and Publishing
* setting Polish Support to not installed
* setting Italian Support to not installed
* mail-server references package perl-Cyrus which doesn't exist
* setting Swedish Support to not installed
* setting Croatian Support to not installed
* setting Gaelic Support to not installed
* setting British Support to not installed
* setting Indonesian Support to not installed
* setting Greek Support to not installed
* setting Irish Support to not installed
* miscallvars references package anaconda-product which doesn't exist
* miscallvars references package lilo which doesn't exist
* zlib-devel-0:1.2.2.2-3.i386 not installed in group Compatibility Arch Development Support
* glibc-devel-0:2.3.5-10.i386 not installed in group Compatibility Arch Development Support
* xorg-x11-devel-0:6.8.2-31.i386 not installed in group Compatibility Arch Development Support
* ncurses-devel-0:5.4-17.i386 not installed in group Compatibility Arch Development Support
* compat-libf2c-32-0:3.2.3-47.fc4.i386 not installed in group Compatibility Arch Development Support
* compat-libstdc++-296-0:2.96-132.fc4.i386 not installed in group Compatibility Arch Development Support
* libstdc++-devel-0:4.0.0-8.i386 not installed in group Compatibility Arch Development Support
* compat-libstdc++-33-0:3.2.3-47.fc4.i386 not installed in group Compatibility Arch Development Support
* pam-devel-0:0.79-8.i386 not installed in group Compatibility Arch Development Support
* setting Galician Support to not installed
* kannada-support references package openoffice.org-langpack-kn_IN which doesn't exist
* setting Kannada Support to not installed
* gail-devel-0:1.8.3-2.i386 not installed in group GNOME Software Development
* gtk2-devel-0:2.6.7-4.i386 not installed in group GNOME Software Development
* libIDL-devel-0:0.8.5-2.i386 not installed in group GNOME Software Development
* libgnomecanvas-devel-0:2.10.0-1.i386 not installed in group GNOME Software Development
* gnome-vfs2-devel-0:2.10.0-5.i386 not installed in group GNOME Software Development
* libglade2-devel-0:2.5.1-2.i386 not installed in group GNOME Software Development
* libgnomeui-devel-0:2.10.0-1.i386 not installed in group GNOME Software Development
* libbonobo-devel-0:2.8.1-1.i386 not installed in group GNOME Software Development
* glib2-devel-0:2.6.4-1.i386 not installed in group GNOME Software Development
* eel2-devel-0:2.10.0-2.i386 not installed in group GNOME Software Development
* atk-devel-0:1.9.1-1.i386 not installed in group GNOME Software Development
* gtk-doc-0:1.3-2.noarch not installed in group GNOME Software Development
* libxslt-devel-0:1.1.14-2.i386 not installed in group GNOME Software Development
* libbonoboui-devel-0:2.8.1-4.i386 not installed in group GNOME Software Development
* GConf2-devel-0:2.10.0-4.i386 not installed in group GNOME Software Development* ORBit2-devel-0:2.12.1-3.i386 not installed in group GNOME Software Development* libart_lgpl-devel-0:2.3.17-2.i386 not installed in group GNOME Software Development
* pango-devel-0:1.8.1-2.i386 not installed in group GNOME Software Development
* fontconfig-devel-0:2.2.3-13.i386 not installed in group GNOME Software Development
* librsvg2-devel-0:2.9.5-2.i386 not installed in group GNOME Software Development
* libgnome-devel-0:2.10.0-3.i386 not installed in group GNOME Software Development
* httpd-0:2.0.54-10.i386 not installed in group Web Server
* web-server references package struts11-webapps-tomcat5 which doesn't exist
* web-server references package httpd-suexec which doesn't exist
* base-x references package desktop-backgrounds-extra which doesn't exist
* setting Basque Support to not installed
* pkgconfig-1:0.15.0-6.i386 not installed in group Development Tools
* development-tools references package gcc-ppc32 which doesn't exist
* gcc-0:4.0.0-8.i386 not installed in group Development Tools
* redhat-rpm-config-0:8.0.34-1.noarch not installed in group Development Tools
* autoconf-0:2.59-5.noarch not installed in group Development Tools
* development-tools references package pfmon which doesn't exist
* automake-0:1.9.5-1.noarch not installed in group Development Tools
* gcc-c++-0:4.0.0-8.i386 not installed in group Development Tools
* gdb-0:6.3.0.0-1.21.i386 not installed in group Development Tools
* flex-0:2.5.4a-34.i386 not installed in group Development Tools
* libtool-0:1.5.16.multilib2-1.i386 not installed in group Development Tools
* rpm-build-0:4.4.1-21.i386 not installed in group Development Tools
* strace-0:4.5.11-1.i386 not installed in group Development Tools
* bison-0:2.0-6.i386 not installed in group Development Tools
* development-tools references package gcc-c++-ppc32 which doesn't exist
* setting Afrikaans Support to not installed
* setting Legacy Network Server to not installed







selecting already installed package docbook-style-dsssl
selecting already installed package tetex
selecting already installed package docbook-style-xsl
selecting already installed package tetex-xdvi
* using jadetex-0:3.12-13.noarch to satisfy jadetex
* using perl-SGMLSpm-0:1.03ii-16.noarch to satisfy perl-SGMLSpm-1.03ii
* using tetex-dvips-0:3.0-4.i386 to satisfy tetex-dvips
* using tetex-latex-0:3.0-4.i386 to satisfy tetex-latex
* using passivetex-0:1.25-5.noarch to satisfy passivetex-1.11
* using tetex-fonts-0:3.0-4.i386 to satisfy tetex-fonts-3.0
* using xmltex-0:20020625-5.noarch to satisfy xmltex-20000118-4
exception while mounting: (16, 'Device or resource busy')
looking for me in /etc/mtab
dev is: /dev/hdc, where is: /media/cdrecorder
/dev/hda2 / ext3 rw 0 0

/dev/proc /proc proc rw 0 0

/dev/sys /sys sysfs rw 0 0

/dev/devpts /dev/pts devpts rw,gid=5,mode=620 0 0

/dev/shm /dev/shm tmpfs rw 0 0

none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0

sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs rw 0 0

automount(pid2475) /misc autofs rw,fd=4,pgrp=2475,minproto=2,maxproto=4 0 0

automount(pid2511) /net autofs rw,fd=4,pgrp=2511,minproto=2,maxproto=4 0 0

/dev/hdc /media/cdrecorder iso9660 rw 0 0

found it
Moreover, I also tried putting in some software using the Front-end (THE GUI)..

When I put the CD in..it suddenly closed...without giving me any errors, without any warnings at all!

Please help.

All the CDs are fine. (Sha1 sum checked.) and no scratches too. :P
 
Old 11-02-2005, 09:26 PM   #7
kurtdriver
Member
 
Registered: May 2005
Location: Vancouver, Canada
Distribution: Fedora 18, Puppy Linux, various others
Posts: 107

Rep: Reputation: 15
Duff, you might try to do this from the net instead of the cd. Eithor a website or, better yet try yum which does dependancy checking and can install fron the internet. And by using the net you'll get updated packages.
Happy computing Kurt
 
Old 11-02-2005, 10:35 PM   #8
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Original Poster
Rep: Reputation: 47
Yes. I know that. But I was just wondering why the hell does it crash like that!

It is any discovered bug, otherwise, I am gonna report that !
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Package Manager Help agtlewis Linux - General 3 10-06-2005 11:26 AM
fedora core package manager alaios Fedora 1 06-06-2005 05:13 AM
Synaptic package manager on Fedora Core 3 joao_foscarini Linux - Newbie 7 04-20-2005 11:13 AM
Core 2 package manager incompatible with up2date? sdo Fedora 1 07-14-2004 10:37 AM
Package Manager on Fedora core 1 i286 Fedora 10 01-17-2004 04:04 AM


All times are GMT -5. The time now is 10:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration