LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 11-19-2004, 05:48 PM   #1
DrD
Member
 
Registered: Nov 2003
Distribution: Fedora Core 4
Posts: 99

Rep: Reputation: 15
Fedora Core 3 and nVidia drivers - solution (2 part)


This is taken directly from user "pucko" from the nvidia linux forum. I, as well as others, seemed to have a strange issue getting the nvidia drivers to work after a reboot; I followed what he did below, and I got it to work!
Quote:
So I just installed Fedora Core 3 plus the nVidia drivers on my Amd64, and the result was a system that hang on "Configuring kernel parameters.

Here what I did to fix it:

1) Interrupt Grub from booting, edit the bootparameters with "e"-key, and remove the "rhgb"-parameter from the boot parameters. The continue booting normally. (This will skip the graphical boot in Fedora.)

2) Fedora complains about not being able to start GDM, ignore it and cancel all questions to get to the login prompt.

3) Login as root, enter "init 3" to go to single-user mode. Enter "modprobe nvidia" to load the nvidia-module.

4) Finally, enter "cp -a /dev/nvidia* /etc/udev/devices/" to fix the boot problem.

5) Now just enter "init 5" and you're back in business.

This solved my problem and now it boots fine. Maybe my experience will help others too?
I should mention I don't have an athlon 64, I've got a 32 bit athlon XP, so that doesn't matter.

Second - I could into gnome with the nvidia drivers after that (after editing /etc/X11/xorg.conf and replaceing driver "nv" with driver "nvidia" like you are supposed to do), but when running 3D-accelerated programs, I'd get a strange error that reffered me to the readme file from nvidia. Here's the fix for that, taken right out of the readme file:
Quote:
Q: OpenGL applications exit with the following error message:

Error: Could not open /dev/nvidiactl because the permissions
are too restrictive. Please see the FREQUENTLY ASKED QUESTIONS
section of /usr/share/doc/NVIDIA_GLX-1.0/README for steps
to correct.

A: It is likely that a security module for the PAM system may be
changing the permissions on the NVIDIA device files. In most cases
this security system works, but it can get confused. To correct this
problem it is recommended that you disable this security feature.
Different Linux distributions have different files to control this;
please consult with your distributor for the correct method of
disabling this security feature. As an example, if your system has
the file
/etc/security/console.perms
then you should edit the file and remove the line that starts with
"<dri>" (we have also received reports that additional references to
<dri> in console.perms must be removed, but this has not been verified
by NVIDIA). If instead your system has the file
/etc/logindevperms
then you should edit the file and remove the line that lists
/dev/nvidiactl. The above steps will prevent the PAM security system
from modifying the permissions on the NVIDIA device files. Next,
you will need to reset the permissions on the device files back
to their original permissions and owner. You can do that with the
following commands:
chmod 0666 /dev/nvidia* chown root /dev/nvidia*
This also worked. Make sure that you not only remove (or just place a '#' in front of) the line that starts with <dri>, but also do the same to the line at the bottem which contains <dri> in it as well. I didn't edit out the latter one the first time around, and as a result, I couldn't login as anything but root when I rebooted! (not sure why). In a nutshell, remove or edit out every line in console.perms that contains "<dri>"

As a side note, aren't these fixes sort of stupid? I mean the fact that you have to do them at all. Not pointing fingers, its just another reason newbies may fear linux.
Could anyone sticky this to the top of the fedora thread for a little while, in case lots of people come looking for a solution?
 
Old 11-19-2004, 06:57 PM   #2
Fenster
Member
 
Registered: Jul 2004
Location: Ireland
Distribution: Fedora Core 2
Posts: 70

Rep: Reputation: Disabled
Another fix is to edit the /etc/rc.sysinit and /etc/rc.d/rc.sysinit scripts.

In /etc/rc.sysinit, locate the following area:

Code:
echo -n $"Initializing hardware... "

ide=""
scsi=""
network=""
audio=""
other=""
In other="" add nvida

In /etc/rc.d/rc.sysinit, do the same.

No idea why it works, but the module has worked perfectly for me since.
 
Old 11-19-2004, 07:34 PM   #3
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
if you are using a riva tnt m64 32 MB video card or something similar, the nvidia 6629 won't work even with the solution above.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia drivers on fedora core 3 srasiroslayer Linux - Software 2 12-31-2004 11:17 AM
fedora core 3 nvidia drivers doralsoral Linux - Software 4 12-03-2004 08:58 PM
New Nvidia Drivers - Fedora Core 2 JustOl'Bob Linux - Newbie 10 07-08-2004 05:28 PM
fedora core 2 nvidia drivers cprogrck Linux - Hardware 21 06-16-2004 11:50 AM
Nvidia drivers with Fedora core 1 doralsoral Linux - Software 5 12-24-2003 05:56 AM


All times are GMT -5. The time now is 05:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration