LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 08-09-2004, 06:24 AM   #1
svoltmer
Member
 
Registered: Apr 2004
Posts: 33

Rep: Reputation: 15
Fedora Core 2 Can't start Xserver


I have finally got FC2 to install. It starts loading then asks for my login so I give it root and my PW then I type "init 5", right? and It won't start xserver. I says that it needs me to configure the mouse, but when I do it still won't start. It looks like it is having problems displaying the video. What should I do? I am fairly new to linux and don't know what to try next.
 
Old 08-09-2004, 07:52 AM   #2
justin_p
Member
 
Registered: Jan 2004
Location: Virginia, USA
Distribution: slack 13; I've used it all :)
Posts: 433

Rep: Reputation: 30
try on run xorgconfig (or whatever to program is in FC2, hopefully soneone else could provide that command). This will try to configure everything automatically. If it is not able to do it, it should give you the option to set up everything manually. Just know your hardware.
 
Old 08-09-2004, 01:16 PM   #3
LinuxLala
Senior Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: Fedora 7
Posts: 1,305

Rep: Reputation: 45
You can try editing the xorg.conf file. At the console say

vi /etc/X11/xorg.conf

Browse down to the section titled Monitor. See if all is well. Also check out the Mouse section. Before you can make any changes to the file you need to press the key 'a'. A --INSERT-- would appear at the bottom left. Now you can edit the file. When you are done editing,

hit the escape key
press colon(
write wq

The sequence is
Esc : wq

Last edited by LinuxLala; 08-09-2004 at 01:23 PM.
 
Old 08-09-2004, 03:09 PM   #4
svoltmer
Member
 
Registered: Apr 2004
Posts: 33

Original Poster
Rep: Reputation: 15
I don't have that dir. I can go to /usr/X11R6/bin/getconfig, but that doesn't help me. I need a way to alter the display settings and the pointer settings so it can start xserver. How can I change these? Thanks

Last edited by svoltmer; 08-09-2004 at 04:19 PM.
 
Old 08-09-2004, 11:05 PM   #5
OEP
Member
 
Registered: Apr 2004
Location: AL, USA
Distribution: FC4, Gentoo
Posts: 58

Rep: Reputation: 15
You don't have /etc/X11 folder?

That sounds kinda questionable, but one issue I have had with the X server and mice is that the x server configured my mouse as /dev/mouse when it really should be /dev/input/mice.

Try "grep /etc/X11/xorg.conf /dev/mouse" and see if anything shows up...
 
Old 08-10-2004, 11:14 AM   #6
LinuxLala
Senior Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: Fedora 7
Posts: 1,305

Rep: Reputation: 45
the directory is /etc/X11 The config file is xorg.conf
 
Old 08-10-2004, 12:57 PM   #7
svoltmer
Member
 
Registered: Apr 2004
Posts: 33

Original Poster
Rep: Reputation: 15
when I used the "grep /etc/x11/xorg.cfg/dev/mouse" command all I got was a flashing cursor.

Also... what can I use to edit the "xorg.cfg" file if I can't get my desktop environment started? and how? Thanks
 
Old 08-10-2004, 01:24 PM   #8
FlimFlam
LQ Newbie
 
Registered: Aug 2004
Distribution: homegrown
Posts: 1

Rep: Reputation: 0
from the prompt type:
vim /etc/X11/xorg.conf

This will allow you to access and edit your xorg.conf file without needing your window manager.

fF....
 
Old 08-10-2004, 01:32 PM   #9
LinuxLala
Senior Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: Fedora 7
Posts: 1,305

Rep: Reputation: 45
You don't need to have X running to use vi. VI is a command line text editor. Use the method I described above to edit xorg.conf
 
Old 08-10-2004, 05:15 PM   #10
svoltmer
Member
 
Registered: Apr 2004
Posts: 33

Original Poster
Rep: Reputation: 15
Thanks! I was able to make a "xorg.conf" file. But when I "startx" I get the error "No Device section for PCI:1:0:0" Well, I have a Device section with this listed:

Section "Device"
Identifier "Card0"
Driver "ati"
BoardName "Radeon X800 Pro"
BusID "PCI:1:0:0"
Endsection
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Core 2 Start Problem Megasoft Linux - Hardware 1 10-20-2004 12:26 PM
Fedora Core 2 Won't Start Xserver svoltmer Fedora 2 08-10-2004 12:17 PM
Fedora Core 1 Installer Doesn't Start davefnelson Linux - Laptop and Netbook 0 07-23-2004 09:38 PM
XServer crash - Fedora Core 1 nodon11 Linux - Newbie 1 05-01-2004 04:04 PM
fedora core 2 test 2 not loading xserver or x kwingate Linux - Software 3 04-18-2004 04:16 PM


All times are GMT -5. The time now is 03:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration