LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 01-01-2005, 05:24 AM   #1
ksmj
Member
 
Registered: Jan 2005
Location: Malaysia
Distribution: Fedora Core 3
Posts: 35

Rep: Reputation: 15
Fedora C3 boot problem


Hi,

I am just wondering if anyone has come across problem similar to this and know how to fix it.

When i boot up my system, it says

Uncompressing linux ...... ok, booting the kernel
audit (1104535970:0): initialized
Red Hat Nash version 4.1.18 starting
insmod: error inserting '/lib/BusLogic.ko': -1 No
ERROR: /lib/insmod exited abnormally!
INIT: version 2.85 booting
.
.
.
.
Initializing hardware ... storage network audio done [ok]
Configuring hernel parameters


and it just stops there without doing anything.


can someone please help?


thanks
 
Old 01-01-2005, 08:57 AM   #2
Kumo
LQ Newbie
 
Registered: Jan 2005
Location: Germany
Distribution: Vector Linux 5.1
Posts: 6

Rep: Reputation: 0
Could it be, that you installed the NVidia driver? Because i had the same problem if i "just" installed it. If in the Videocard0 section in your /etc/X11/xorg.conf the driveroption is nvidia, you could change the driver to vesa (with the rescue mode), and check if that solves the problem. But you surely won't want to keep that configuration, as, at least for me, the Hz of the monitor stays at 60. To solve this, you need to load the nvidia driver yourself, only then X starts properly, it seems. My suggestion would be to edit the /etc/rc.sysinit and search for the location of the "grafical boot", which shouldn't be far down. Then you just write "/sbin/modprobe nvidia" before it, change the /etc/X11/xorg.conf back (commenting out dri and changing the driver back to nvidia) and then it should work.

Hope this helps.

[Edit]Ok, to be honest, the solution doesn't always work. But it seems that it always works if i change to the vesa driver. So maybe disabling the graphical boot would be another solution.[/Edit]

Last edited by Kumo; 01-02-2005 at 07:29 AM.
 
Old 01-02-2005, 06:18 PM   #3
RemusX2
Member
 
Registered: Oct 2003
Location: Bozeman, Montana
Distribution: Gentoo 2010, Ubuntu 9.04
Posts: 175

Rep: Reputation: 30
I had the same problem after I installed the Nvidia Drivers. The steps I take to fix this are:

When grub appears I go into the boot options... I'm not sure whether that is done my pressing 'a' or 'e' but under one of them there will be a line of text that contains the leters rhgb. Delete those four letters and it should boot normally. When the system does boot up log in as yourself. (this will be terminal style)
then type :
su -c '/sbin/modprobe nvidia'
password: <root password>


Of course this is assuming you're running the nvidia drivers.... hope this helps.
 
Old 01-02-2005, 06:45 PM   #4
jordo2323
LQ Newbie
 
Registered: Oct 2004
Location: Milwaukee, WI
Posts: 16

Rep: Reputation: 0
Fedora Boot Problem

I had a similar problem too. I tried loading Fedora 3 on a Dell 1100 Pentium 3 with plenty of RAM, and got it to upgrade (from Fedora 2) but when it loads, the video crashed.

I tried to do a full install, but the installation hangs when trying to find the installation media on CD1. Fedora Core 3 is not impressing me thus far.


I think my Dell Inspiron 1100 has a Nvidia card in it, but I can't quite remember.
 
Old 01-02-2005, 11:42 PM   #5
ksmj
Member
 
Registered: Jan 2005
Location: Malaysia
Distribution: Fedora Core 3
Posts: 35

Original Poster
Rep: Reputation: 15
i've got it sorted out thanks. It's due to the rhgb thing in the kernel parameter. Once i removed it, it works fine as i've experienced in rh9


thanks for all the replies


Kelvin
 
Old 01-04-2005, 06:48 AM   #6
Kumo
LQ Newbie
 
Registered: Jan 2005
Location: Germany
Distribution: Vector Linux 5.1
Posts: 6

Rep: Reputation: 0
Hm, does the rhgb enable the graphical boot? (As it could be spelled as redhat graphical boot) Or do you still get the Status bar etc?
 
Old 01-04-2005, 11:53 PM   #7
ksmj
Member
 
Registered: Jan 2005
Location: Malaysia
Distribution: Fedora Core 3
Posts: 35

Original Poster
Rep: Reputation: 15
i still get the graphics interface when i boot up.


Kel.
 
Old 01-06-2005, 05:09 PM   #8
Magicplayr2000
LQ Newbie
 
Registered: Jun 2004
Posts: 23

Rep: Reputation: 15
Quote:
Originally posted by RemusX2
I had the same problem after I installed the Nvidia Drivers. The steps I take to fix this are:

When grub appears I go into the boot options... I'm not sure whether that is done my pressing 'a' or 'e' but under one of them there will be a line of text that contains the leters rhgb. Delete those four letters and it should boot normally. When the system does boot up log in as yourself. (this will be terminal style)
then type :
su -c '/sbin/modprobe nvidia'
password: <root password>


Of course this is assuming you're running the nvidia drivers.... hope this helps.
I tried doing that and it said "Fatal: module Nvidia not found"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Boot problem with Fedora and XP grizos Fedora 3 05-08-2005 12:07 PM
Fedora core 3 / MS XP boot problem Ellylls_Grove Linux - Laptop and Netbook 0 12-26-2004 03:54 PM
Fedora Core 1 Boot Problem~! skate Linux - Newbie 4 06-08-2004 05:48 AM
Fedora Core 1 Boot problem :-\ Tekk Fedora - Installation 1 04-12-2004 08:48 PM
Fedora Boot Problem landholl Linux - Networking 5 02-10-2004 03:52 PM


All times are GMT -5. The time now is 09:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration