LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 11-11-2003, 09:44 AM   #1
lucastic
Member
 
Registered: Aug 2003
Location: Oz
Distribution: Gentoo - Debian
Posts: 202

Rep: Reputation: 30
Fedora and Nvidia Drivers


Hi all,

Has anyone had any luck with fedora core 1 and the latest Nvidia drivers.

In run level 3 I type

sh NVIDIA*

the installer starts ok, then tells me there is an error with my kernel headers, and that installation has failed.

Do I need to recompile the kernel?? (Never recompilied before....)

Graphics card is a Geforce 4 MX-440

Any help would be appreciated.

Lucas
 
Old 11-11-2003, 10:21 AM   #2
mishmash
Member
 
Registered: Nov 2003
Location: Canada
Distribution: Mandrake 9.x, 10
Posts: 87

Rep: Reputation: 15
Hi,

Please read entirely the thread named "Nvidia Driver", I have provided the steps to install the driver. If you have installed Fedora Core 1 and did no specific modifications to it, the NVIDIA driver should install correctly.

This is the link to the thread:

http://www.linuxquestions.org/questi...hreadid=113254

Regards,

mishmash
 
Old 11-11-2003, 10:47 PM   #3
lucastic
Member
 
Registered: Aug 2003
Location: Oz
Distribution: Gentoo - Debian
Posts: 202

Original Poster
Rep: Reputation: 30
Hi,

I have tried the method you described and get this error every time:

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Wed Nov 12 15:15:48 2003

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : false
no questions : false
silent : false
XFree86 install prefix : /usr/X11R6
OpenGL install prefix : /usr
Installer install prefix: /usr
kernel include path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp site : ftp://download.nvidia.com

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
ERROR: Unable to find the kernel header files for the currently running kernel.
Please make sure you have installed the kernel header files for your
kernel; on Red Hat Linux systems, for example, be sure you have the
'kernel-source' rpm installed. If you know the correct kernel header
files are installed, you may specify the kernel include path with the
'--kernel-include-path' commandline option.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.


Any ideas?

Thanks

Lucas
 
Old 11-12-2003, 01:12 AM   #4
DrD
Member
 
Registered: Nov 2003
Distribution: Fedora Core 4
Posts: 99

Rep: Reputation: 15
In case anybody is wondering, I am having the EXACT same issue - "no precomiled kernel..." etc error comes up when I try this. I did do the "export CC=gcc32" command beforehand.
 
Old 11-12-2003, 01:55 AM   #5
lucastic
Member
 
Registered: Aug 2003
Location: Oz
Distribution: Gentoo - Debian
Posts: 202

Original Poster
Rep: Reputation: 30
I think I have progressed but still not able to install the driver...

I installed KERNEL-SOURCE*.RPM, install went fine.

But when I tried to install the NVIDIA drivers with the kernel.h location as '/usr/src/linux-2.4.20-20.9/include/linux/kernel.h

I get the followimg error;

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Wed Nov 12 17:13:33 2003

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : false
no questions : false
silent : false
XFree86 install prefix : /usr/X11R6
OpenGL install prefix : /usr
Installer install prefix: /usr
kernel include path : /usr/src/linux-2.4.20-20.9/include
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp site : ftp://download.nvidia.com

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: No)
-> No precompiled kernel interface was found to match your kernel; this means
that the installer will need to compile a new kernel interface.
-> Using the kernel include path '/usr/src/linux-2.4.20-20.9/include' as
specified by the '--kernel-include-dir' commandline option.
-> Kernel include path: '/usr/src/linux-2.4.20-20.9/include'
-> Cleaning kernel module build directory.
executing: 'cd ./usr/src/nv; make clean'...
rm -f nv.o os-agp.o os-interface.o os-registry.o nv-linux.o nv_compiler.h *
.d NVdriver nvidia.o
-> Building kernel module:
executing: 'cd ./usr/src/nv; make nvidia.o SYSINCLUDE=/usr/src/linux-2.4.20-
20.9/include'...

You appear to be compiling the NVIDIA kernel module with
a compiler different from the one that was used to compile
the running kernel. This may be perfectly fine, but there
are cases where this can lead to unexpected behaviour and
system crashes.

If you know what you are doing and want to override this
check, you can do so by setting IGNORE_CC_MISMATCH.

In any other case, set the CC environment variable to the
name of the compiler that was used to compile the kernel.

*** Failed cc sanity check. Bailing out! ***
make: *** [gcc-check] Error 1
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.
 
Old 11-12-2003, 03:13 AM   #6
ronss
Member
 
Registered: Mar 2002
Location: phoenix,az
Distribution: red hat linux enterprise-centos
Posts: 766

Rep: Reputation: 31
go to mishmash,s thread, its very good. also , go to http://www.nvidia.com. and look at the read me files. follow it with mishmash,s tread. the only thing you different with the fedora core vs red hat 9 is typing in the exporting gcc that stated in the other thread.
 
Old 11-12-2003, 10:43 AM   #7
cybrjackle
Member
 
Registered: Jul 2003
Distribution: Debian etch/lenny/sid, Fedora 7/Rawhide, CentOS 4/5, FreeBSD 6.2 and Solaris 10/Nevada
Posts: 110

Rep: Reputation: 16
Go here and try it:

http://rebus.webz.cz/
 
Old 11-15-2003, 01:36 AM   #8
lucastic
Member
 
Registered: Aug 2003
Location: Oz
Distribution: Gentoo - Debian
Posts: 202

Original Poster
Rep: Reputation: 30
After a week of frustration, this is beginning to get really annoying.

I have tried everything suggested everywhere on this forum... Just getting errors.

After many attempts at mismatches method, I tried the one with the link above.

Downloaded the rpm files, had to install rpm-builder.

Built the rpm files, installed them, everything seemed ok.

Change the XF86Config to nvidia instead of nv, then type startx... ERROR nvidia module cannot be found!

Those of you who havent wasted days trying to install the nvidia drivers, what sort of base install did you do, personal desktop, workstation???

Thanks

Lucas
 
Old 11-15-2003, 04:01 AM   #9
jolavillette
LQ Newbie
 
Registered: Nov 2003
Posts: 6

Rep: Reputation: 0
hi lucastic

ok i think you ran into 2 different problems : one with kernel headers and one with gcc version

the first one you solve by installing rpm-source packages

but it seems that you did nothing about the second one.
the installer tells you : " If you know what you are doing and want to override this check, you can do so by setting IGNORE_CC_MISMATCH."

if i remember ok, you must run the NVDIA* archive with the option to decompress itself only, then edit the makefile to set the IGNORE_CC_MISMATCH variable, and then run the installer by hand

i will checked this again in my Fedora 0.95 install and i will try to be more specific.
 
Old 11-15-2003, 04:16 AM   #10
jolavillette
LQ Newbie
 
Registered: Nov 2003
Posts: 6

Rep: Reputation: 0
here is what I did with Fedora 0.95 to compile the nvidia graphic module :

1. Uncompress the NVIDIA* archive you found on nvidia website :
sh NVIDIA* --extract-only
2. edit the Makefile located in the NVIDIA*/usr/src/nv directory
3. add IGNORE_CC_MISMATCH=1 at the beginning of the Makefile
4. run the installer again : ./nvidia-installer

It worked for me.
(you still need to modify you XF86Config file, this is another question)
 
Old 11-15-2003, 06:10 AM   #11
lucastic
Member
 
Registered: Aug 2003
Location: Oz
Distribution: Gentoo - Debian
Posts: 202

Original Poster
Rep: Reputation: 30
Thanks, I will try and let you know how I go.
 
Old 11-15-2003, 06:51 AM   #12
hkctr
Member
 
Registered: Sep 2003
Posts: 106

Rep: Reputation: 15
All I did was install the kernel-sources from the CD. Actually, what I did was click the box during the installation for the Kernel Development packages to be installed. This takes care of everything concerning the kernel.

I edited XF86Config and changed nv to nvidia, commented out glxcore and dri and rebooted. This is easier than editing initab to change the runlevel. It will try to start X upon reboot and fail, taking you back to the command line prompt.

Then, as root, I typed:

env IGNORE_CC_MISMATCH=1 sh /path/to/NVIDIA-Linux-x86-1.0-4496-pkg2.run

The installer runs and installs the driver. Type X on the command line when its done to see if X will start. alt-ctrl-backspace will kill X take you back to the command line.

Reboot and you should see the Nvidia logo shortly.
This method takes about 2 minutes including reboots and never fails for me YMMV.

Edited

Last edited by hkctr; 11-15-2003 at 06:53 AM.
 
Old 11-16-2003, 05:47 AM   #13
lucastic
Member
 
Registered: Aug 2003
Location: Oz
Distribution: Gentoo - Debian
Posts: 202

Original Poster
Rep: Reputation: 30
thanks HKCTR,

I finally managed to get the drivers installed, heres how;

1-Reinstalled Fedora with a full install including almost everything, kernel utils etc... (before I was doing a personal desktop install which may have caused most of my problems)

2- boot computer, login, download NVIDIA-Linux* (i386) from Nvidia website, put the NVIDIA driver file in /root

3- from gnome or kde or whatever find the /etc/innitab file and change from 5 to run level 3 as default. (As I prefer to start with text login I do this anyway, HKCTR's method is equally as good if you want to return to graphical login after nvidia setup)

4- reboot

5- type the following after text login:

env IGNORE_CC_MISMATCH=1 sh /path/to/NVIDIA-Linux-x86-1.0-4496-pkg2.run

or

env IGNORE_CC_MISMATCH=1 sh /root/NVIDIA-Linux*

follow the nvidia prompts to accept license etc... it may say no precompilied Kernel found... just continue on and the driver will install correctly.

6- vi /etc/X11/XF86Config to change the "nv" to "nvidia", altenatively you can type startx again and change the XF86Config file from the GUI. Then logout if in Gnome or KDE.

7 - Type startx, and you should shortly see the nvidia startup screen. YAY!!!

Thankyou to everyone for their help.

Long live the Penguin!!
 
Old 11-16-2003, 06:58 AM   #14
wiraone
Member
 
Registered: Nov 2003
Location: Diawang-awangan
Distribution: Ubuntu Hoary!
Posts: 319

Rep: Reputation: 30
Err.. in Penguin world, if you don't touch the kernel, you do not need to reboot your PC!
 
Old 11-16-2003, 07:40 AM   #15
lucastic
Member
 
Registered: Aug 2003
Location: Oz
Distribution: Gentoo - Debian
Posts: 202

Original Poster
Rep: Reputation: 30
I know you dont have to reboot, but on initial running of Fedora when you log out of gnome it takes you back to graphic login, not text.... Just seemed easier to reboot, to get to text login after changing intittab> command line, seeing as it only takes all of about 30 seconds to reboot.

The method is merely supposed to work not be perfect....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[fedora c3]nvidia drivers h3xis Linux - Hardware 0 02-08-2005 05:36 PM
Nvidia Drivers for Fedora 3 LemonyZ Linux - Newbie 2 01-16-2005 07:32 AM
Nvidia Drivers For Fedora :) LinuxMyK Fedora 15 07-04-2004 06:31 PM
fedora core 2 nvidia drivers cprogrck Linux - Hardware 21 06-16-2004 11:50 AM
NVidia drivers with Fedora 1 jlacroix Fedora 11 11-12-2003 12:09 PM


All times are GMT -5. The time now is 01:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration