LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 11-27-2008, 08:53 AM   #1
jalsk
Member
 
Registered: Nov 2003
Location: Boise, Idaho
Distribution: Fedora 9 x86_64 and Gentoo
Posts: 51

Rep: Reputation: 15
Fedora 9 gnome freezes, computer continues to run


I am having an interesting issue. I am running Fedora 9 x86_64 with Gnome as my window manager (mostly because KDE4 isn't really ready for everyday use). Every once in a while, gnome will freak out for a minute and all of my window decorations will disappear (the top bar, minimize, maximize, and close buttons). Once this happens, all of the programs that I had running all continue to run, but I am unable to interact with the desktop. This happens infrequently, but is quite frustrating when it does happen. Any idea what might be happening and how I might fix it? Thanks in advance.

-jalsk
 
Old 11-28-2008, 06:51 PM   #2
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,828

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
This sounds like it might be a problem with Compiz. Are you running the 3D stuff? There are know problems with disappearing window decorations.
 
Old 11-28-2008, 06:57 PM   #3
jalsk
Member
 
Registered: Nov 2003
Location: Boise, Idaho
Distribution: Fedora 9 x86_64 and Gentoo
Posts: 51

Original Poster
Rep: Reputation: 15
I don't believe that I'm using Compiz. Can Compiz be enabled without it being done explicitly? I do remember that when I set up my machine I had issues with getting my video drivers working properly (I have an nvidia geforce 8600gt), so I may have turned it on without realizing it. If compiz is enabled, should I try to disable it? Just today I switched from gnome to kde 4.1 in hopes that it might fix my issue, but I don't know if that will have the desired effect.

-jalsk
 
Old 11-29-2008, 06:00 AM   #4
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,828

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Compiz is the 3D, rotating cube desktop. If you hold down the ctrl + alt keys, and press a right or left arrow key, the cube will spin to the next face. If that doesn't happen, then no, you do not have compiz running. If yes, then you have it running.

Quote:
Can Compiz be enabled without it being done explicitly?
Not as far as I know.

If KDE 4 fails also, I would bet the problem is not any of the desktop code. Try KDE 4 for a few days, see what happens. If it is stable, great.

If compiz is running, yes you can disable it. Have a look through your menus, look for something called CompizConfig Settings Manager. It will only be there if the 3D stuff is loaded. If you do have Compiz, it is worth fixing the problem. ( in my opinion ) You have a fast enough video card, why not use it.

I would have to do some searching, as I remember it, the problem I had was fixed with a configuration setting for Windows Decorations.
 
Old 11-29-2008, 11:15 AM   #5
jalsk
Member
 
Registered: Nov 2003
Location: Boise, Idaho
Distribution: Fedora 9 x86_64 and Gentoo
Posts: 51

Original Poster
Rep: Reputation: 15
Well, I don't have compiz running... I use the Ctrl + Alt + arrow key shortcut to change desktops all the time and there are no pretty transitions. Maybe it is something else?

-jalsk
 
Old 11-29-2008, 04:45 PM   #6
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,828

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Hmmm. I did some googling. There are lots of problems as you describe. Could you post your /etc/X11/xorg.conf file?

Most of the fixes have the user add a line in the screen section.

Quote:
Option "AddARGBGLXVisuals" "true"
You could try it, edit the file as root, and add the line.You would need to restart the x-server. Just hit Ctrl + Alt + Backspace.

As far as I know, this is dealing with Nvidia + GLX. Here is a link you can read through.

https://bugs.launchpad.net/ubuntu/+bug/154596

I know this is an older version of Ubuntu, and you are running FC9, 64 bit. Ubuntu is also uning Gnome.

Try the fix, and post your xorg.conf file.
 
Old 12-09-2008, 10:12 PM   #7
jalsk
Member
 
Registered: Nov 2003
Location: Boise, Idaho
Distribution: Fedora 9 x86_64 and Gentoo
Posts: 51

Original Poster
Rep: Reputation: 15
Here's a copy of my xorg.conf file. Just in the past few days I upgraded from Fedora 9 to Fedora 10 (in place upgrade), and thus far I don't think it has caused any additional issues. I did try switching to KDE4.1 for a few days and the issue with X appears to be present still, albeit in a different form. With KDE, I can still interact with the desktop, but only using the keyboard. This is nice because I can at least log out and back in again rather than having to kill X and start it back up again, but it is still frustrating.

I also had an issue where, by no act on my part other than killing the X server and having it restart, my screens switched positions. Suddenly it was as if I had switched the DVI connectors on the two monitors, but I didn't... Then after a few reboots it switched back to normal. It was the strangest thing.

Hopefully this helps and you can glean some useful information from this config file. Thanks!

Code:
# Xorg configuration created by pyxf86config

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "Screen0" 0 0
	Screen      1  "Screen1" RightOf "Screen0"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "ServerFlags"
	Option "Xinerama" "true"
EndSection

Section "InputDevice"
# keyboard added by rhpxl
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
	Option	    "RenderAccel" "True"
	BusID       "PCI:1:0:0"
	Screen      1
EndSection

Section "Module"
	Load "glx"
	Load "dri"
EndSection

Section "Device"
	Identifier  "Videocard1"
	Driver      "nvidia"
	Option	    "RenderAccel" "True"
	BusID       "PCI:1:0:0"
	Screen      0
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard1"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "Screen"
	Identifier "Screen1"
	Device     "Videocard0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "DRI"
	Mode 0666
EndSection
-jalsk
 
Old 12-10-2008, 09:35 AM   #8
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,828

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Quote:
I can still interact with the desktop, but only using the keyboard.
This has to have something to do with the mouse section of your /etc/X11/xorg.conf file.

If you have a copy of the old file, with the mouse working, look there. If not, you could try a live CD like Knoppix, and have a look at the xorg file there. Knoppix is very good at detecting hardware.

It would also be interesting to see what other things differ for your video card.

As far as what you posted for your xorg file, I don't see anything unusual there. You can try the fix I posted earlier in the thread. See if that has the desired effect. If not, not much time lost.

Beyond that, have you done any looking on the FC forums to see if anyone else is having any of these issues? or the Nvidia forums?

Last edited by camorri; 12-10-2008 at 09:37 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 9 X86/64 live CD freezes when I run installer WiglyWorm Linux - Newbie 7 05-20-2008 02:45 PM
Computer freezes when I click on Configure your computer pburn Mandriva 1 07-28-2006 07:00 AM
Error after editing /etc/rc/rc.local, Fedora freezes when tries to run the script simeandrews Fedora 1 06-24-2005 10:52 AM
Computer boots up, then Gnome freezes. john8775 Linux - Software 4 03-17-2005 12:09 AM
XServer freezes but machine continues running... hlslaughter Linux - Hardware 5 06-27-2003 01:04 AM


All times are GMT -5. The time now is 08:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration