LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 07-05-2008, 04:00 AM   #1
Novatian
Member
 
Registered: Feb 2008
Location: Australia
Distribution: Mint 17 MATE 64bit and 32bit, TAILS, Fedora 20, Android, Manjaro.
Posts: 613

Rep: Reputation: 33
Fedora 9, First Boot, Stops at "Grub:" What To Do?


Hi, this is my first test of using Fedora 9 Sulphur. I successfully installed it from three CDs. Installing over Manadriva free edition, Spring 08, using the old partitions and overwriting the root partition.

Would that have also cleared the other partitions, on my 80 GB HDD?

But the main question is, that after following the instruction to restart, it did so only to the point of the black screen and writing, the last word being "Grub:" with the option to add some input I think.

I was really sleepy at the time and may have missed something.

How shall I get through to the conclusion of the process, from Grub?
 
Old 07-05-2008, 11:32 PM   #2
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,505

Rep: Reputation: 1078Reputation: 1078Reputation: 1078Reputation: 1078Reputation: 1078Reputation: 1078Reputation: 1078Reputation: 1078
I'd be guessing you didn't install grub at all, or not into the MBR - and you are still getting the MBR code from your previous install.
If you didn't install it at all, redo the full install. If it's simply not in the MBR, boot the CD, choose to boot the disk install, open a terminal, and use "df" to see what the disk is called - probably /dev/sda.
Then "grub-install /dev/sda".

(other partitions should be left alone by the install)
 
Old 07-15-2008, 03:41 PM   #3
miketrigs93
LQ Newbie
 
Registered: Jul 2008
Posts: 6

Rep: Reputation: 0
Exclamation grub

i installed Fedora 9 onto my PC which has Windows XP using the DVD that I got with the Linux Format Magazine in the UK
I installed it onto Hard disk 2 (I think I didn't istall grub onto the MBR or something like that so the MBR is on HDD 1)
at the end of the installation I rebooted the computer as asked by fedora, and it booted with windows. I read through various forums(including this one) to find the answer. I changed my BIOS settings from:
1st booot: CD-ROM
2nd boot: HDD 1
3rd boot: other device (i'm pretty sure that's what it said, though I may be wrong)

to:
1st: HDD 2 2nd: HDD 1 3rd: CD-ROM

i read somewhere that The disk with Fedora on it should be set as 1st. I tried various combinations, and most of them just brought up a menu that asked if I wanted to run Windows in safe mode, normally, or if I wanted to restore the previous settings, and Windows would boot normally (or in safe mode).

I then read that a common problem is grub hasn't been installed correctly. So I booted the CD, and clicked update Fedora (or something similar) and then I re-installed grub to see if that would work, but I got the same result.

I read somewhere that fedora should be booting from the disk where the MBR is, so I booted the CD again, reinstalling it and removing the previous installation. This time I selected both hard disks to install fedora on and disk 1 to boot from (presumably that's where grub is now :S )

at the end of the installation I rebooted as requested, but nothing at all booted, not even windows xp. The only differance was that I got a pageful of writing (which i got normally while booting xp) but on the bottom line it said: 'GRUB....'

it is possible that I messed up the BIOS settings for booting (how should they be?)

please if anyone can help do so, I'm a complete Linux newbie and it shows. Also I apologise for making this sound so complicated even if it seems extremely simple.

Last edited by miketrigs93; 07-15-2008 at 03:47 PM.
 
Old 07-15-2008, 03:49 PM   #4
miketrigs93
LQ Newbie
 
Registered: Jul 2008
Posts: 6

Rep: Reputation: 0
Exclamation grub

i installed Fedora 9 onto my PC which has Windows XP using the DVD that I got with the Linux Format Magazine in the UK
I installed it onto Hard disk 2 (I think I didn't istall grub onto the MBR or something like that so the MBR is on HDD 1)
at the end of the installation I rebooted the computer as asked by fedora, and it booted with windows. I read through various forums(including this one) to find the answer. I changed my BIOS settings from:
1st booot: CD-ROM
2nd boot: HDD 1
3rd boot: other device (i'm pretty sure that's what it said, though I may be wrong)

to:
1st: HDD 2 2nd: HDD 1 3rd: CD-ROM

i read somewhere that The disk with Fedora on it should be set as 1st. I tried various combinations, and most of them just brought up a menu that asked if I wanted to run Windows in safe mode, normally, or if I wanted to restore the previous settings, and Windows would boot normally.

I then read that a common problem is grub hasn't been installed correctly. So I booted the CD, and clicked update Fedora (or something similar) and then I re-installed grub to see if that would work, but I got the same result.

I read somewhere that fedora should be booting from the disk where the MBR is, so I booted the CD again, reinstalling it and removing the previous installation. This time I selected both hard disks to install fedora on and disk 1 to boot from (presumably that's where grub is now :S )

at the end of the installation I rebooted as requested, but nothing at all booted, not even windows xp. The only differance was that I got a pageful of writing (which i got normally while booting xp) but on the bottom line it said: 'GRUB....'

it is possible that I messed up the BIOS settings for booting (how should they be?)

please if anyone can help do so, I'm a complete Linux newbie and it shows. Also I apologise for making this sound so complicated even if it seems extremely simple.
 
Old 07-15-2008, 04:52 PM   #5
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
@mike

I recommend doing yet another install. Make sure to unplug your windows drive before you start so GRUB doesn't get a chance to get astray. Make sure to install to the MBR. Once you are up and running, plug the windows drive back in as a secondary drive. You will then have to add an entry (manually) to GRUB in order to be able to boot into windows. Make sure to choose a proper file type: installing grub on an xfs or jfs partition is asking for trouble. I prefer those for most of my stuff since they are generally faster than ext3 but in that case you have to create a small separate boot partition (100MB) that uses ext3.

By the way, are you using PATA drives? SATA? SATA should be pretty failsafe but PATA has something called Master-Slave-Cable Select that can make booting seriously complicated. Some operating systems simply cannot boot off a slave drive, whether it is set in BIOS as first drive or second.

Last edited by jay73; 07-15-2008 at 04:53 PM.
 
Old 07-16-2008, 04:04 AM   #6
miketrigs93
LQ Newbie
 
Registered: Jul 2008
Posts: 6

Rep: Reputation: 0
Question

I opened up the PC to take a look at the hard disks. One of them is a Seagate Barracuda 7200.9 (200GB) ST3200827A, and the other is a Western Digital Caviar SE WD800JB (80GB)- this is the one where windows xp is installed. The wire going into the Western Digital one has master written on it, and the other has slave.
I don't know whether they're PATA or SATA though (i'm guessing they're SATA but i don't really know), can someone please look up these disks (if they don't already know what they are) and tell me what to do next.
 
Old 07-16-2008, 04:53 AM   #7
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
The difference isn't hard to tell. PATA drives have those broad data cables (about two inches wide I would guess) while SATA drives are much narrower, about a quarter of an inch . Also PATA drives are coupled (there are / can be two devices on the same data cable) while SATA drives have their invididual cable. ATA is being outphased and is being replaced by SATA. If you have an older computer, they would almost certainly be PATA.

In case you still wonder, yes, they are PATA drives (Parellel ATA). If your first drive (according to BIOS) is the slave of the set, then that would explain much. Pull the small jumpers out of the drives and insert them properly, either the other way round or use cable select for both. If you use cable select, the master-order relationship will be determined by the cable rather than by the jumpers: the black connector will be master, the grey one slave. It's easy to remember: top connector is the master, the one further down the cable is the slave. Cable select is the more failsafe approach in my opinion. Plug the jumpers in where it says "CS".
 
Old 07-16-2008, 08:16 AM   #8
miketrigs93
LQ Newbie
 
Registered: Jul 2008
Posts: 6

Rep: Reputation: 0
If I switch the hard disks around, would I be able to boot into windows (which would be on the slave)?
would it be possible to install fedora on the same disk as xp and boot them both from there?
 
Old 07-16-2008, 08:52 AM   #9
miketrigs93
LQ Newbie
 
Registered: Jul 2008
Posts: 6

Rep: Reputation: 0
right... i did that and now it won't even turn on, or it does it just has a blank screen (and I'm pretty sure I put all the cables in right, because I've done it before, i'm not such a big newbie).
anyway, you probably can't help me now, so it's probably time to take the pc to the computer store :-(
 
Old 07-16-2008, 10:58 AM   #10
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
If it was working before then it should work again if you simple restore the jumpers to their original condition. And by the way, you were not supposed to touch the cables, just the jumpers on the hard drives. Unless, of course, you selected cable select and you wanted the lower drive to be master. I'm not sure what you did exactly.
 
Old 07-17-2008, 04:10 AM   #11
miketrigs93
LQ Newbie
 
Registered: Jul 2008
Posts: 6

Rep: Reputation: 0
well, at first I changed it to cable select and switched the cables, but that didn't work, so I changed it back to the original setup with the jumpers and cables, and I still get a blank screen. Never mind, I'm taking it to the computer store for a service. Thanks for your help anyway.
 
Old 07-17-2008, 10:00 AM   #12
DOTT.EVARISTI
Member
 
Registered: Jan 2007
Location: La spezia ( Italia )
Distribution: Fedora 9 amd 64, Gnome,PCLOS 2007,OpenSuse 11 amd 64,Sabayon 3.4,Xp,Vista
Posts: 248

Rep: Reputation: 31
Cool

Quote:
Originally Posted by miketrigs93 View Post
well, at first I changed it to cable select and switched the cables, but that didn't work, so I changed it back to the original setup with the jumpers and cables, and I still get a blank screen. Never mind, I'm taking it to the computer store for a service. Thanks for your help anyway.

Nothing easier..??

It's happened the same boot problem to me too leaving Win xp in hd 1 and installing Fedora 9 Gnome 2.22 in hd 3 and i fixed it recovering win mbr by win recovery console with fixmbr and then with fixboot,then simply following fedora dvd instruction to install a new version of grub..now everything works well and just now i'm writing from fedora within firefox 3 beta 5

I hope it works for you too.

Good luck !


Last edited by DOTT.EVARISTI; 07-17-2008 at 10:05 AM.
 
  


Reply

Tags
bios, boot, fedora, grub, xp


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dual booting fedora with vista - boot error - "GRUB loading stage 2" ans Fedora 2 08-20-2007 07:12 AM
dual boot fedora & vista - boot error - "GRUB loading stage 2" ans Fedora 1 08-20-2007 04:35 AM
uninstall boot loader "Lilo" install "Grub" sethis Linux - Newbie 6 11-30-2006 10:32 AM
Fedora 6 won't boot anymore, stops on "Enabling local filesystem quotas" ttnunam Linux - General 2 11-07-2006 01:01 PM
Boot stops at "GRUB" Flasher2 Linux - Hardware 6 06-25-2005 11:55 AM


All times are GMT -5. The time now is 01:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration