LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 05-25-2008, 09:03 PM   #1
saravkrish
Member
 
Registered: Mar 2004
Location: KY, USA
Distribution: Fedora Core 1
Posts: 190

Rep: Reputation: 30
Fedora 9 boots (long delay) as single core if I go to GRUB menu, otherwise boots fine


Hi,

This is 100% reproducible. I'm using a Shuttle SG33G5 and Q9300 (45nm).

If I press a key during the GRUB countdown and choose Linux (Linux is the default), the boot hangs after the line "Booting the kernel." and before "Redhat nash..." is displayed.

So I went into GRUB and removed the "quiet" kernel option to see why/where it's failing. Then when typing up this in another PC, I noticed that Fedora 9 actually booted but with single core support.

I see this in dmesg:
CPU 1 irqstacks, hard=c07ba000 soft=c079a000
Not responding.
Inquiring remote APIC #1...
... APIC #1 ID: failed
... APIC #1 VERSION: failed
... APIC #1 SPIV: failed
CPU #1 not responding - cannot use it.
Booting processor 1/2 ip 4000
Not responding.
Inquiring remote APIC #2...
... APIC #2 ID: failed
... APIC #2 VERSION: failed
... APIC #2 SPIV: failed
CPU #2 not responding - cannot use it.
Booting processor 1/3 ip 4000
Not responding.
Inquiring remote APIC #3...
... APIC #3 ID: failed
... APIC #3 VERSION: failed
... APIC #3 SPIV: failed
CPU #3 not responding - cannot use it.
Total of 1 processors activated (5015.39 BogoMIPS).
ENABLING IO-APIC IRQs
..TIMER: vector=0x31 apic1=0 pin1=2 apic2=-1 pin2=-1
Brought up 1 CPUs

Please help. How do I fix this? It's kinda pointless having a boot option if I can't use it.

Thanks,
Sarav

Last edited by saravkrish; 05-25-2008 at 09:05 PM.
 
Old 05-27-2008, 08:59 AM   #2
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled
1) so you have not advised what happens if you do not arrow down at the grub menu???

2) IMHO this has nothing to do with grub but with your kernel selection and distro selection relative to your hardware.

3) does this hardware work with any distro including live cd that you know of?

4) until you get a better answer...if you have not run a good all round live cd such as knoppix...upload your /var/log/syslog to a on line site such as www.ripway.com so we can study your chipsets pls.

it is possible your kernel is hanging because it does not have the correct drivers or....needs a boot parameter aka cheat code...aka boot prompt to stop some driver loading etc
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
redhat enterprise linux 4 boots slow with 2 GB RAM , boots fast with 512MB robinsingh Linux - Hardware 14 08-27-2008 12:34 AM
/grub/menu.lst file disappeared but computer still boots (grub) rrrssssss Linux - General 5 04-08-2007 10:02 AM
problems booting a 2.6 kernel , 2.4 boots fine! dimgr Debian 2 12-27-2006 10:19 AM
boots fine, but won't pull up KDE. kells80 Mandriva 1 08-10-2004 06:53 AM
RH 8 - boots fine from floppy, not from Grub equack Linux - Newbie 29 03-26-2003 11:17 PM


All times are GMT -5. The time now is 05:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration