LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 01-08-2008, 10:29 PM   #1
crash_override_me
Member
 
Registered: Aug 2005
Location: India, New Delhi
Distribution: Debian Etch, Ubuntu
Posts: 342

Rep: Reputation: 30
fedora 8 eating up my limited internet usage


hi all,

just installed fedora 8.
started the inet connection (its dhcp) for the 1st time on it.
it seems something is eating up my precious MBs. i have only 2 GBs/month available.

is it something to related to automatic updates..??
plz help, before it eats up single MB left.
 
Old 01-09-2008, 01:13 AM   #2
LinuxManMikeC
Member
 
Registered: Nov 2007
Location: Provo, Utah
Distribution: Debian and Ubuntu
Posts: 74

Rep: Reputation: 15
Yep, that would probably be the auto update eating your bandwidth. Each boot will check for and download updated repository data (may also be a periodic check if the system is up long enough). When something has changed its usually a few MB per repository and when nothing has changed its much less traffic (no idea exactly how much though). Either way its a good idea to disable the auto updates on your limited bandwidth. To just disable the auto update checking you disable the service yum-updatesd. Better yet, you can uninstall the package yum-updatesd since you won't be using it anyway. I would advise running pup every week/2weeks/month and download what you consider the most important updates (at least security fixes).
 
Old 01-09-2008, 01:58 PM   #3
crash_override_me
Member
 
Registered: Aug 2005
Location: India, New Delhi
Distribution: Debian Etch, Ubuntu
Posts: 342

Original Poster
Rep: Reputation: 30
thanx for the info.
btw what is 'pup' ??
 
Old 01-09-2008, 03:49 PM   #4
LinuxManMikeC
Member
 
Registered: Nov 2007
Location: Provo, Utah
Distribution: Debian and Ubuntu
Posts: 74

Rep: Reputation: 15
Oh, sorry, are you a command line geek? Pup is just the standard GUI tool for package updates on Fedora. Pirut is the standard GUI tool for adding/removing packages. Both are just front-ends for yum. Or maybe you use some other GUI tool like yumex or the KDE one (forgot its name). Anyway, use some tool to check for updates at less frequent intervals.

Side note: I was just thinking, the whole point of this auto update tool is so you don't have to remember to check updates. Yum-updatesd could still be useful if you could configure it to check much less frequently. I checked the configuration file (/etc/yum/yum-updatesd.conf) and it stores its interval in seconds which has a default of 3600 seconds (1 hour) on my Fedora 7 system. Now it shouldn't be a problem setting this to an insanely huge value like 2592000 seconds (30 days), but I still think it will check on each boot. So if you reboot every day it will still run once every 24 hours, not once every 30 days. Not certain of this and I can find no documentation detailing startup behavior, but it seems to be how it works. Now I'm curios, if I figure this out I'll let you know.


List of long intervals converted to seconds if you feel like experimenting:
Default interval 1 hour (3600 seconds)
Weekly would be 604800 seconds
Bi-weekly 1209600 seconds
Monthly (30 days) would be 2592000 seconds
 
Old 01-09-2008, 04:22 PM   #5
LinuxManMikeC
Member
 
Registered: Nov 2007
Location: Provo, Utah
Distribution: Debian and Ubuntu
Posts: 74

Rep: Reputation: 15
Ok, my idea won't work unless you plan on keeping your computer on 24/7. Once yum-updatesd starts it waits for the specified interval and then checks if there are updates. So with a long wait value (and assuming you don't leave your computer running for weeks at a time) it would never check for updates. Therefore, there would be no reason running the service in the first place.

Please forgive me if you were bored, confused, or just plain didn't care. The short story is, get rid of yum-updatesd to save your limited bandwidth, but remember to manually check for updates periodically.
 
Old 01-10-2008, 03:42 AM   #6
crash_override_me
Member
 
Registered: Aug 2005
Location: India, New Delhi
Distribution: Debian Etch, Ubuntu
Posts: 342

Original Poster
Rep: Reputation: 30
nice analyses.. nyways i have disabled yum-updatesd in the startup services.!!
 
  


Reply

Tags
pup, update, yum


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Limited internet access - OS X Broder Other *NIX 3 06-02-2007 01:40 AM
Limited Internet theRobr Mandriva 5 03-23-2007 07:50 PM
limited internet surfing with Suse Linux 10.0 and Fritz!Box DSL (LAN setting) quantumnicity Linux - Networking 4 02-14-2006 04:13 AM
cant connect to the internet on the limited edition 2005 mairajas Linux - Networking 4 05-30-2005 09:33 PM
Fedora eating up RAM and CPU sokar Linux - General 2 01-25-2004 03:47 PM


All times are GMT -5. The time now is 09:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration