LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   Fedora 8 and compiz fusion.... (http://www.linuxquestions.org/questions/fedora-35/fedora-8-and-compiz-fusion-598547/)

sblantipodi 11-10-2007 05:27 AM

Fedora 8 and compiz fusion....
 
Hi,
I've got a GeForce 8600M GT using latest 100.14.19 driver.

When I run compiz-manager from a consolle I see:
compiz-manager
Checking for Xgl: not present.
Detected PCI ID for VGA: 01:00.0 0300: 10de:0407 (rev a1) (prog-if 00 [VGA])
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (1280x800) to maximum 3D texture size (8192): Passed.
Checking for nVidia: present.
Checking for FBConfig: present.
Checking for Xgl: not present.
Starting kde-window-decorator

why xgl is not present? What does it means?

Simon Bridge 11-10-2007 07:22 AM

Quote:

why xgl is not present? What does it means?
With nvidia card, perhaps you use aiglx? Does compiz work? Do you have 3D graphics OK? What is being loaded in /etc/X11/xorg.conf?

sblantipodi 11-10-2007 07:32 AM

Quote:

Originally Posted by Simon Bridge (Post 2954224)
With nvidia card, perhaps you use aiglx? Does compiz work? Do you have 3D graphics OK? What is being loaded in /etc/X11/xorg.conf?

This is my xorg.conf file:
Code:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder26)  Wed Sep 12 14:29:17 PDT 2007

# Xorg configuration created by pyxf86config

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Synaptics" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
    Load          "glx"
    # SubSection "extmod" Option "omit xfree86-dga" EndSubSection
EndSection

Section "InputDevice"
    Identifier    "Keyboard0"
    Driver        "kbd"
    Option        "XkbModel" "pc105"
    Option        "XkbLayout" "it"
EndSection

Section "InputDevice"
    Identifier    "Synaptics"
    Driver        "synaptics"
    Option        "Device" "/dev/input/mice"
    Option        "Protocol" "auto-dev"
    Option        "Emulate3Buttons" "yes"
EndSection

Section "InputDevice"
    Identifier    "Synaptics"
    Driver        "synaptics"
    Option        "Device" "/dev/input/mice"
    Option        "Protocol" "auto-dev"
    Option        "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
    Identifier    "Monitor0"
    VendorName    "Unknown"
    ModelName      "Unknown"
    HorizSync      30.0 - 110.0
    VertRefresh    50.0 - 150.0
    Option        "DPMS"
EndSection

Section "Device"
    Identifier    "Videocard0"
    Driver        "nvidia"
EndSection

Section "Screen"
    Identifier    "Screen0"
    Device        "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection    "Display"
        Viewport    0 0
        Depth      24
    Option "AddARGBGLXVisuals" "True"
    # Option "DynamicTwinView" "False"
    EndSubSection
Section "Extensions"
    Option "Composite" "Enable"
EndSection
EndSection

please help :(
Compiz seems to work but not all plugins.
I can display the cube but as I repeat not all plugins work.

Simon Bridge 11-10-2007 08:21 AM

Quote:

X configuration file generated by nvidia-xconfig
Could it be that you used the nvidia installer instead of yum?

I have options:
Code:

        Option          "AddARGBVisuals"        "True"
        Option          "AddARGBGLXVisuals"    "True"
        Option          "NoLogo"        "True"

... in the "device" section instead of "screen".

sblantipodi 11-10-2007 08:32 AM

Quote:

Originally Posted by Simon Bridge (Post 2954272)
Could it be that you used the nvidia installer instead of yum?

I have options:
Code:

        Option          "AddARGBVisuals"        "True"
        Option          "AddARGBGLXVisuals"    "True"
        Option          "NoLogo"        "True"

... in the "device" section instead of "screen".

I insert this options in the device section.
Same problem.

Compiz works, but compiz-manager tell me xgl not present. :(

Simon Bridge 11-10-2007 10:26 AM

Option "AllowGLXWithComposite" "true"

But:
http://en.wikipedia.org/wiki/AIGLX
.. you are using aiglx

sblantipodi 11-10-2007 07:15 PM

Quote:

Originally Posted by Simon Bridge (Post 2954382)
Option "AllowGLXWithComposite" "true"

But:
http://en.wikipedia.org/wiki/AIGLX
.. you are using aiglx

thanks for your reply.
I have added this line:
Option "AllowGLXWithComposite" "true"

compiz fusion seems to work well but I have another problem.

When using kde if I switch to framebuffer usinf CTRL + ALT + F1
and then return to kde with ALT + F7 kde seems to crash.
I see only a black windows and I need to kill kde with CTRL + ALT + BACKSPACE.

Can you help me please? This is very annoying...

Simon Bridge 11-11-2007 06:04 AM

Fedora has been a while for me now, but I thought ctrl-alt-F1 put you in tty1.
http://www.linuxquestions.org/questi...screen-385376/

There has been a bug in Beryl Core that shows this behavior:
https://bugs.launchpad.net/fedora/+s...re/+bug/107034
... ended as "invalid" as Beryl got merged with compiz.

http://gentoo-wiki.com/HOWTO_XGL/Troubleshooting
... gentoo wiki has a neet page on GLX troubleshooting.

i.e. There is a bug in the later drivers for mobile nvidia that does this.
Otherwise, you need to look in the syslog (prev session) to see if compiz is reporting any errors.

Ruling out compiz leads us into KDE/X/nvidia territory. If you are using the binary nvidia driver, then all bets are off. Especially if you used nvidia's installer (which yau have yet to confirm). If you disable compiz and use the free driver, does the problem remain?

sblantipodi 11-11-2007 06:16 AM

Quote:

Originally Posted by Simon Bridge (Post 2955071)
Fedora has been a while for me now, but I thought ctrl-alt-F1 put you in tty1.
http://www.linuxquestions.org/questi...screen-385376/

There has been a bug in Beryl Core that shows this behavior:
https://bugs.launchpad.net/fedora/+s...re/+bug/107034
... ended as "invalid" as Beryl got merged with compiz.

http://gentoo-wiki.com/HOWTO_XGL/Troubleshooting
... gentoo wiki has a neet page on GLX troubleshooting.

i.e. There is a bug in the later drivers for mobile nvidia that does this.
Otherwise, you need to look in the syslog (prev session) to see if compiz is reporting any errors.

Ruling out compiz leads us into KDE/X/nvidia territory. If you are using the binary nvidia driver, then all bets are off. Especially if you used nvidia's installer (which yau have yet to confirm). If you disable compiz and use the free driver, does the problem remain?

no, if I disable compiz all is ok.
is there a way to solve this problem?

Simon Bridge 11-11-2007 07:18 AM

http://ubuntuforums.org/archive/index.php/t-492763.html
... several ideas here that seem to help others.

sblantipodi 11-11-2007 09:13 AM

Quote:

Originally Posted by Simon Bridge (Post 2955114)
http://ubuntuforums.org/archive/index.php/t-492763.html
... several ideas here that seem to help others.

well, I simply solved installing 100.14.23 driver.
Thanks!!!

btbam88 02-22-2008 12:38 AM

woops
 
I actually tried to remove compiz fusion and try beryl... but once i tried it, i realized it couldn't work. I'm kinda new, so spare no detail. How do i reinstall compiz onto my Fedora core 8 computer?

Simon Bridge 02-24-2008 05:03 AM

probably:

yum install compiz compiz-gnome compiz-fusion-plugins-extra

... it's official now, so you can probably just select the packages with pirut.

Jongi 02-24-2008 11:02 AM

Do you use the livna repo? Did you install the kmod-nvidia driver? If yes, then

As root:

# livna-config-display

Tick Allow livna-config-display to edit configuration files
Choose AIGLX under Automatic Configuration.

I then used this guide to install compiz-fusion


All times are GMT -5. The time now is 02:27 PM.