LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   Fedora 7: system time not showing properly. (http://www.linuxquestions.org/questions/fedora-35/fedora-7-system-time-not-showing-properly-569737/)

LoveKing 07-16-2007 05:49 AM

Fedora 7: system time not showing properly.
 
I have a dual boot with windows xp sp2. I had installed Fedora 7 a week back. I am using KDE.

From the initial boot up the time is showing wrongly. I had set the time zone correctly to asia/Calcutta. still it is showing time wrongly. when i set it to local timezone the time is ahead by atleast 6 - 7 hours. To get the correct time i have to set the timezone to -1:00 gmt or to GMT.

The time is showing correctly in BIOS and also in windows. Where do i have to check out for correcting the problem?

fatzeus 07-16-2007 05:57 AM

I don't know where in Fedora, but probably you have set the clock time as localtime and not GMT.
You can set (maybe even in windows) if the time is stored in GMT or in your local timezone.

b0uncer 07-16-2007 05:59 AM

The problem is probably because Linux uses GMT time + localtime hours when it calculates the local time (that means: clock is set to GMT, then you tell in which timezone you are, and Linux tells you the time at that timezone - changing timezones is a matter of changing your location, not changing the actual machine clock). Windows doesn't use this setup, if I'm right, it just has one time which is your localtime. Some distributions ask you during your setup (at least if they find there's windows on board) if you're using localtime or GMT, so they can set the clock correctly. If you answer the "wrong" answer, your localtime is miscalculated and shows some hours less or more than you intended..

Fix is to tell Linux to use the correct timezone, or just GMT, so that it calculates the time correctly. Some distributions have the timezone set in /etc/environment, others elsewhere.

LoveKing 07-17-2007 11:36 AM

thanks for the reply fatzeus and b0uncer. Ok. i checked out the /etc/environment file and is was blank. then at terminal i executed cat /etc/timezone and it showed my timezone to be Asia/Calcutta. But still it is shows time ahead by 5:30 hours. so what u said is correct b0uncer. Linux takes up the system time and adds my timezone to it. since i am in india the timezone is +5:30 and so when it is 9 o clock in my wall clock here it shows 2:30 in the panel.
But that was not the case previously, in Fedora 6 and 5. there was no problem with time.

I tried to fiddle with the timezones and when i added UTC as additional timezone to be displayed. it displays the system time correctly.

when i place my mouse over the clock in kde it shows
Local Timezone 02:30, Wednesday 18 July 2007
UTC 21:00, Tuesday 17 Tuesday 2007.

Is there anyway: to keep my timezone settings and get correct time?

LoveKing 07-17-2007 12:14 PM

ok i solved the problem, or so i think.
i went to /etc/sysconfig/clock and editied it and set the UTC to false(it was set to true when i opened it). and i got my system time correct with my timezone intact.
I found about this in this thread
http://lists.kde.org/?l=kde-linux&m=112007294015819

Hope this helps somebody else too who has similar probs like mine.


All times are GMT -5. The time now is 03:48 PM.