LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 02-16-2014, 02:56 PM   #1
haziz
Member
 
Registered: Jan 2012
Location: /dev/null
Distribution: Slackware, Fedora, Debian, Centos, Ubuntu
Posts: 60

Rep: Reputation: 1
Fedora 20 Console Font?


I know how to edit the console font on Centos 6.5 by editing the SYSCONF entry in the /etc/sysconfig/i18n file, but I suspect this has changed in Fedora 20.

I have a laptop with a HiDPI high resolution screen (3200 x 1800 pixels) that is handled surprisingly well by Gnome 3.10 but I often work in a TTY terminal (alt ctrl F2-F6) and the font there is tiny.

How do adjust the font in the TTY terminal under Fedora 20?

Thanks.
 
Old 02-16-2014, 03:03 PM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,385

Rep: Reputation: 1089Reputation: 1089Reputation: 1089Reputation: 1089Reputation: 1089Reputation: 1089Reputation: 1089Reputation: 1089
Let me Google this for you:
https://ask.fedoraproject.org/en/que...-console-font/
 
Old 02-16-2014, 03:16 PM   #3
haziz
Member
 
Registered: Jan 2012
Location: /dev/null
Distribution: Slackware, Fedora, Debian, Centos, Ubuntu
Posts: 60

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by Didier Spaier View Post
I already saw that posting. However when I tried "sudo setfont lat2-sun32.psfu.gz" it had no visible effect and I was leery of changing my grub settings specially since my grasp of Grub2 is far less than my knowlege of Grub Legacy or LILO.

I also had a fun night trying to dual boot Fedora 20 and Windows 8.1 within a secure boot setup before giving up in disgust and just nuking the Windows install and reverting to Legacy BIOS. Interestingly I had succeeded in the past to setup a dual boot Ubuntu Install dual booting within secure boot setup, however GRUB now always failed to install even when I tried to reinstall Ubuntu. I have just had a fun 16 hours doing multiple installations while trying to dual boot Fedora with Windows, so I am being extra cautious now that I have a working Fedora only install.

Last edited by haziz; 02-16-2014 at 03:33 PM.
 
Old 02-16-2014, 03:52 PM   #4
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,385

Rep: Reputation: 1089Reputation: 1089Reputation: 1089Reputation: 1089Reputation: 1089Reputation: 1089Reputation: 1089Reputation: 1089
Quote:
Originally Posted by haziz View Post
However when I tried "sudo setfont lat2-sun32.psfu.gz" it had no visible effect [...]
Maybe this font is not installed ? see which fonts you have in /lib/kbd/consolefont.

Check also this page: http://daddy-linux.blogspot.fr/2012/...in-fedora.html
 
Old 02-16-2014, 03:56 PM   #5
haziz
Member
 
Registered: Jan 2012
Location: /dev/null
Distribution: Slackware, Fedora, Debian, Centos, Ubuntu
Posts: 60

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by Didier Spaier View Post
Maybe this font is not installed ? see which fonts you have in /lib/kbd/consolefont.

Check also this page: http://daddy-linux.blogspot.fr/2012/...in-fedora.html
It is installed. I can see it in my ls listing of /lib/kbd/consolfonts.
 
Old 02-16-2014, 04:07 PM   #6
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,385

Rep: Reputation: 1089Reputation: 1089Reputation: 1089Reputation: 1089Reputation: 1089Reputation: 1089Reputation: 1089Reputation: 1089
Do you type the command "sudo setfont lat2-sun32.psfu.gz" in the same tty where you want to display text?
What happens if you type "sudo su" followed by "setfont lat2-sun32.psfu.gz"?
Does the command work for other fonts?
 
Old 02-16-2014, 04:13 PM   #7
John VV
Guru
 
Registered: Aug 2005
Posts: 13,051

Rep: Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741
sudo is not set up by default
on fedora/rhel/cent you have to set it up if you want to use it

normally you would use
" su " or " su - "
 
Old 02-16-2014, 04:22 PM   #8
haziz
Member
 
Registered: Jan 2012
Location: /dev/null
Distribution: Slackware, Fedora, Debian, Centos, Ubuntu
Posts: 60

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by Didier Spaier View Post
Do you type the command "sudo setfont lat2-sun32.psfu.gz" in the same tty where you want to display text?
What happens if you type "sudo su" followed by "setfont lat2-sun32.psfu.gz"?
Does the command work for other fonts?
I think you nailed it. I was typing it in the graphical console and checking the result in the tty terminal.
 
Old 02-16-2014, 04:49 PM   #9
haziz
Member
 
Registered: Jan 2012
Location: /dev/null
Distribution: Slackware, Fedora, Debian, Centos, Ubuntu
Posts: 60

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by haziz View Post
I think you nailed it. I was typing it in the graphical console and checking the result in the tty terminal.
setfont does work within the same tty terminal. Now I have to figure out how to make the change permanent. Changing the kernel parameter in /etc/default/grub does not make a permanent change, and I did update grub with:

Code:
grub2-mkconfig -o /boot/grub2/grub.cfg
I have to look up the solution in the Debian forum since I remember seeing the solution there in the past.
 
Old 02-16-2014, 05:15 PM   #10
haziz
Member
 
Registered: Jan 2012
Location: /dev/null
Distribution: Slackware, Fedora, Debian, Centos, Ubuntu
Posts: 60

Original Poster
Rep: Reputation: 1
I haven't found a proper permanent solution till now but as a temporary measure I added a

Code:
setfont ter-c32b
line to my .bash_profile file, this way I have a readable terminal once I log into a tty terminal.
 
Old 02-17-2014, 02:12 AM   #11
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,385

Rep: Reputation: 1089Reputation: 1089Reputation: 1089Reputation: 1089Reputation: 1089Reputation: 1089Reputation: 1089Reputation: 1089
My guess (only a guess, as fortunately I'm not a Fedora user :-) is that you suffer from a change in Fedora 20, due to systemd introduction, in the way console settings are handled, so now you have to make your changes in /etc/vconsolefont instead of modifying the SYSCONF variable in /etc/sysconfig/i18n. See this page to know more.

PS It seems systemd was first at least partly introduced in Fedora18, so I'm not actually sure when this change was made.

Last edited by Didier Spaier; 02-17-2014 at 02:46 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Set console locale, font, and font size? penyuan Debian 3 12-09-2011 07:54 PM
Console font problem? Diggy Linux - General 3 04-05-2010 02:22 PM
Console font nc3b Slackware 4 08-18-2006 02:02 PM
console - own font ProfEich Programming 1 10-22-2005 08:29 AM
console font bboti Linux - General 1 09-25-2005 03:54 PM


All times are GMT -5. The time now is 03:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration