LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 01-30-2013, 06:18 PM   #1
rmknox
Member
 
Registered: May 2010
Posts: 352

Rep: Reputation: 29
fedora 17 boot problem - iscsiadm "no records found"


when i boot fedora 17 - instead of getting the complete boot with the graphical interface, it acts as if it were in terminal line mode and prompts me

login Knox:

I type knox

It prompts Password:

I type my password

It says
Quote:
iscsiadm no records found
and hangs

I find I can get around this by booting to level 1 and then typing init 5

Can someone explain to me what is going on?

FYI - I removed from my grub2 command file the 2 items that cause it to put up a splash screen during the boot - but I did this months ago when I was on fedora 16
 
Old 01-30-2013, 06:30 PM   #2
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,758

Rep: Reputation: 644Reputation: 644Reputation: 644Reputation: 644Reputation: 644Reputation: 644
Sounds like you have iscsi enabled and it's prompting for a password to log in to the storage .. are you using shared storage? .. maybe the password has been changed?
 
1 members found this post helpful.
Old 01-30-2013, 11:26 PM   #3
rmknox
Member
 
Registered: May 2010
Posts: 352

Original Poster
Rep: Reputation: 29
Quote:
Originally Posted by kbp View Post
Sounds like you have iscsi enabled and it's prompting for a password to log in to the storage .. are you using shared storage? .. maybe the password has been changed?
kbp
1) I should have mentioned this is fedora 3.7.3-101.fc16.i686

2) I must confess I know nothing about iscsi or shared anything

3) If you know how to do so - can you tell me how to disable iscsi - if that makes sense - It's just me and my desktop system

4) Maybe this latest kernel brought with it some default behaviour?

Thanks

Dick

The peculiar thing is that sometimes it boots ok and sometimes it doesn't. It seems like there may be some correlation with whether I touch the keyboard or mouse during the boot? - but coincidences can look like magic to those of us who are in the dark. When it does this thing I can get it to start by re booting to level 1 and then init 5.

Finally - this is an Intel Core 2 Duo CPU E4500@2.20GHz x 2
 
Old 01-30-2013, 11:34 PM   #4
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,758

Rep: Reputation: 644Reputation: 644Reputation: 644Reputation: 644Reputation: 644Reputation: 644
Open a terminal and try:

Code:
sudo systemctl stop iscsi.service
sudo systemctl disable iscsi.service
sudo systemctl stop iscsid.service
sudo systemctl disable iscsid.service
 
1 members found this post helpful.
Old 01-31-2013, 12:10 AM   #5
rmknox
Member
 
Registered: May 2010
Posts: 352

Original Poster
Rep: Reputation: 29
Quote:
Originally Posted by kbp View Post
Open a terminal and try:

Code:
sudo systemctl stop iscsi.service
sudo systemctl disable iscsi.service
sudo systemctl stop iscsid.service
sudo systemctl disable iscsid.service
ok i did so and here is the result
Quote:
[knox@knox ~]$ sudo systemctl stop iscsi.service
[sudo] password for knox:
[knox@knox ~]$ sudo systemctl disable iscsi.service
iscsi.service is not a native service, redirecting to /sbin/chkconfig.
Executing /sbin/chkconfig iscsi off
[knox@knox ~]$ sudo systemctl stop iscsid.service
[knox@knox ~]$ sudo systemctl disable iscsid.service
iscsid.service is not a native service, redirecting to /sbin/chkconfig.
Executing /sbin/chkconfig iscsid off
[knox@knox ~]$
I've just read a description of iscsi and it does not in any way apply to me and my desktop

I asked yum to tell me what is installed and I find
Quote:
iscsi-initiator-utils.i686 6.2.0.872-18.fc17 @anaconda-0
would it make sense to ask yum to remove those utilities? Or maybe ask yum to tell me who depends on them and what would be the consequence of removing them? I understand fedora 17 and particularly 18 are involved in leading edge server issues. I am not.

And thank you so much - so much to learn - so little time.
 
Old 01-31-2013, 04:38 AM   #6
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,758

Rep: Reputation: 644Reputation: 644Reputation: 644Reputation: 644Reputation: 644Reputation: 644
Definitely .. just do:

Code:
yum erase iscsi-initiator-utils
.. and see what other packages it wants to remove, if you're happy for them to be erased then say 'yes'
 
1 members found this post helpful.
Old 01-31-2013, 10:23 AM   #7
rmknox
Member
 
Registered: May 2010
Posts: 352

Original Poster
Rep: Reputation: 29
Quote:
Originally Posted by kbp View Post
Definitely .. just do:

Code:
yum erase iscsi-initiator-utils
.. and see what other packages it wants to remove, if you're happy for them to be erased then say 'yes'
kbp

ok - I did and there was nothing that depended on it so I said yes
and again - thanks so much for your help

Dick
Quote:
[knox@knox ~]$ sudo yum erase iscsi-initiator-utils
[sudo] password for knox:
Loaded plugins: auto-update-debuginfo, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package iscsi-initiator-utils.i686 0:6.2.0.872-18.fc17 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

==================================================================================================== ========================================
Package Arch Version Repository Size
==================================================================================================== ========================================
Removing:
iscsi-initiator-utils i686 6.2.0.872-18.fc17 @anaconda-0 1.9 M

Transaction Summary
==================================================================================================== ========================================
Remove 1 Package

Installed size: 1.9 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Erasing : iscsi-initiator-utils-6.2.0.872-18.fc17.i686 1/1
Verifying : iscsi-initiator-utils-6.2.0.872-18.fc17.i686 1/1

Removed:
iscsi-initiator-utils.i686 0:6.2.0.872-18.fc17

Complete!
[knox@knox ~]$
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
iscsiadm: no records found! amalik Linux - Server 1 03-12-2012 10:33 PM
iscsiadm records not found after restarting the service... CubanCracker Linux - Newbie 0 11-04-2010 03:23 PM
first line on disp during boot "doing fast boot", then "FATAL: mbcache not found" rangerpresto Suse/Novell 2 02-13-2010 11:18 PM
Fedora 10 "volume group volgroup00 not found" == no boot srozing Linux - Newbie 5 04-15-2009 09:49 AM


All times are GMT -5. The time now is 06:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration