LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 05-28-2011, 04:52 PM   #1
PreacherBill
Member
 
Registered: Nov 2006
Location: Louisville, KY
Distribution: CentOS 6
Posts: 41

Rep: Reputation: 15
Fedora 15 not mounting NFS shares from fstab


I have just upgraded to F15 as well as switching from Gnome to XFCE, so I don't know where this problem originates. NFS shares that were previously mounted via the fstab file in F14 don't now. Based on the log file, it appears that they are attempting to be mounted before the network interface is brought up. They mount fine manually after logon.

I expect that there are a few ways to hack around this, but I think mounting nfs from fstab should be a common enough thing that it should work without hacks. Any ideas?

TIA

Bill
 
Old 05-29-2011, 02:00 AM   #2
webbch
LQ Newbie
 
Registered: May 2011
Posts: 2

Rep: Reputation: Disabled
I'm having an identical problem trying to mount my Windows shares using fstab. I can mount manually after boot (mount -t cifs //WINDOWSBOX01/C /mnt/WindowsBox01/C), but not using fstab. Also, 'mount -a' doesn't appear to reload the fstab either. Instead, I get a message,
"mount: sysfs already mounted or /sys busy"
"mount: according to mtab, /sys is already mounted on /sys"
 
Old 05-30-2011, 09:16 AM   #3
falcom
Member
 
Registered: May 2009
Posts: 102

Rep: Reputation: 13
if your partition or HD is windows NTFS system, first you need
Quote:
yum install -y ntfd-3g
after you agree in your /etc/fstab file
it's all !!
works perfect!
 
Old 05-30-2011, 02:57 PM   #4
PreacherBill
Member
 
Registered: Nov 2006
Location: Louisville, KY
Distribution: CentOS 6
Posts: 41

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by falcom View Post
if your partition or HD is windows NTFS system, first you need
It's all linux I'm afraid, so that's not it.

I just wish I knew if it was a Fedora or Xfce issue.

Thanks anyway!
 
Old 05-31-2011, 08:18 AM   #5
falcom
Member
 
Registered: May 2009
Posts: 102

Rep: Reputation: 13
sorry i have a error the correct command is
Quote:
yum install -y ntfs-3g ntfs-config
ok i have 3 hd in my pc and many partitions, lock my fstab
Quote:
/dev/sdb1 /media/Rafha ext3 defaults 0 0
or
Quote:
/dev/sdb2 /media/Rafha2 ntfs defaults 0 0
 
Old 05-31-2011, 08:19 AM   #6
falcom
Member
 
Registered: May 2009
Posts: 102

Rep: Reputation: 13
Quote:
Originally Posted by PreacherBill View Post
It's all linux I'm afraid, so that's not it.

I just wish I knew if it was a Fedora or Xfce issue.

Thanks anyway!
is not a problem in linux is only configuration problem
 
Old 05-31-2011, 08:21 AM   #7
falcom
Member
 
Registered: May 2009
Posts: 102

Rep: Reputation: 13
Quote:
Originally Posted by punt View Post
falcom, I am encountering the same issue with NTFS mounts (pretty sure you meant ntfs-3g) and I am in the same boat as PreacherBill. The mounts are being brought up before the network interface is being brought up. How does one prioritize differently? I have so many mounts that it locks up my computer....
you can try to boot fedora you can press the space bar and go priority or discarding the services you up if that's what you want?
 
Old 05-31-2011, 08:58 AM   #8
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,899

Rep: Reputation: 746Reputation: 746Reputation: 746Reputation: 746Reputation: 746Reputation: 746Reputation: 746
NTFS and nfs are completely different. NTFS is a filesystem and nfs is a networking protocol.
ntfs-3g is for mounting local NTFS file systems and not for networking. samba is an implementation of the MS SMB/CIFS protocol which is used to share files and printers with windows.

I'm not sure what Fedora had implemented/changed in its start up scripts etc.
There are several methods.

Check out the -o _netdev option which delays mounting network shares. See man mount for details.
The quickest an easiest method would be to put the mount command in /etc/rc.local
or using autofs:
http://fedoraproject.org/wiki/Docs/Drafts/AGBeta/NFS
 
Old 06-02-2011, 12:37 AM   #9
webbch
LQ Newbie
 
Registered: May 2011
Posts: 2

Rep: Reputation: Disabled
I had a syntax error in my fstab....All is well now. Here's the syntax for my mount
//WINDOWSBOX01/C /mnt/WindowsBox01/C cifs credentials=/etc/cifspw 0 0

where "cifspw" file just has two lines:
username=myusername
password=mypassword

Still get the odd warning message when I issue a "mount -a", but it does re-mount my shares just fine.
 
Old 06-03-2011, 09:17 PM   #10
blackjackshellac
LQ Newbie
 
Registered: Aug 2007
Posts: 2

Rep: Reputation: 0
Quote:
Originally Posted by PreacherBill View Post
I have just upgraded to F15 as well as switching from Gnome to XFCE, so I don't know where this problem originates. NFS shares that were previously mounted via the fstab file in F14 don't now. Based on the log file, it appears that they are attempting to be mounted before the network interface is brought up. They mount fine manually after logon.

I expect that there are a few ways to hack around this, but I think mounting nfs from fstab should be a common enough thing that it should work without hacks. Any ideas?

TIA

Bill
I think you have to enter a comment=systemd.mount option in fstab, haven't tried it yet but this seems to be what one needs,

Check this out: https://fedoraproject.org/wiki/User:.../Systemd.mount
 
Old 06-05-2011, 05:15 AM   #11
skiyengar
LQ Newbie
 
Registered: Jun 2011
Posts: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by PreacherBill View Post
I have just upgraded to F15 as well as switching from Gnome to XFCE, so I don't know where this problem originates. NFS shares that were previously mounted via the fstab file in F14 don't now. Based on the log file, it appears that they are attempting to be mounted before the network interface is brought up. They mount fine manually after logon.

I expect that there are a few ways to hack around this, but I think mounting nfs from fstab should be a common enough thing that it should work without hacks. Any ideas?

TIA

Bill
I've the same problem.. Connection times out. But works fine if firewall is stopped. It definitely is a firewall configuration issue.
 
Old 07-05-2011, 03:16 PM   #12
PreacherBill
Member
 
Registered: Nov 2006
Location: Louisville, KY
Distribution: CentOS 6
Posts: 41

Original Poster
Rep: Reputation: 15
Sorry about leaving this thread hanging. I have been out of town far more than in for the last month.

I solved this problem (for now) by reverting back to F14. This gives me some time to figure out where I'm going to go. I am simply not satisfied with the options offered in F15. I'm not saying the changes are bad, but they don't allow me to work the way I need/want to. So it's time to look at other distros.

Thanks for all the comments!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fstab Mounting Windows Shares...help ssa2204 Linux - Newbie 2 08-19-2006 11:16 PM
Conditionally mounting nfs shares eagle862 Linux - Networking 1 11-02-2004 11:46 PM
Mounting Windows shares in fstab raypen Slackware 4 10-16-2004 05:16 PM
mounting w2k shares in fstab GraemeK Linux - Networking 2 01-30-2004 04:49 AM
Support for mounting NFS shares glock19 Linux - General 1 05-09-2002 07:02 PM


All times are GMT -5. The time now is 01:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration