LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 08-22-2010, 11:31 AM   #1
frsepulv
LQ Newbie
 
Registered: Aug 2010
Location: Valparaiso, Chile
Distribution: Fedora
Posts: 3

Rep: Reputation: 0
Fedora 13 sound problem - HDA Intel


Hi,

I've a HP 420 laptop (it looks like it's not sold everywhere, here are some specifications - Spanish site: http://h10010.www1.hp.com/wwpc/cl/es...8-4158858.html) and I've recently installed Fedora 13. Everything works smoothly, except for the audio device, which doesn't output sound through the external speakers (headphones work, though).

System information:

Code:
$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: HDA Generic [HDA Generic]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 3: INTEL HDMI 0 [INTEL HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

$ lspci -v | grep Audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

$ cat /proc/asound/card0/codec#* | grep Codec
Codec: IDT ID 7666
Codec: LSI ID 1040
Codec: Intel G45 DEVCTG
I've pretty much read every single thread existing on the Internet looking for a solution. Google produced only one thread for this model (Spanish forum, no answer so far). Every other possible solution hasn't worked - editing alsa-base.conf with several models (hp, hp-m4, hp-dv5, laptop, auto, genric and a few others I can't recall) and options (enable-msi, single_cmd, bdl_pos_adj, etc.). I've used Windows 7 on this laptop and sound works flawlessly there.

Any help would be greatly appreciated. Please excuse my rough English, you may've realized it isn't my native language.

Thanks.
 
Old 08-22-2010, 01:39 PM   #2
smoker
Senior Member
 
Registered: Oct 2004
Distribution: Fedora Core 4, 12, 13, 14, 15, 17
Posts: 2,279

Rep: Reputation: 248Reputation: 248Reputation: 248
From the fact that the sound works through the headphones, we can deduce that it's not a driver issue. Have you got the pulse audio device chooser installed ? If you have, check that the output device is set correctly. if you haven't, then it's worth installing it and various other sound related tools :
Code:
yum install alsa-plugins-pulseaudio pulseaudio-esound-compat pulseaudio-libs pulseaudio-libs-glib2 pulseaudio-module-zeroconf pulseaudio-libs-zeroconf xmms-pulse pulseaudio-module-gconf wine-pulseaudio xine-lib-pulseaudio pulseaudio-utils pulseaudio-module-bluetooth gst-mixer padevchooser paman paprefs pavucontrol pavumeter

Last edited by smoker; 08-22-2010 at 01:40 PM.
 
Old 08-23-2010, 10:23 AM   #3
frsepulv
LQ Newbie
 
Registered: Aug 2010
Location: Valparaiso, Chile
Distribution: Fedora
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by smoker View Post
From the fact that the sound works through the headphones, we can deduce that it's not a driver issue. Have you got the pulse audio device chooser installed ? If you have, check that the output device is set correctly. if you haven't, then it's worth installing it and various other sound related tools
padevchooser wasn't installed, so I installed it and all those tools you suggested. After checking with padevchooser I couldn't see anything blatantly wrong with it. I attach a screenshot showing some hardware info. There is one audio device (Internal Audio Analog Stereo) which produces an input and an output subdevice and allows to choose the following configuration profiles:
  • Analog Stereo Duplex
  • Analog Stereo Output
  • Digital Stereo (HDMI) Output + Analog Stereo Input
  • Digital Stereo (HDMI) Output
  • Analog Stereo Input
  • Disabled

Excluding the info in the screenshot, this is the same data I could gather from gnome-volume-control.
Attached Images
File Type: png Screenshot.png (65.5 KB, 14 views)
 
Old 08-23-2010, 10:31 AM   #4
smoker
Senior Member
 
Registered: Oct 2004
Distribution: Fedora Core 4, 12, 13, 14, 15, 17
Posts: 2,279

Rep: Reputation: 248Reputation: 248Reputation: 248
Did you actually try changing any of the settings in padevchooser ? I've found that unless you specifically select a default sink by clicking on it, you get no sound.
 
Old 08-23-2010, 05:30 PM   #5
frsepulv
LQ Newbie
 
Registered: Aug 2010
Location: Valparaiso, Chile
Distribution: Fedora
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by smoker View Post
Did you actually try changing any of the settings in padevchooser ? I've found that unless you specifically select a default sink by clicking on it, you get no sound.
Yeah, I've played with pretty much every option I could (clicked on all devices on the list, changed default sink, got a volume to ~2300%, etc.) Still no sound from speakers. I get the feeling this is like an "invisible headphone set" is always connected - no errors appear when I unplug the headphones (which I would expect if it tries to send sound through an non existent device) and volume monitors show normal audio activity whenever a sound should be heard.

Would it do any good if I try switching to KDE? I understand Phonon replaces PulseAudio there.
 
  


Reply

Tags
fedora, hp, sndhdaintel


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No Sound with Fedora 10 on ATI Tech SBx00 Azalia (Intel HDA) linuxdawg Linux - Laptop and Netbook 5 06-07-2009 05:27 AM
sound recording problem - snd-hda-intel bad_zeppelin Linux - Hardware 5 03-19-2007 05:15 PM
Problem with Intel HDA sound card DeNayGo Linux - Hardware 6 03-04-2007 06:15 PM
Problem with HDA-intel sound card FC5 tuxtoti Fedora 5 05-23-2006 01:25 AM
Problem with HDA-intel sound card FC5 tuxtoti Linux - Hardware 3 04-12-2006 09:03 PM


All times are GMT -5. The time now is 05:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration