LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   Fedora 12 + No Sound (http://www.linuxquestions.org/questions/fedora-35/fedora-12-no-sound-773082/)

sparker 12-02-2009 09:02 PM

Fedora 12 + No Sound
 
I have recently done a fresh install of fedora 12 (gnome) and everything seems to be working just fine except for there is no sound at all.

I did not encounter this problem when using fedora 10. I have gathered the information about my sound card which can be found here:

http://www.alsa-project.org/db/?f=fc...96070ffe3b3fc6

Thanks.

michael.guerrero 12-02-2009 09:30 PM

I have the same problem.

I ran the alsa-info.sh

http://www.alsa-project.org/db/?f=7e...ebfa04852520e4

michael.guerrero 12-02-2009 09:50 PM

Oh my god...I installed the Pulse Audio volume control and never checked it. When I went to look at it the audio channel was muted. This isn't the Alsa mixer, this is the Pulse Audio Volume Control.

In KDE, Applications > Multimedia > Volume Control.

That was dumb.

Nich Saville 12-27-2009 11:20 AM

I also have no sound after installing Fedora 12. There wasn't much under Fedora 10 but at least SoundRecorder worked. This has now vanished. As recommended above I ran alsa-info.sh. This advised a change to all config files. There are over 100 of them!

Any help would be gratefully received!

As an extra, anyone who knows how to e-mail Bruno Wolf III please give him my profound thanks: without his help I had no floppy, another fedora 12 howler. And, by the way, where is Open Office in Fedora 12?

justaguy_75ae 01-18-2010 11:18 AM

1. Do you still have pulseaudio installed
*fedora is completely dependent on Pulse for sound almost.


2. is pulseaudio running in the process id
go to applications->system monitor and search for it.


3. run lspci and post the output
and post the output here.... lspci shows vital hardware information

Applications->System Tools->Terminal

lspci
<hit enter>



4. if you have an onboard sound card and and installed card make sure the onboard is disabled if you are using an installed card vs onboard, also make sure your speakers are connected the right outputs.


5. try alsa mixer to make sure it has not been muted
make sure <front> and <pcm front> and <pcm> are at 100 %

Applications->System Tools->Terminal
alsamixer -c <cardnumber>

<cardnumber> is usually 1 or zero. if pulse audio shows up as a device make sure it is at 100 volume level and then move to the next number
till your card shows up exclude < >

to exit alsa mixer press Esc
... after words to exit terminal type exit and hit enter.

6. Try the digital / analog out settings, that causes sound loss too. that had been an issue in previous fedora for me, but not fedora 11 and 12 for me.
* if you left alsamixer restart it with the proper card number then press f5
then click the left arrow until you see in Analog/Digital ouput jack and toggle it using m. DO NOT CLOSE out alsamixer at this point test your sound if it does not work still then you best untoggle it before you close out... by pressing m again.

7. you need to install pavucontrol

su -c 'yum install pavucontrol'

it is very powerful utility for managing sound

the installed app will be found in Applictions -> Sound & Video -> Pulse Audio Volume Control

it allows you to select Ouput Devices, Input Devices, Recording levels. and adjust volume.

Completely Clueless 01-28-2010 11:07 AM

Quote:

Originally Posted by justaguy_75ae (Post 3831056)
1. Do you still have pulseaudio installed
*fedora is completely dependent on Pulse for sound almost.
[...]
7. you need to install pavucontrol

su -c 'yum install pavucontrol'

it is very powerful utility for managing sound

the installed app will be found in Applictions -> Sound & Video -> Pulse Audio Volume Control

it allows you to select Ouput Devices, Input Devices, Recording levels. and adjust volume.

One vital step missing from the above.
Once installed, go to the pulse audio control configuration tab and change the default "analogue stereo input" to one of the other choices including an output option! Also check to ensure the speaker symbol on the Fedora task bar is showing un-muted.

Nich Saville 01-30-2010 04:24 AM

Fedora 12 sound
 
Thanks for all the advice! Sorry I didn't do this before but I had trouble registering. I became so fed up with Fedora 12 that I went back to Fedora 10 with which I can record and play sound.
The one exception to this is recording sound with Java.
This although it apparently works only records silence. However, I believe this to be a Java bug since Sound Recorder works OK. It is worth noting, though, that Audacity refuses to record more than 1/2 seconds worth under Fedora 10.


All times are GMT -5. The time now is 02:57 AM.