LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 04-18-2010, 06:27 PM   #1
Nivag
LQ Newbie
 
Registered: Dec 2009
Location: Auckland, New Zealand
Distribution: Fedora
Posts: 7

Rep: Reputation: 0
Lightbulb Fedora 12 Firefox 64 bit flash pulse audio no sound - resolved


The situation was that I had 2 Fedora 12 boxen.

One played flash videos with sound, and one did not!

Eventually I found the actual problem, and it was trivially fixed (I don't want to remember the many blind alleys I went into first...).

When I looked at
System ==> Sound Preferences ==> Sound
and selected the 'Applications' tab, I got the line:
"No application is currently running or recording audio.",
but the Mute check box to the right of the 'Output Volume' slider at the top of the tab was unticked.

However, when I was running a flash video, I had a line:
"ALSA plug-in (npviewer.bin) ..." with another Mute check box on the right that was ticked! Unticking this new Mute check box, enabled Firefox to play YouTube video's with sound!
 
Old 06-13-2010, 04:53 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,139
Blog Entries: 54

Rep: Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791
Thanks for posting back the fix!

//NTLB (and marked SOLVED for OP)
 
Old 11-24-2010, 12:44 AM   #3
bill_mcgonigle
LQ Newbie
 
Registered: Sep 2009
Posts: 3

Rep: Reputation: 0
Smile

Thanks - I had a similar problem on f14 and this got me close.

On mine, my video card's HDMI sound output was set at a higher preference than the motherboard audio (I use a DVI cable to my monitor). In KDE's Multimedia/Phonon control panel, I needed to click on each category, including the root of the settings tree, and select the internal audio and click 'Prefer (Up)' on each.

This was perplexing because system sounds were working, and set to the internal audio, for some reason. The symptom in Flash plugin was the video running at high speed. No need to even refresh the webpage once this setting was re-configured.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Myspace audio player doesn't work (Firefox, Flash, x86_64, Fedora 10) daw617 Linux - Software 3 02-25-2009 09:02 AM
Pulse audio detects hardware but no playback fedora 8 blitz2190 Linux - Software 0 08-23-2008 04:34 PM
network sound with Pulse Audio mattd7591 Linux - General 0 03-29-2008 10:00 PM
no audio flash player firefox 32-bit browser, RHEL4, x86_64. saak.stepi Linux - Software 1 01-11-2008 07:05 PM
no sound with Pulse-audio and xmms Brynn Linux - Software 2 12-06-2007 04:03 PM


All times are GMT -5. The time now is 06:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration