LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 02-12-2010, 05:03 PM   #1
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
Fedora 12 and i915GM


Hi.

I have some problems with Fedora 12 and the main is I can notice flickers on my notebook LCD.
I have checked with xrandr - it shows 60 Hz - in the output everything like in opensuse.
But I do not see any flickers on opensuse, I see them on Fedora.
I was trying to turn off TV1 and VGA1 - did not help.
I was not able to change uxa driver to something else, like xaa or exa, may be that can help. It looks like vertical refresh is not 60Hz, or may be not always.

May be some one can help me with it, some pages, or bugs about it.
Because I can't use fedora longer then one hour, I start to feel pain in my eyes.

Thanks.

Last edited by nimnull22; 02-12-2010 at 05:08 PM.
 
Old 02-13-2010, 07:52 AM   #2
smoker
Senior Member
 
Registered: Oct 2004
Distribution: Fedora Core 4, 12, 13, 14, 15, 17
Posts: 2,279

Rep: Reputation: 248Reputation: 248Reputation: 248
Which driver are you using ? try disabling the automatic fedora (plymouth) driver settings at boot.

When you boot, select to modify the kernel parameters and add
nomodeset=1 to the end of the line.

If that works, modify /boot/grub/grub.conf to have the same parameter at the end of the relevant line for the relevant kernel.

regards

Alan
 
Old 02-13-2010, 08:45 AM   #3
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Original Poster
Rep: Reputation: 92
Driver i915, for Xorg - uxa, refresh rate and size 1024x768 65Hz. Everything the same with opensuse, but looks different.
Sometimes, when I do not look directly on screen, but on keyboard or near, I can notice picture a little bit flickers. I have never notice it before.

I will try "nomodeset=1"
 
Old 02-13-2010, 01:19 PM   #4
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Original Poster
Rep: Reputation: 92
Checked this - did not help. And it looks like, I can't anything except UXA, I did not found way how to tell X11 use xaa or exa.
I also was unable to disable DRI2, X11 still use it, "even it is disabled by default"

Need help - how to disable DRI2, I want to check difference. I do not have it in opensuse 11.1

Thanks.
 
Old 02-13-2010, 01:58 PM   #5
smoker
Senior Member
 
Registered: Oct 2004
Distribution: Fedora Core 4, 12, 13, 14, 15, 17
Posts: 2,279

Rep: Reputation: 248Reputation: 248Reputation: 248
I'm not comfortable hacking your xorg.conf from a distance. You say you want a 60Hz setting but then you mention you have a 65Hz setting ...
 
Old 02-13-2010, 02:29 PM   #6
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Original Poster
Rep: Reputation: 92
Normal output is:
LVDS connected 1024x768+0+0 (normal left inverted right x axis y axis) 304mm x 228mm
1024x768 60.0*+
800x600 60.3
640x480 59.9

But -v --verbose:
1024x768 (0x3c) 65.0MHz -HSync -VSync *current +preferred
h: width 1024 start 1048 end 1184 total 1344 skew 0 clock 48.4KHz
v: height 768 start 771 end 777 total 806 clock 60.0Hz

And it is the same with opensuse output, but picture is different.
I can read man xorg.conf, it is not necessary to hack it, but in man page there is not option to enable XAA or EXA.
 
Old 02-13-2010, 02:44 PM   #7
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Original Poster
Rep: Reputation: 92
In my opensuse Xorg.conf, I can use
Option "AccelMethod" "xaa|exa"

But my server 1.5.2. On fedora 12 I have 1.7.4, and it tells me
(W) intel (0): Option "AccelMethod" is not used.

So I assume, I can't use XAA.

Last edited by nimnull22; 02-13-2010 at 04:37 PM.
 
Old 02-13-2010, 11:04 PM   #8
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Original Poster
Rep: Reputation: 92
I've managed to fix a VESA driver for i915:
VESA(0): VESA VBE OEM: Intel(r)915GM/910ML/915MS Graphics Chip Accelerated VGA BIOS

And I perfectly see everything - like in opensuse.
So I thing that UXA + DRI2 = piece of ****.

I am going to use VESA by now, and my ayes will be fine.
 
Old 02-14-2010, 03:58 PM   #9
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Original Poster
Rep: Reputation: 92
No way. Unfortunately.

After 4 hours I can notice flicker on first blue screen with logo "F" within boot time.
Looks like it is not problem with X11 and its drivers.

Anyway - the result is I can't use it.
Strange, but I've never experience anything like it on suse 11.1 - but it uses different kernel. I will check their LiveCD with the same kernel and post my opinion.

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
i915GM graphics card, x was working, now isn't Peterius Linux - Laptop and Netbook 11 05-08-2007 01:14 PM
Very bad i915gm performance noteventime Linux - Hardware 2 04-16-2006 02:10 PM
Installing DRI on Intel i915gm Abomb Linux - Software 1 03-22-2006 10:38 AM
Dell Inspiron 6000 and i915GM not working R4cOOn Linux - Laptop and Netbook 2 09-20-2005 10:23 PM
Configuration troubles on XFree86 4.5.0 with i915GM michalceri Linux - Laptop and Netbook 2 09-16-2005 02:36 AM


All times are GMT -5. The time now is 08:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration