LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   Fedora 11 running very HOT on thinkpad X61s (http://www.linuxquestions.org/questions/fedora-35/fedora-11-running-very-hot-on-thinkpad-x61s-742244/)

rasaan 07-23-2009 10:20 AM

Fedora 11 running very HOT on thinkpad X61s
 
Hi all,

I realize that my computer is getting very hot whenever I run Fedora. Any insight out there? Any help would be greatly appreciated.

thanks, Rasaan

serafean 07-23-2009 11:10 AM

Hi, first check if any process is using 100% (or less, but constantly) of your cpu ('top' command in a terminal is good for this). Then check that cpu frequency scaling is enabled in the BIOS and in Fedora. Last, check your computer for dust : it prevents the airflow and thus reducing greatly thecooling potential of your fans.

rasaan 07-24-2009 12:14 AM

Thanks for the response. This is the output from the top command. I figured it had to do with CPU. How do I proceed with the BIOS step?

thanks,
Rasaan

[rasaan@localhost ~]$ top

top - 21:12:28 up 12:08, 4 users, load average: 1.82, 1.42, 1.31
Tasks: 163 total, 3 running, 160 sleeping, 0 stopped, 0 zombie
Cpu(s): 59.3%us, 3.5%sy, 0.0%ni, 37.2%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st
Mem: 3946400k total, 2723744k used, 1222656k free, 111992k buffers
Swap: 5996536k total, 0k used, 5996536k free, 1867808k cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
2143 rasaan 20 0 319m 15m 10m R 93.3 0.4 709:26.34 gnome-panel
4845 rasaan 20 0 1126m 237m 33m R 18.3 6.2 50:26.75 firefox
2233 root 20 0 413m 127m 23m S 5.6 3.3 11:49.79 Xorg
5059 rasaan 20 0 279m 16m 10m S 4.6 0.4 0:07.63 gnome-terminal
2456 rasaan 20 0 494m 6468 4748 S 2.3 0.2 12:56.30 pulseaudio
5815 rasaan 20 0 493m 41m 14m S 0.7 1.1 0:42.32 evince
2461 rasaan 20 0 779m 46m 19m S 0.3 1.2 0:51.75 nautilus
2487 rasaan 20 0 163m 8176 4744 S 0.3 0.2 0:49.47 compiz
2789 rasaan 20 0 274m 20m 5316 S 0.3 0.5 0:08.71 gnome-screensav
5950 rasaan 20 0 14856 1176 852 R 0.3 0.0 0:00.28 top
1 root 20 0 4076 856 596 S 0.0 0.0 0:00.99 init
2 root 15 -5 0 0 0 S 0.0 0.0 0:00.01 kthreadd
3 root RT -5 0 0 0 S 0.0 0.0 0:00.00 migration/0
4 root 15 -5 0 0 0 S 0.0 0.0 0:00.50 ksoftirqd/0
5 root RT -5 0 0 0 S 0.0 0.0 0:00.00 watchdog/0
6 root RT -5 0 0 0 S 0.0 0.0 0:00.00 migration/1
7 root 15 -5 0 0 0 S 0.0 0.0 0:00.17 ksoftirqd/1

karamarisan 07-24-2009 12:37 AM

BIOS setup? Your problem is that gnome-panel is running amok. Try removing applets from it one at a time and watching top to see which one was causing the high CPU usage.

rasaan 07-24-2009 12:58 PM

Appreciate the input. How do I see a listing of gnome panel applets?

Rasaan

karamarisan 07-24-2009 02:38 PM

There's surely a way, but why not just right-click on and remove them one at a time? gnome-panel is the bar on top/bottom of your screen. Start with anything that updates.

mek 07-28-2009 07:13 AM

try to check if you have the latest firmware for your BIOS laptop, sometimes there are issues with these laptops, that are solved with a firmware upgrade(thermal problems, IRQ freezes, etc.)

rasaan 07-29-2009 11:16 AM

Thanks for the input!

initself 12-21-2015 12:12 AM

X61s systems are known to run hot on any OS, particularly under the right keyboard rest, where the WiFi card is located. Poor design. Perhaps you can disable the card and run a USB WiFi dongle.

John VV 12-21-2015 12:04 PM

initself

i take it you did not see the DATE??????

this is a 6 year old thread

and for a LONG dead and long unsupported Fedora 11
the current is Fedora 23


All times are GMT -5. The time now is 05:38 PM.