LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 07-06-2009, 02:35 PM   #1
bcage
LQ Newbie
 
Registered: Jun 2005
Distribution: Fedora 11
Posts: 22

Rep: Reputation: 16
Fedora 11 - Firefox 3.5, Flash content has no sound


I am running Fedora 11 for AMD64 and Firefox 3.5 with the Adobe flash plugin installed. I can get video, but not sound. I have trolled through the internet for this and it seems to be a common problem, but I have yet to find the solution.

Sound on the system does work. I can playback mp3 in Amarok and videos through VLC with sound. Also, sound in Firefox works also (e.g. I can play the embedded video on the "You have upgraded to Firefox 3.5" page and the sound plays fine.

If I go to youtube or a similar site, I get video, no sound.

In the system log I can see a series of errors like:
pulseaudio[4053]: reserve-wrap.c: Failed to acquire reservation lock on device 'Audio0': Input/output error

This is interesting since the other programs seem to have no problems getting whatever locks are required. Otherwise, I cannot see any errors.

As I said before, this seems to be a common problem with no posted solutions. Earlier versions of Fedora seemed to fix this by installing libflashsupport, but that seems to be no longer available for since Fedora 10.

Any insight you can provide will be greatly appreciated.
 
Old 07-08-2009, 03:51 AM   #2
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,477

Rep: Reputation: 87
Hi

I had the exact same problem in FF with the Flash plugin, but also, unlike you, I had no sound AT ALL in FC11.

It turned out that it was a buggy pulseaudio that was causing my problems, maybe the fixes I list below will help you getting sound in FF with a Flash plugin:

Step 1 - completely disable pulseaudio, as root:

Code:
1. Go to /etc/alsa
2. Rename the file pulse-default.conf to pulse-default.conf.bak
3. Become root and killall pulseaudio (put this in /etc/rc.local, since the system will restart pulseaudio each time it is booted)
Step 2 - re-enable OSS (FC11 does have it installed, only it is disabled by default)

Code:
1. To fix, go into /etc/modprobe.d/dist-oss-conf and uncomment the bottommost line. Save the file, and reboot the system.
Once it comes back up, check if you have better luck with sound. After doing the steps above, I had sound back and working fine in FC11, including sound with the flash plugin in FF (i. e. Youtube had sound, as well as other streaming video sites).

Hope this helps,
 
Old 07-08-2009, 08:26 PM   #3
bcage
LQ Newbie
 
Registered: Jun 2005
Distribution: Fedora 11
Posts: 22

Original Poster
Rep: Reputation: 16
Ok, gave it a shot; no luck, however... I am not really certain that I have really done what you said. I did each of the steps you specified, but if I do a ps after a reboot I still see the pulseaudio. I know the rc.local executed so something else is starting it back up. Thanks for the suggestion.
 
Old 07-08-2009, 08:42 PM   #4
bcage
LQ Newbie
 
Registered: Jun 2005
Distribution: Fedora 11
Posts: 22

Original Poster
Rep: Reputation: 16
Smile Fixed!

Ok, finally got it working. I installed the Adobe 64bit alpha version of flash player and all is well. I followed the directions posted in a thread at

https://fcp.surfsite.org/modules/new...post_id=347528

The thread is for 64bit Fedora 10, but this works on my 64bit Fedora 11 install.

I have pasted the directions from that thread below for others if needed.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~

At this point you should probably be using the 64-bit flash on 64-bit
systems. Here are my notes from when I did it. Caution the pathnames
on adobe's site may have changed a bit.

# alpha release of flash 64-bit

# pulseaudio-libs.i386 pulseaudio-*libs*.i386
yum erase flash-plugin.i386 nspluginwrapper.x86_64 nspluginwrapper.i386

cd /tmp
# main page: http://labs.adobe.com/downloads/flashplayer10.html
wget http://download.macromedia.com/pub/l...6_64.so.tar.gz
tar -xvzf libflashplayer-10.0.22.87.linux-x86_64.so.tar.gz
cp libflashplayer.so /usr/lib64/mozilla/plugins/libflashplayer.so

-wolfgang
--
Wolfgang S. Rupprecht Android 1.5 (Cupcake) and Fedora-11
Guidelines: http://fedoraproject.org/wiki/Commun...ListGuidelines
 
Old 07-29-2009, 07:48 PM   #5
msodos
LQ Newbie
 
Registered: Jun 2005
Location: Roswell, GA
Posts: 5

Rep: Reputation: 0
Quote:
Originally Posted by rylan76 View Post
Hi

I had the exact same problem in FF with the Flash plugin, but also, unlike you, I had no sound AT ALL in FC11.

It turned out that it was a buggy pulseaudio that was causing my problems, maybe the fixes I list below will help you getting sound in FF with a Flash plugin:

Step 1 - completely disable pulseaudio, as root:

Code:
1. Go to /etc/alsa
2. Rename the file pulse-default.conf to pulse-default.conf.bak
3. Become root and killall pulseaudio (put this in /etc/rc.local, since the system will restart pulseaudio each time it is booted)
Step 2 - re-enable OSS (FC11 does have it installed, only it is disabled by default)

Code:
1. To fix, go into /etc/modprobe.d/dist-oss-conf and uncomment the bottommost line. Save the file, and reboot the system.
Once it comes back up, check if you have better luck with sound. After doing the steps above, I had sound back and working fine in FC11, including sound with the flash plugin in FF (i. e. Youtube had sound, as well as other streaming video sites).

Hope this helps,

Followed instructions to the letter and it did not help at all. Also, when I do a ps after reboot, pulseaudio is still running, why?
I am running on Fedora 11, Firefox 3.5.1 on a 32 bit machine; actually 2 of them on is a 3gb Acer, and the other is an Acer netbook. Same issue on both.
Sound works perfectly when not using FF.
 
Old 07-29-2009, 07:55 PM   #6
linus72
Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: PocketWriter/MinimalX
Posts: 5,084

Rep: Reputation: 336Reputation: 336Reputation: 336Reputation: 336
Just wondering

Where did you guys get your flash plugin for f11??

I got mine from adobe(rpm)
and it works great on all my PC's, and lappys too?

is it just the 64bit version?
 
Old 07-29-2009, 08:21 PM   #7
msodos
LQ Newbie
 
Registered: Jun 2005
Location: Roswell, GA
Posts: 5

Rep: Reputation: 0
Got mine (32) directly from Adobe...
 
Old 07-29-2009, 08:22 PM   #8
msodos
LQ Newbie
 
Registered: Jun 2005
Location: Roswell, GA
Posts: 5

Rep: Reputation: 0
got mine directly from Adobe (32 bit)
 
Old 07-29-2009, 08:41 PM   #9
linus72
Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: PocketWriter/MinimalX
Posts: 5,084

Rep: Reputation: 336Reputation: 336Reputation: 336Reputation: 336
Hmm

well, it works fine on my HP Pavillion amd athlon64 3300+

and Emachines athlonXP also works good 2200+

lappy toshiba works good too

which fedora??

Omega fedora says it use fusion repos or something
would that have it?
 
Old 07-29-2009, 10:03 PM   #10
msodos
LQ Newbie
 
Registered: Jun 2005
Location: Roswell, GA
Posts: 5

Rep: Reputation: 0
Already installed from rpmfusion. It did not help either.
I undid the changes and it is still the same, no sound in Firefox.

btw, FEDORA 11 is the distro.
 
Old 08-14-2009, 11:12 AM   #11
kmacphail
Member
 
Registered: Jan 2009
Location: Isle of Lewis
Distribution: Gentoo, Crunchbang (XFCE)
Posts: 133
Blog Entries: 1

Rep: Reputation: 18
Right then I finally got this working on Fedora 11 (64 bit) but not the way that a lot of the websites have been saying.

Using the Add/Remove Software from the system and admin menu, I found a program called Alsa to PulseAudio backend, alsa-plugins-pulseaudio-1.2.20-2.fc11 (x86_64)

I restarted Firefox and flash was now playing with sound included. I hope this helps somebody as I was on this problem for four hours, it nearly drove me mad. Please note that my problem was exclusively linked to flash without sound, not Fedora without sound.
 
Old 09-20-2009, 03:03 PM   #12
erpp
LQ Newbie
 
Registered: Sep 2009
Posts: 2

Rep: Reputation: 0
Following previous post:

Erased alsa-plugins-pulseaudio:
[root@COOLERMASTER EFRAIN]# yum erase alsa-plugins-pulseaudio.x86_64
(System > Administration > Add/Remove Software reported "Unresolved Dependencies" for it, when checked through Selection > Depends On.)

and then:
[root@COOLERMASTER EFRAIN]# yum install alsa-plugins-pulseaudio.x86_64

Did same for "pulseaudio.x86_64", for which same thing was happening.
Make sure you install again all the erased dependencies - some have to be installed individually.

Also followed procedure for x86_64 - Fedora 11, in fedoraproject.org/wiki/Flash. Not sure if this added anything - Doesn'look like it in the Yum Log.

Sound did not come back inmediately, but next day it was there. Why? I don't know.
Only thing I did inmediately before was going through System > Preferences > Sound, and opening all the tabs in it.

Stating the obvious - make sure volume is up on both Advanced Volume Controls, and Sound, in System Preferences menu, before you do anything else.

Good luck
 
Old 09-20-2009, 03:05 PM   #13
erpp
LQ Newbie
 
Registered: Sep 2009
Posts: 2

Rep: Reputation: 0
In reference to my previous post: My problem was NO SOUND IN YOU TUBE, IN FEDORA 11.
 
Old 09-24-2009, 08:45 PM   #14
illpotat0
LQ Newbie
 
Registered: Sep 2009
Posts: 1

Rep: Reputation: 0
Code:

1. Go to /etc/alsa
2. Rename the file pulse-default.conf to pulse-default.conf.bak
3. Become root and killall pulseaudio (put this in /etc/rc.local, since the system will restart pulseaudio each time it is booted)

Step 2 - re-enable OSS (FC11 does have it installed, only it is disabled by default)

Code:

1. To fix, go into /etc/modprobe.d/dist-oss-conf and uncomment the bottommost line. Save the file, and reboot the system.

Once it comes back up, check if you have better luck with sound. After doing the steps above, I had sound back and working fine in FC11, including sound with the flash plugin in FF (i. e. Youtube had sound, as well as other streaming video sites).

It worked for me. Pulseaudio was definitely the culprit here. Any flash video that was played on any site had no sound, whatsoever. I stumbled upon this forum and the exact steps outlined in rylan76' post did the trick. Thanks rylan76.
 
Old 09-26-2009, 04:57 AM   #15
alifed
LQ Newbie
 
Registered: Sep 2009
Location: Iraq
Posts: 3

Rep: Reputation: 0
Cool Hi

I got this problem , no sound in .flv videos and unstable playing. i hope this will help.

you must install some missing libraries as below ,
do the following as root:

rpm -Uvh http://download1.rpmfusion.org/free/...ble.noarch.rpm

rpm -Uvh http://download1.rpmfusion.org/nonfr...ble.noarch.rpm

Now, Install all other plug ins..

yum -y install gstreamer-plugins-bad gstreamer-plugins-ugly xine-lib-extras-nonfree

yum install xine xine-lib libdvdcss

now close firefox and type

yum install firefox

after that i hope your fedora box will play all media types and play youtube movie clips with sound

Last edited by alifed; 09-26-2009 at 04:59 AM.
 
  


Reply

Tags
bit, fedora, firefox, fix, flash, flash-plugin, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Flash No Sound in Firefox in Fedora 10 shreks Fedora 4 01-21-2009 08:45 AM
Sound isn't working in Flash in Firefox in Fedora 9 nadavvin Linux - Desktop 4 07-17-2008 03:02 PM
Firefox crashes on flash content fannymites Suse/Novell 11 07-30-2007 09:55 PM
Why does not the browser(Firefox) support flash content on some websites ? deepumnit General 4 12-25-2006 01:34 PM
Flash content (was) giving me problems using Firefox rickh LQ Suggestions & Feedback 1 08-15-2006 03:03 PM


All times are GMT -5. The time now is 03:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration