LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 11-29-2008, 01:13 AM   #1
mm07
LQ Newbie
 
Registered: Jan 2007
Posts: 18

Rep: Reputation: 0
Fedora 10 ATI video driver not working and not available???


All,

I can't seem to properly install the ATI drivers for the new Fedora 10 installation.

I've read these forums and online and I find instructions for Fedora 9,8, and 7 which say to enable the linva repository and install fglrx. ok, easy right?

So linva is now Rpmfusion, but the
I read on the RPMFUSION frontpage that the ATI drivers are not yet available, but unsure why. A search in Rpmfusion did not yield the fglrx driver.

I was able to turn up ONE article on how to install F10 ATI Drivers here:
http://fedoraforum.org/forum/showthread.php?t=155503

But to be honest, I read through it and it doesn't seem right. Very hacky and odd...why so many steps?

I went to ATI's site and downloaded it directly from there, installed it rebooted and system hung and would not boot into the gui.

So What the heck is going on?
What is the story with no ATI drivers?
What's the simplest way to install ATI drivers?
My card is a 1300 model.

THanks
-Mike

Last edited by mm07; 11-29-2008 at 08:25 AM.
 
Old 11-29-2008, 08:44 AM   #2
DragonSlayer48DX
Registered User
 
Registered: Dec 2006
Posts: 1,454
Blog Entries: 1

Rep: Reputation: 74
Quote:
Originally Posted by mm07 View Post
I was able to turn up ONE article on how to install F10 ATI Drivers here:

http://fedoraforum.org/forum/showthread.php?t=155503

But to be honest, I read through it and it doesn't seem right. Very hacky and odd...why so many steps?
I agree... it's a hack. And with only 54% claiming that it worked and nearly 30% stating that it didn't, I wouldn't bother.

Quote:
What is the story with no ATI drivers?
Keep in mind that hardware manufacturers are not in bed with Linux distro maintainers like they are with Microsoft, so it should be no big surprise that specialty drivers like ATI and nVidia won't always be immediately available for every new distro upgrade.

Quote:
What's the simplest way to install ATI drivers?
Wait for them to be released to Rpmfusion. It shouldn't be too long.

Cheers
 
Old 11-29-2008, 12:16 PM   #3
mm07
LQ Newbie
 
Registered: Jan 2007
Posts: 18

Original Poster
Rep: Reputation: 0
Thanks Bill, just the answer I was hoping for.
As long as they are coming, I can wait.

The display works fine, just some artifacts in the form of lines on the side of my screen during some operations..
All in all Fedora 10 is a pretty good distro so far..
 
Old 12-06-2008, 04:40 PM   #4
muneer1st
Member
 
Registered: Sep 2008
Distribution: Fedora 9
Posts: 34

Rep: Reputation: 15
Yes, Same problem i am too getting. Some sort of line are flickering in right side of the screen.
I was searching for F10 ATI driver and arrived here.

friend dragonslayer48dx and mm07, if you guys manage to find supported drivers or any solution for this, please let me a PM. Thank you ,, bye.....
 
Old 12-06-2008, 09:03 PM   #5
kz26
Member
 
Registered: Aug 2005
Location: USA
Distribution: Fedora, Ubuntu, Backtrack
Posts: 70

Rep: Reputation: 15
Try the RPMFusion repo.

As root:
Code:
rpm -Uvh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm
yum install kmod-fglrx

Last edited by kz26; 12-06-2008 at 09:09 PM.
 
Old 12-07-2008, 01:28 AM   #6
mm07
LQ Newbie
 
Registered: Jan 2007
Posts: 18

Original Poster
Rep: Reputation: 0
kz26,
Did you read my initial post.
It says the ATI drivers are not available for Fedora 10 in RPMFusion.


I just checked again and they are still not. Am I mistaken, or are you?

[root@linuxdesktop ~]# yum install kmod-fglrx
Loaded plugins: refresh-packagekit
Setting up Install Process
Parsing package install arguments
No package kmod-fglrx available.
Nothing to do

[root@linuxdesktop ~]# yum repolist
Loaded plugins: refresh-packagekit
repo id repo name status
adobe-linux-i386 Adobe Systems Incorporated enabled : 17
fedora Fedora 10 - i386 enabled : 11,416
rpmfusion-free RPM Fusion for Fedora 10 - Free enabled : 324
rpmfusion-free-updat RPM Fusion for Fedora 10 - Free - Update enabled : 0
rpmfusion-nonfree RPM Fusion for Fedora 10 - Nonfree enabled : 142
rpmfusion-nonfree-up RPM Fusion for Fedora 10 - Nonfree - Upd enabled : 0
updates Fedora 10 - i386 - Updates enabled : 912
repolist: 12,811
 
Old 12-09-2008, 08:34 PM   #7
kz26
Member
 
Registered: Aug 2005
Location: USA
Distribution: Fedora, Ubuntu, Backtrack
Posts: 70

Rep: Reputation: 15
Hm. Your're right, my mistake! I guess we'll have to wait for the Livna guys to finish building and moving their stuff to RPMFusion.

I actually have an nVidia card, which does have drivers in the repo - I mistakenly assumed that the same was true for ATI.
 
Old 12-10-2008, 02:20 AM   #8
muneer1st
Member
 
Registered: Sep 2008
Distribution: Fedora 9
Posts: 34

Rep: Reputation: 15
yes thats right , will wait for the driver. It will not take more time.
 
Old 12-23-2008, 04:51 PM   #9
muneer1st
Member
 
Registered: Sep 2008
Distribution: Fedora 9
Posts: 34

Rep: Reputation: 15
hi friends..
I followed the folowing guide to install hack to to my ati card on fedora 10.
http://forums.fedoraforum.org/showthread.php?t=155503

I downgraded libdrm and was in process of installing the F9 rpmfusion drivers. unfortunately i lost internet connection and my system hanged. I could do nothing. At the end I restarted the system. I ccan see now up to fedora 10 blue color loading screen. It finish loading and then go blank. I cannot go byond that.

Now wot should i to do over come this. Please help me friends.

THanks in advance.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Video Driver for ATI peeths003 Linux - Desktop 6 10-23-2008 04:25 AM
ATI x1600 video driver dreck Fedora 84 04-05-2007 01:04 PM
ATI Video Driver flatstan Suse/Novell 2 01-01-2007 05:55 AM
I broke my video driver (ATI)... ZoMBiE_KiLLeR Linux - Newbie 6 04-30-2006 05:09 PM
Fedora 5 problems with gnome and ati video driver Melciah Fedora 1 04-24-2006 12:08 PM


All times are GMT -5. The time now is 09:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration