LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 02-15-2009, 03:33 AM   #1
jonaskellens
Member
 
Registered: Jul 2008
Location: Ghent, Belgium
Distribution: Fedora, CentOS
Posts: 620

Rep: Reputation: 33
Fedo10: getting wlan and sound to work


[eddy@eddy ~]$ lspci
00:00.0 Host bridge: ATI Technologies Inc Radeon Xpress 200 (RS480/RS482/RX480/RX482) Chipset - Host bridge
00:02.0 PCI bridge: ATI Technologies Inc RS480 PCI-X Root Port
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 10)
00:14.1 IDE interface: ATI Technologies Inc IXP SB400 IDE Controller
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge
00:14.5 Multimedia audio controller: ATI Technologies Inc IXP SB400 AC'97 Audio Controller (rev 01)
00:14.6 Modem: ATI Technologies Inc SB400 AC'97 Modem Controller (rev 01)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility X700 (PCIE)
02:03.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:04.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ac)
02:04.1 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ac)
02:04.2 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 04)
02:09.0 Ethernet controller: Linksys, A Division of Cisco Systems [AirConn] INPROCOMM IPN 2220 Wireless LAN Adapter (rev 01)

Now, how can I modprobe the right module for my wireless lan ??

02:09.0 Ethernet controller: Linksys, A Division of Cisco Systems [AirConn] INPROCOMM IPN 2220 Wireless LAN Adapter (rev 01)
Subsystem: Micro-Star International Co., Ltd. Device 6855
Control: I/O+ Mem+ BusMaster+ SpecCycle+ MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 64 (8000ns min, 8000ns max)
Interrupt: pin A routed to IRQ 5
Region 0: I/O ports at e400 [size=32]
Region 1: Memory at fbfff800 (32-bit, non-prefetchable) [size=32]
Region 2: Memory at fbffe800 (32-bit, non-prefetchable) [size=2K]
Capabilities: <access denied>

What info do I need to load the right module ??

Sound also does no work out of the box after installing Fedora 10 on this Targa Traveller.

00:14.5 Multimedia audio controller: ATI Technologies Inc IXP SB400 AC'97 Audio Controller (rev 01)
Subsystem: Micro-Star International Co., Ltd. Device 0291
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
Status: Cap+ 66MHz+ UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 64 (500ns min), Cache Line Size: 32 bytes
Interrupt: pin B routed to IRQ 17
Region 0: Memory at fbdfc800 (32-bit, non-prefetchable) [size=256]
Capabilities: <access denied>
Kernel driver in use: ATI IXP AC97 controller
Kernel modules: snd-atiixp

UPDATE :

sound works...

But wireless :

[eddy@eddy ~]$ ndiswrapper -l
neti2220 : driver installed
device (17FE:2220) present
[eddy@eddy ~]$ ifup 17FE:2220
/sbin/ifup: configuratie voor 17FE:2220 niet gevonden.
Gebruik: ifup <apparaatnaam>
[eddy@eddy ~]$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

pan0 no wireless extensions.

I installed ndiswrapper and installed the windows XP-driver via ndiswrapper, but still no workin wifi...

2nd UPDATE :

"modprobe ndiswrapper" and my wireless is activated !!

But still one problem : loading this module at startup...
modprobe -m does not make the wireless to load at startup. What can I do ??

Last edited by jonaskellens; 02-15-2009 at 05:34 AM.
 
Old 02-15-2009, 07:00 AM   #2
theacerguy
Member
 
Registered: Jan 2009
Location: on my pc!
Distribution: openSUSE 11.2 opensolaris 2009.06
Posts: 218
Blog Entries: 7

Rep: Reputation: 32
personnaly madwifi work best because it loads at boot but it should anyway try creating a boot script with modprobe ndiswrapper in it
 
Old 02-16-2009, 02:44 AM   #3
jonaskellens
Member
 
Registered: Jul 2008
Location: Ghent, Belgium
Distribution: Fedora, CentOS
Posts: 620

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by theacerguy View Post
personnaly madwifi work best because it loads at boot but it should anyway try creating a boot script with modprobe ndiswrapper in it
Like putting it in rc.local ???
 
Old 02-21-2009, 08:56 AM   #4
theacerguy
Member
 
Registered: Jan 2009
Location: on my pc!
Distribution: openSUSE 11.2 opensolaris 2009.06
Posts: 218
Blog Entries: 7

Rep: Reputation: 32
Quote:
Originally Posted by jonaskellens View Post
Like putting it in rc.local ???
i guess so i have never created a boot script before my wifi and sound just works at boot
 
Old 02-22-2009, 02:40 AM   #5
jonaskellens
Member
 
Registered: Jul 2008
Location: Ghent, Belgium
Distribution: Fedora, CentOS
Posts: 620

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by theacerguy View Post
i guess so i have never created a boot script before my wifi and sound just works at boot
I've put a little script in rc.local that activates my wlan card at boot.
 
Old 03-10-2009, 01:34 PM   #6
theacerguy
Member
 
Registered: Jan 2009
Location: on my pc!
Distribution: openSUSE 11.2 opensolaris 2009.06
Posts: 218
Blog Entries: 7

Rep: Reputation: 32
Quote:
Originally Posted by jonaskellens View Post
I've put a little script in rc.local that activates my wlan card at boot.
hope it works!! tell me the result please
 
Old 03-11-2009, 04:01 AM   #7
jonaskellens
Member
 
Registered: Jul 2008
Location: Ghent, Belgium
Distribution: Fedora, CentOS
Posts: 620

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by theacerguy View Post
hope it works!! tell me the result please
Well I've just put "modprobe ndiswrapper" in rc.local which loads my wireless module, namely ndiswrapper.
Ndiswrapper is an alias for wlan0, defined in ndiswrapper.conf.

However I'm having some trouble with WPA-encryption. But there's enough tutorials about this problem on the internet to solve my problem.
 
Old 03-13-2009, 11:30 AM   #8
theacerguy
Member
 
Registered: Jan 2009
Location: on my pc!
Distribution: openSUSE 11.2 opensolaris 2009.06
Posts: 218
Blog Entries: 7

Rep: Reputation: 32
Quote:
Originally Posted by jonaskellens View Post
Well I've just put "modprobe ndiswrapper" in rc.local which loads my wireless module, namely ndiswrapper.
Ndiswrapper is an alias for wlan0, defined in ndiswrapper.conf.

However I'm having some trouble with WPA-encryption. But there's enough tutorials about this problem on the internet to solve my problem.
wpa is a snake pit i had to ditch it on my pc most new kit doesnt lilke it my vista my aspire one did though i think
 
Old 03-13-2009, 01:42 PM   #9
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,151

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
Quote:
Originally Posted by theacerguy View Post
wpa is a snake pit i had to ditch it on my pc most new kit doesnt lilke it my vista my aspire one did though i think
The NetworkManager seem to handle WPA interactions quite smoothly, although you need the wpa_cli installed as well as wpa_supplicant. (The standard wpa_supplicant RPM includes all the wpa tools.)

The only problems with using the NetworkManager that I've noticed are that:
  1. You can only have one network device active.
  2. It's difficult to activate the wireless connection in run level 3. (In Ubuntu, after setting /etc/wpa_supplicant.conf, all I need to do is a dhclient, but that doesn't work on Fedora.)
Anyhow, my advice is to use the NetworkManager on Fedora. Basically (once you've got your hardware working), all you need to do is click on the network icon* in the task bar and select the access point to which you want to connect. If a password or pass phrase is needed, you'll be prompted to enter it and it will (if you wish) be stored in your "walet" so you don't need to re-enter it the next time you use that AP. The NM ysed the wpa_cli to connect to the AP (ignoring wpa_supplicat.conf) so you don't need to set up your configuration file.

If you do want to set up a configuration file, here's what my simple one looks like (pass phrases redacted, of course):
Code:
$ sudo cat /etc/wpa_supplicant/wpa_supplicant.conf
[sudo] password for Peter:                                          
ctrl_interface=/var/run/wpa_supplicant                              
ctrl_interface_group=wheel                                          

update_config=1
eapol_version=2
ap_scan=2      

# Wireless router
network={
        ssid="T.S.S."
        proto=WPA WPA2
        key_mgmt=WPA-PSK
        pairwise=CCMP TKIP
        group=CCMP TKIP   
        psk=" redacted "
        priority=0          
}                           

# Qwest DSL modem
network={
        ssid="T.S.S. 2"
        proto=WPA WPA2 
        key_mgmt=WPA-PSK
        pairwise=CCMP TKIP
        group=CCMP TKIP   
        psk=" redacted "
        priority=1          
}

# Neighbor                            
network={                   
        ssid="Revelas"      
        proto=WPA           
        key_mgmt=WPA-PSK    
        pairwise=CCMP TKIP  
        group=CCMP TKIP     
        psk=" redacted "
        priority=2          
}

# Any open-access AP . . .
network={
        key_mgmt=NONE
        priority=3
}
* I believe that GNOME automatically adds the NM icon to the task bar. If you use KDE, you'll need to install knetworkmanager and run it (once) to get the icon on your task bar.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help getting a WLAN NIC to work (or help chosing a new card that will work) stromdal Linux - Wireless Networking 3 04-27-2008 12:17 AM
WLAN-card works/doesn't work 0p3r4 Linux - Wireless Networking 2 09-01-2006 01:03 PM
WLAN,sound and there buttons dont work, Hp-Compaq nx9420 rickeboy Linux - Laptop and Netbook 6 05-17-2006 11:08 AM
Getting SUSE 10.0 to work with WLAN Poneyboy Linux - Wireless Networking 3 11-23-2005 12:33 PM
wlan with wep doesn't work danlin Linux - Wireless Networking 2 07-02-2004 02:10 AM


All times are GMT -5. The time now is 06:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration