LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 11-08-2012, 05:43 PM   #1
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,340

Rep: Reputation: 42
FEd 17 touchpad scrolling


I have Fed 17. I think it is a bit boring visually. Only light grey windows, no wobbly windows. Compiz can't be installed easily. Someone told me to try xfce desktop. I downloaded it. Now I have no touchpad scrolling, and nowhere to enable it. There is nothing in Settings>Mouse.

How can I get around this? Works in gnome
 
Old 11-10-2012, 05:55 AM   #2
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,839

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Do you have a /etc/X11/xorg.conf file? If yes, you can configure it in there. There are about 50 different settings for synaptics touch pads. To see what can be set, in a konsole, type 'man synaptics'. ( Just what is between the quotes ). Look at the options, its a long list.

If you do not have an xorg.conf, you can make one, or you may have a synaptics.conf file. I don't use Fedora, so I don't know the exact details. Try googling 'how to fedora synaptics' and see what turns up.

There is a gui front end to configure synaptics touchpads. Have a look for an application called flsynclient. There is a gui for KDE as well, the name escapes me right now.

There are man models of touchpads. In that list of 50 or so options, not all will work on all touchpads. You have to try them, and see what happens. Its a project, don't expect instant answers.

Xfce is the desktop I use. It doesn't have as much eye candy as KDE or Gnome. It is more light weight.

Compiz is a different ball game all together. You need an accelerated graphics card first, and the proprietary drivers loaded. Then you can install Compiz. It should be in the repos for fedora.
 
Old 11-10-2012, 05:08 PM   #3
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,340

Original Poster
Rep: Reputation: 42
Thanks, I'll try your suggestions. I never tried to configure X directly. But I must have an x.conf somewhere. I'm just surprised that xfce doesn't have the option 'enable touchpad scrolling' under Settings>Mouse Gnome does.
Correction: I have no /etc/X11/x.conf Not in Fedora, and not in Ubuntu.
Fedora have dropped Compiz. Ubuntu still use it, or part of it. Which means I can still have my lovely wobbly windows. But the latest kernels of Ubuntu are acting up, I get freeze ups and crashes. It is the atlc driver. In Fedora, which is always in front of Ubuntu in terms of kernel version, this has been fixed.

Maybe Fedora will bring back Compiz. I really hope so!

Can you get any window colour except light grey in Fedora Gnome? Maybe there is a setting somewhere for Window colour. I hate grey!

For the crashes I mentioned above, look at the bottom of:

https://bugzilla.redhat.com/show_bug.cgi?id=781217

Last edited by Pedroski; 11-10-2012 at 05:30 PM.
 
Old 11-10-2012, 06:28 PM   #4
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,839

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Quote:
/etc/X11/x.conf
The file is /etc/X11/xorg.conf ; go to the root / , then do a change directory to etc/X11/ ; the command would be cd /etc/X11/ then do a 'ls xorg.conf' without quotes. If the file is there, it will show, if it is not, then nothing will be the response.

To clarify, in most up to date distros, a static xorg.conf file is no longer needed. It is dynamically built when the system starts up. I run Slackware. Slack supplies a file you copy, and add what ever options you need for the touchpad. For what its worth, the file is called 50-synaptics.conf and goes in the /etc/X11/xorg.conf.d/ directory. I don't know how Fedora handles it. That is why I suggested you google for a How To for Fedora.

Quote:
Can you get any window colour except light grey
Go to Settings --> Xfce Settings Manager & click. In the settings window, select Appearance. There are several choices there on the Style tab.
 
Old 11-10-2012, 07:59 PM   #5
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,340

Original Poster
Rep: Reputation: 42
Thanks.
I have no file xorg.conf on this computer. Nowhere. I presume it has been superceded.

Do you know where the window manager actually sets the window frame colour? I could change this to the colour of my heart's desire! Or anything but grey! I know I can set a theme, but somewhere in the collection of window themes is a variable: window_frame_colour=light grey. If I could just twig that variable it would be good.

Fedora has a folder /etc/X11/xorg.conf.d/ It contains a text file 00-system-setup-keyboard.conf
# This file is autogenerated by system-setup-keyboard. Any
# modifications will be lost.

Section "InputClass"
Identifier "system-setup-keyboard"
MatchIsKeyboard "on"
Option "XkbModel" "pc105+inet"
Option "XkbLayout" "us"
# Option "XkbVariant" "(null)"
Option "XkbOptions" "terminate:ctrl_alt_bksp,"
EndSection

Nothing on touchpad scrolling. But in gnome I can set this under Settings>Mouse. Just xfce can't do that

Last edited by Pedroski; 11-10-2012 at 08:38 PM.
 
Old 11-11-2012, 06:21 AM   #6
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,839

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Quote:
Do you know where the window manager actually sets the window frame colour?
No, I chose Xfce-curve under appearance, and that makes the frames a nice blue. I don't do much with eye candy these days. You could go to http://www.xfce.org/ and look in the doc there. You may find out how to make your own appearance files.

Leave the keyboard file alone. You add files for each component you want/need to configure.
Here is the file that comes on Slack as a starting point.

Quote:
# DO NOT EDIT THIS FILE - IT WILL BE OVERWRITTEN ON UPGRADES
# Copy this file to /etc/X11/xorg.conf.d/ and edit the copy
#
# Use "synclient -l" to see all available options
# Use "man synaptics" for details about what the options do
#
Section "InputClass"
Identifier "touchpad"
Driver "synaptics"
MatchDevicePath "/dev/input/event*"
MatchIsTouchpad "on"
Option "TapButton1" "1"
Option "TapButton2" "2"
Option "TapButton3" "3"
EndSection
What you can try, is copy this, and save it to /etc/X11/xorg.conf.d/ and name the file 50-synaptics.conf.

You will need to add some options to the file, once again, read 'man synaptics' for a full list of options. One you add an option, you need to restart the xserver for the change to take affect. Do have a look for the app flsynclient , it may do all you need. It is nice to have it installed. I use an external mouse when I can plug in my netbook, and the app has a simple way to turn the touchpad off so your hands don't accidentally cause erratic mouse movement.
 
Old 11-12-2012, 07:53 PM   #7
Inkit
Member
 
Registered: Feb 2011
Location: India
Distribution: Mint 10
Posts: 141

Rep: Reputation: 15
Quote:
I think it is a bit boring visually. Only light grey windows, no wobbly windows.
Have you tried the KDE spin yet? KDE gives you very good visuals, and it is very easy to configure. I get all the effects I need even without an accelerated graphics card on my system.
 
Old 11-13-2012, 03:26 AM   #8
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 14.04
Posts: 1,340

Original Poster
Rep: Reputation: 42
Yeah, got kde plasma. It is more configurable, but I am not used to it, so it takes a while. For instance, I can't find a program to install or upgrade software in kde. But I can do that from a terminal if I have to. Or start grey gnome! At the mo I have pink windows. Might have to adjust that, but it is better than grey.
xfce couldn't get the touchpad working, but kde did. I downloaded ksynaptic-something, and it got the touchpad working under xfce too.

I still wish they would resurrect compiz!!
 
Old 11-13-2012, 09:08 PM   #9
Inkit
Member
 
Registered: Feb 2011
Location: India
Distribution: Mint 10
Posts: 141

Rep: Reputation: 15
Granted, I used to use synaptic when on Mint KDE. But until something else comes along, it's probably your best bet.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] touchpad scrolling R3V0LV3R Slackware 2 12-26-2011 05:39 PM
touchpad scrolling Pedroski Fedora 0 09-30-2011 08:06 PM
touchpad scrolling Pedroski Fedora 0 09-09-2011 05:55 AM
Problem with touchpad scrolling darknails Linux - Laptop and Netbook 2 02-12-2006 09:12 AM
Scrolling using Touchpad mousie Linux - Laptop and Netbook 5 09-10-2005 08:26 AM


All times are GMT -5. The time now is 11:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration