LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 11-12-2008, 01:18 PM   #1
firekid1239
LQ Newbie
 
Registered: Jan 2008
Posts: 18

Rep: Reputation: 0
FC9 With Nvidia 7100gs Video Mode Not Supported


Allright... I just installed FC9 x86 64 bit onto my computer. My computer specs are as follows.

AMD Athlon 64 x2 6400+ (3.22ghz)
3 Gigs DDR.
180GB HDD
Nvidia Geforce 7100GS
17" Samsung LCD
DVD Writer
Yada Yada Yada....


Well I did a dual boot with FC9 and XP and the installation went fine. Now when I boot the system with fedora, I get an error on my monitor that says video mode not supported. I can use ctrl+alt+f2 and get in to the command line no problem, but the Xwindow does not want to load. The installation never asked me to pick a driver or anything so I assumed that Anaconda automatically found a compatible one. Guess not....

Anyone have any suggestion on how I can fix this. I am new to Linux, but I am also in my first semester of College for Network Administration and fedora is what we are studying. So I am somewhat fluent in the command line.
 
Old 11-13-2008, 11:05 AM   #2
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,475

Rep: Reputation: 87
Hmm you might try installing the proprietary Linux NVidia driver?

If you had a 32 bit system that would (I guess) get pretty close to solving your problem. But I suspect that this has to do with specifically the fact that you are on a 64 bit architecture... Not sure, if 32 / 64 bittedness affects the issue, if you can even get a 64bit NVidia driver for X...
 
Old 11-17-2008, 01:42 PM   #3
firekid1239
LQ Newbie
 
Registered: Jan 2008
Posts: 18

Original Poster
Rep: Reputation: 0
Solved It!

Actually I was searching google.com/linux (love it!) and I found the issue. It had nothing to do with it being a 64 bit architecture. During installation Anaconda didn't give me the option to select a video driver, it just used one automatically. The driver it used automatically was "vesa" which was for vesa-compatible video cards.

What I did was I used the command line (ctrl+alt+f2) and made my way to /etc/x11/xorg.conf. I edited xorg.conf with VI and changed the driver from "vesa" to "nv". It was as simple as that. Fedora selected the wrong driver by default.

Hope this helps anyone else with this problem. As a matter of fact, this issue seems to happen with alot of Nvidia drivers from what I hear.



For those who are new to linux (like me), I will give you step by step instructions on how to do this.


Punch in ctrl+alt+f2 to enter the command line. It will probably ask you to log in. Make sure you log in as root. At the command line type cd / to change to the root directory. Then type cd /etc/X11 to change to the directory of the conf file.

Type vi xorg.conf and press enter. Then press the "i" key to enter insert mode. Use the arrow keys to move down to where the driver selected is "vesa". Change "vesa" to "nv". Then press the escape key and press shift+:

type in "wq" minus the quotes which WRITES your changes to xorg.conf and QUITS vi. Then you should be back at the command line. Type "cat xorg.conf" minus the quotes to make sure that the changes you made were saved. Restart the computer and all should be fine.

If that doesnt work repost to this thread and maybe someone else will have a different soulution, because I sure as heck don't! Lol.

Last edited by firekid1239; 11-17-2008 at 01:45 PM. Reason: Spaces didn't show up for command line instructions.
 
Old 11-19-2008, 08:35 AM   #4
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,475

Rep: Reputation: 87
Ok, I stand corrected. I know nothing about the 64 bit side (a bit convenient to blame the unknown when you encounter something... erm... unknown!
 
Old 11-20-2008, 09:01 PM   #5
Ryptyde
Member
 
Registered: Jun 2004
Location: Tragic City,Michigan,USA
Distribution: Fedora 18 Fedora 17
Posts: 242

Rep: Reputation: 37
Quote:
Originally Posted by firekid1239 View Post
Actually I was searching google.com/linux (love it!) and I found the issue. It had nothing to do with it being a 64 bit architecture. During installation Anaconda didn't give me the option to select a video driver, it just used one automatically. The driver it used automatically was "vesa" which was for vesa-compatible video cards.

What I did was I used the command line (ctrl+alt+f2) and made my way to /etc/x11/xorg.conf. I edited xorg.conf with VI and changed the driver from "vesa" to "nv". It was as simple as that. Fedora selected the wrong driver by default.

Hope this helps anyone else with this problem. As a matter of fact, this issue seems to happen with alot of Nvidia drivers from what I hear.



For those who are new to linux (like me), I will give you step by step instructions on how to do this.


Punch in ctrl+alt+f2 to enter the command line. It will probably ask you to log in. Make sure you log in as root. At the command line type cd / to change to the root directory. Then type cd /etc/X11 to change to the directory of the conf file.

Type vi xorg.conf and press enter. Then press the "i" key to enter insert mode. Use the arrow keys to move down to where the driver selected is "vesa". Change "vesa" to "nv". Then press the escape key and press shift+:

type in "wq" minus the quotes which WRITES your changes to xorg.conf and QUITS vi. Then you should be back at the command line. Type "cat xorg.conf" minus the quotes to make sure that the changes you made were saved. Restart the computer and all should be fine.

If that doesnt work repost to this thread and maybe someone else will have a different soulution, because I sure as heck don't! Lol.
This will only get you a 2d desktop and not be able to use 3D desktop-effects you can get the nVidia drivers from the rpmfusion repo so to have all the bells and whistles your card can provide.
 
Old 11-20-2008, 11:09 PM   #6
John VV
Guru
 
Registered: Aug 2005
Posts: 12,901

Rep: Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713Reputation: 1713
you do know that the " nv " driver is 2d only install the rpmfusion repo and install the kmod-nvidia driver or the akmod-nvidia driver http://rpmfusion.org/

yum install kmod-nvidia
 
  


Reply

Tags
fc9, geforce, nvidia


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Video Mode not Supported HBN Linux - Hardware 3 07-16-2007 11:07 PM
Video mode not supported sivasankariit Suse/Novell 7 02-22-2006 07:38 AM
video mode not supported zchoyt Linux - Hardware 4 02-24-2005 10:51 AM
Video Mode Not Supported DigiCrime Linux - Hardware 0 07-06-2004 09:48 PM
video mode not supported Zeag Mandriva 1 03-29-2004 06:27 PM


All times are GMT -5. The time now is 04:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration