LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   FC7 boots from live CD, but not from SATA HD (http://www.linuxquestions.org/questions/fedora-35/fc7-boots-from-live-cd-but-not-from-sata-hd-596056/)

adrianwb 10-31-2007 07:28 AM

FC7 boots from live CD, but not from SATA HD
 
It's my first post here. I'm reasonably competent in linux, but have got stuck so hope someone can help. My system is a Shuttle XPC SD32 with Intel Core2 Duo, Maxtor 320Gb SATA HD, 2 Gb RAM. I installed the default Xen (2.6.20-2925.9.fc7xen) and standard (2.6.21-1.3194.fc7.i686) kernels - boots ok into the Xen one, but won't switch off without holding down the power button. Searched the net for answers without much success - mostly involving apm instead of acpi, but apm isn't supported in the xen kernel as far as I can see (no options when doing a make menuconfig if I try to build a new kernel). So thought I'd revert back to basics (can do without Xen) and try the standard kernel which does support apm.

The computer boots into grub fine (mbr on /dev/sda), but there is absolutely nothing after the initrd line (even with no quiet on the options) - it's as if the kernel can't see the SATA HD. I've messed about with various acpi, noapic options but nothing - it just waits%

rjlee 10-31-2007 08:54 AM

It sounds like grub can't find the hard-disk in order to load the bootloader from it.

Someone will correct me if I'm wrong, but as I understand it GRUB uses the BIOS to access the hard-disk, rather than any of the Linux kernel's SATA disk drivers. This won't be a problem when booting off a CD because that will load the kernel off the CD (usually an ATAPI interface, which is likely to work even with older BIOSes), and then use the kernel drivers to access the disk.

If this is the problem, it sounds like your BIOS is having trouble seeing the hard-disk. Try going into your BIOS setup (usually by holding down F2, F10, Delete, Esc or some other key during boot; unfortunately there is no real standard here, but it usually says briefly on the screen), and make sure that the BIOS hard-disk is properly configured.

It should also be possible to boot your system off another boot device, like a floppy disk or CD-rom, but's that's probably best kept as a last resort.

Hope that's of some help,

—Robert J Lee.

PTrenholme 10-31-2007 09:12 AM

It's my impression that some BIOSs assume that you want to use the (unpublished, copyrighted) Microsoft disk access "standard," and, therefore, set that as the default. Since those "standards" can only be supported by a "Genuine Microsoft Windows" OS, you might be out of luck if you can't change your BIOS to use some published, open, disk access standard.

Note that my "impression" is formed by (obsessive) reading Pamela Jones' Groklaw blog, not by any actual experience.

doublejoon 11-08-2007 05:52 PM

Try pci=nomsi as kernel option.


All times are GMT -5. The time now is 02:40 PM.