LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 09-17-2007, 01:28 AM   #1
terry-duell
Member
 
Registered: Jan 2007
Location: Melbourne, Australia
Distribution: Fedora 20 x86_64
Posts: 392

Rep: Reputation: 47
FC6 boots into text mode


I have read other threads on similar problems but none seem quite the same.
I recently upgraded the kernel from 2.6.19-1.2895.fc6 to 2.6.22.2-42.fc6 and at the same time updated the nvidia-legacy driver to the one appropriate for the kernel, but still 7185. Prior to the kernel upgrade all was OK.
Since the kernel upgrade the system sometimes (say 3 out 5 times) boots into text mode. If I login and run startx I get a message saying server is already active for display0. If I do cat /tmp/.X0-lock and then run ps ax | grep xxx where xxx is the process number returned by cat, I see that the Xserver is connected to virtual terminal 7, so an alt-F7 will switch into the normal graphics login screen.
If I edit /etc/xorg.conf and replace "nvidia" with "nv" (ie run the default driver rather than the nvidia driver) the system starts up OK in the normal graphics mode...but this hasn't been exhaustively tested.
What I do notice when using "nv" is that the white nvidia splash screen appears as the boot screen switches from the initial text mode to the graphics screen showing boot progress with the bar graph.
When running "nvidia" driver the white nvidia splash screen appears as above, and when the boot process is complete, as the screen switches from the boot bar graph to the login screen. I think the nvidia splash screen only appeared once with the FC5 and FC4 setups.
I have looked at the Xorg log and the system log and don't see anything that would indicate the cause of the problem.
Any ideas or suggestions?
 
Old 09-17-2007, 01:46 AM   #2
odcheck
Member
 
Registered: Aug 2006
Distribution: Fedora, CentOS, RHEL, Debian
Posts: 978

Rep: Reputation: 30
get the latest nvidia driver or use the once from livna.
Reinstall the nvidia driver.
 
Old 09-17-2007, 01:53 AM   #3
terry-duell
Member
 
Registered: Jan 2007
Location: Melbourne, Australia
Distribution: Fedora 20 x86_64
Posts: 392

Original Poster
Rep: Reputation: 47
It is the latest nvidia driver that is available for legacy cards, and I have tried reinstalling, and updating the kernel (again with the appropriate version of the nvidia driver, but it still boots into text mode sometimes. Every time it goes wrong the display attempts appears to attempt to switch but then immediately switches to text mode.
When you say reinstall the nvidia driver, how do you suggest that this be done. Perhaps I am doing it wrong.
I have been using "yum update..."
 
Old 09-17-2007, 02:07 AM   #4
odcheck
Member
 
Registered: Aug 2006
Distribution: Fedora, CentOS, RHEL, Debian
Posts: 978

Rep: Reputation: 30
there you go...

1. yum remove nvidia
2. visit this site
http://rpm.livna.org/rlowiki/
click on the appropriate version in your case fc6 = http://rpm.livna.org/livna-release-6.rpm
This will install the Livna repository for Fedora Core 6
then
3. run
yum install kmod-nvidia

That should do the trick.
 
Old 09-17-2007, 04:43 AM   #5
terry-duell
Member
 
Registered: Jan 2007
Location: Melbourne, Australia
Distribution: Fedora 20 x86_64
Posts: 392

Original Poster
Rep: Reputation: 47
I have been using the Livna driver, and I was under the impression that yum update removed the old version before installing the new, but I will check what is still installed, and if any old version is still hanging around, I will remove it, then see how the system boots.
Thanks for your help.
 
Old 09-17-2007, 05:38 PM   #6
terry-duell
Member
 
Registered: Jan 2007
Location: Melbourne, Australia
Distribution: Fedora 20 x86_64
Posts: 392

Original Poster
Rep: Reputation: 47
OK, I have checked if more than one nvidia driver was installed, and found the previous kernel and the related kmod-nvidia-legacy driver as well as the current ones. I cleaned out the previous versions (yum remove), but the same symptoms still exist.
I think I need some better ideas as to what is going here.
Cheers,
 
Old 10-05-2007, 12:52 PM   #7
shafty023
Member
 
Registered: Oct 2007
Distribution: OSX
Posts: 248

Rep: Reputation: 31
Could you please post the output of /var/log/Xorg.0.log here when you have another one of these instances. This will explain exactly what is going wrong.
 
Old 10-05-2007, 06:33 PM   #8
terry-duell
Member
 
Registered: Jan 2007
Location: Melbourne, Australia
Distribution: Fedora 20 x86_64
Posts: 392

Original Poster
Rep: Reputation: 47
OK, here is the /var/log/Xorg.0.log immediately following an occurrence of the problem.
Blast, no it isn't. I can't see how to include the file. Nothing seems to work.
Sorry I will have to go away and do some homework on how to do that, hopefully I can return soon!
Cheers,
 
Old 10-05-2007, 06:51 PM   #9
terry-duell
Member
 
Registered: Jan 2007
Location: Melbourne, Australia
Distribution: Fedora 20 x86_64
Posts: 392

Original Poster
Rep: Reputation: 47
It played up on this boot, and I have the Xorg.0.log file but can't see how to include or attach it to this reply. Nothing seems to work, and I can't find any guide in FAQ etc. Perhaps a case of domestic blindness!
Some advice needed.
Cheers,
 
Old 10-05-2007, 10:51 PM   #10
terry-duell
Member
 
Registered: Jan 2007
Location: Melbourne, Australia
Distribution: Fedora 20 x86_64
Posts: 392

Original Poster
Rep: Reputation: 47
OK, I now have some info from Xorg.0.log. A recent boot worked OK, and I have compared the log file with a copy taken after a boot into text mode a few hours ago.
There are only 2 real differences. Firstly the time stamp is different, which is OK.
Secondly, the log file from the boot into text mode has 3 additional lines at end...
585 (II) Open ACPI successful (var/run/acpid.socket)
586 (II) NVIDIA(0): Setting mode "1280x1024"
587 (II) Mouse0: Ps2EnablingDataReporting: succeeded

And that's it.
Does that throw any light on the problem?

Last edited by terry-duell; 10-05-2007 at 10:53 PM.
 
Old 10-07-2007, 05:33 PM   #11
shafty023
Member
 
Registered: Oct 2007
Distribution: OSX
Posts: 248

Rep: Reputation: 31
no I'd literally need the entire log from an unsuccessful X windows boot in order to parse through and see what could be causing the problem. Have you also checked your hard drive for errors? Burn this ISO image to a cd (please google how to burn an iso image if you haven't done this before) and boot from it. Run the advanced test and make sure you don't have a defective hard drive causing the issues.
Here is the link
http://www.hitachigst.com/hdd/suppor...2_v410_b00.iso

I know what a successful X windows load should look like, no failures. So I'd need the entire log posted here. You can do this by opening a terminal window and typing "cp /var/log/Xorg.0.log ~/Desktop" without the quotes. This will put a copy of it on your desktop. You can then open it with a word editor and copy/paste it here.
 
Old 10-07-2007, 06:02 PM   #12
terry-duell
Member
 
Registered: Jan 2007
Location: Melbourne, Australia
Distribution: Fedora 20 x86_64
Posts: 392

Original Poster
Rep: Reputation: 47
OK. I managed to paste the log file to a reply, but it got knocked back saying it was too much, and needed to be shortened. Any suggestions, as shortening it may get rid of stuff that you need to see.
I have not yet looked at your other suggestion, but will do so shortly.

Cheers,
 
Old 10-07-2007, 08:10 PM   #13
terry-duell
Member
 
Registered: Jan 2007
Location: Melbourne, Australia
Distribution: Fedora 20 x86_64
Posts: 392

Original Poster
Rep: Reputation: 47
Quote:
Originally Posted by shafty023 View Post
if you haven't done this before) and boot from it. Run the advanced test and make sure you don't have a defective hard drive causing the issues.
Here is the link
http://www.hitachigst.com/hdd/suppor...2_v410_b00.iso
I didn't have much luck with that iso image. I burned a CD OK, and booted from it, but it never gave me any opportunity to select what sort of test to run. It seemed to hang at "detecting IDE secondary master..." which is the DVD drive that the CD was booted from. The hard disc activity light was continually on, and I left it for about 1.5 hours, thinking that perhaps it was gathering disc info etc, but nothing happened, so reset computer. Perhaps this is its nornmal behaviour, and if so it might be helpful if really said what it was doing.
I have tried using the smartmontools instead, to check the my hard discs, and they have passed. I presume that means that the discs own monitoring stuff hasn't seen any errors, but I need to spend a bit more time looking into the smartmontools to be sure.
Not sure if this helps.

Cheers,
 
Old 10-08-2007, 06:03 PM   #14
shafty023
Member
 
Registered: Oct 2007
Distribution: OSX
Posts: 248

Rep: Reputation: 31
Awww this could possibly be a hint that your IDE configuration is incorrect. Perhaps you have the jumpers set incorrectly or cables not connected correctly. It should not under any circumstance freeze up when detecting IDE devices. That application is written by IBM and has never failed on me. I've fixed easily over 500 computers since 2003 when I started pc repair as a side job.

You need to make sure your hard drive is connected by itself with Master jumper set to primary IDE controller. You should also make sure the Dvd rom has the jumper set as master and is connected to the Secondary IDE controller. Let me know if you have more than one cd device. Try unplugging the IDE cable & power from the dvd rom and try booting linux. See if that makes any difference. Doubt it will but you may have a defective dvd rom if all your jumpers and cables are correct.
 
Old 10-09-2007, 03:00 AM   #15
terry-duell
Member
 
Registered: Jan 2007
Location: Melbourne, Australia
Distribution: Fedora 20 x86_64
Posts: 392

Original Poster
Rep: Reputation: 47
OK. I took the trouble to re-check all my IDE devices, just to be sure. I have two hard drives, on the IDE1, and a DVD and a CD drive on IDE2.
The hard drives were on 'cable select', so changed them over to 'Master' and 'slave', to see if that had any effect. The DVD is set 'Master' and the CD 'slave'.
I really don't think there has been anything wrong with the IDE setup, as it has been working flawlessly for a couple of years. The booting into text mode only started when I upgraded the FC6 kernel.
I don't know if the disk checker was working as expected or not, but it didn't look right. Curious that all other disk stuff, like smartmontools, parted etc as well as Windows disk partition tools never find anything wrong with the disks or have any trouble finding the devices.
I really don't know a lot about that side of things, so can only listen to your advice.

Cheers,
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu - new install boots in text mode only jonette20 Ubuntu 7 08-13-2007 01:14 PM
Changing FC6 a text mode installation to graphics mode. wbuik Fedora 2 06-19-2007 08:38 PM
FC6 boots in non-GUI mode kopitao Linux - Newbie 2 02-26-2007 11:43 PM
FC6 installation text mode - don't try this at home rewtedesco Fedora 10 12-26-2006 08:14 PM
X86Free problem, directly boots into text mode,not into gui Tinku Linux - General 2 07-09-2004 12:27 AM


All times are GMT -5. The time now is 02:30 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration