LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 05-05-2006, 02:44 PM   #1
rjstbur
LQ Newbie
 
Registered: Jan 2006
Posts: 8

Rep: Reputation: 0
fc5 x86-64


I have two faults

1) segmentation fault at boot, don't know whether this causes problems.

2) incomplete loading of web pages. secure sites eg bank, google, fully load and perform. however going to search results for google and the onward link does not load. another eg golfbidder.com fully loads and works. Have tried every permutation I can think of with firewall, pop-ups, cookies, still no joy.

any help would be appreciated, I had same problem with red hat and own installation of 2.6.15 on original 2.4.20-8 butput this down to iptables-ipchains complexity..
 
Old 05-06-2006, 06:59 AM   #2
rjstbur
LQ Newbie
 
Registered: Jan 2006
Posts: 8

Original Poster
Rep: Reputation: 0
To give more information, during boot, seg error is 98 error 4, followed by /etc/rc5.d/S05KUDZU line 29, which on inspection refers to "have a 30sec timeout". On shut down get message "hcid segmentation fault". Sorry to say this, but my efforts to load linux on ASUS K8S-MX with amd processor have not gone smoothly. Madriva wouldn't even load from cd, fc5 stuttered several times reading error free cd, and I am getting notion that 64bit system simply is too frail.
 
Old 05-07-2006, 09:54 AM   #3
jcliburn
Member
 
Registered: Dec 2003
Location: Mississippi, USA
Distribution: Fedora
Posts: 435

Rep: Reputation: 33
hcid is used for bluetooth. If you don't need bluetooth, turn it off and your segfaults on shutdown should disappear. Run the following commands as root.

service bluetooth stop
service hidd stop
chkconfig bluetooth off
chkconfig hidd off

I don't think this is your main problem, though, since you're seeing problems across multiple distros. I've run x86_64 FC3, FC4, and FC5 without severe problems. Have you run memtest86+ for an extended period?

Kudzu detects hardware changes in your system. Line 29 is a comment line in the S05kudzu file, so that's not the problem. Likely it's from the previous or subsequent line -- that'd make more sense. What happens when you run "/sbin/kudzu -s" from a root command line? Watch your system log as you do it. That is, open a terminal window and, as root, issue "tail -f /var/log/messages". In another window, as root, issue the command "kudzu -s" and see if anything happens in the tail -f window.
 
Old 05-11-2006, 11:15 AM   #4
rjstbur
LQ Newbie
 
Registered: Jan 2006
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jcliburn
hcid is used for bluetooth. If you don't need bluetooth, turn it off and your segfaults on shutdown should disappear. Run the following commands as root.

service bluetooth stop
service hidd stop
chkconfig bluetooth off
chkconfig hidd off

I don't think this is your main problem, though, since you're seeing problems across multiple distros. I've run x86_64 FC3, FC4, and FC5 without severe problems. Have you run memtest86+ for an extended period?

Kudzu detects hardware changes in your system. Line 29 is a comment line in the S05kudzu file, so that's not the problem. Likely it's from the previous or subsequent line -- that'd make more sense. What happens when you run "/sbin/kudzu -s" from a root command line? Watch your system log as you do it. That is, open a terminal window and, as root, issue "tail -f /var/log/messages". In another window, as root, issue the command "kudzu -s" and see if anything happens in the tail -f window.

Thanks for suggestion, after re-installing, I get same seq fault but line 23. Problem seems wider than just one bug. Failure to complete page load from internet is echo'd in many instances where system goes off to do something, eg file search, download manager, almost any launch of a task, and it goes to sleep, not even registering the pid after ps -fu command. In other words it appears to be unable to complete the initiation of a process.
 
Old 05-13-2006, 06:02 PM   #5
rjstbur
LQ Newbie
 
Registered: Jan 2006
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by rjstbur
Thanks for suggestion, after re-installing, I get same seq fault but line 23. Problem seems wider than just one bug. Failure to complete page load from internet is echo'd in many instances where system goes off to do something, eg file search, download manager, almost any launch of a task, and it goes to sleep, not even registering the pid after ps -fu command. In other words it appears to be unable to complete the initiation of a process.
Further input as to problem:

On firefox/tools/java console

Lots of error reports:

eg after partial load of wanadoo.co.uk, and invitation to request plugins, get series of errors - eror in parsing, expected but found, unknown pseudo-class or psuedo-element visited, unknown property etc.etc.

similar for ft.com:

trying ft.com goToRegion is not defined. line 9 if then refer to page info security get flag "web site not verified" encryption not used

various line numbers in errors refer to

///usr/share/doc/HTML/index.html
///usr/share/doc/HTML/css/content.css line 174

Another:

Exception: "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsiXulRuntimeXPCOMABI]"nsresult
"0x80040111(NS_ERROR_NOTAVAILABLE)"locationj:frame::file ///usr
/lib64/firefox-1.5.0/components/rsUpdateService.js::anonymous::
line 1689"data:no

Surely this means big problems with java and data handling but can anyone help??? Please!!
 
  


Reply

Tags
fc5, segmentation fault, x8664


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FC5 - Anaconda install problem x86-64 [Errno 256] RottenMutt Fedora 31 09-25-2006 11:21 PM
Getting black screen when FC5 x86-64 graphical installler starts X on my laptop johnemb Fedora - Installation 12 05-20-2006 09:54 AM
FC5 x86 64 v. i386, got an opinion? BobNutfield Fedora 1 03-24-2006 05:00 AM
FC5 test 1 x86-64 mickeyboa Fedora 0 12-11-2005 08:36 AM
Boot x86 target from flash, with the image and file system on the x86 host. batsayan Linux - Software 2 08-23-2005 01:09 AM


All times are GMT -5. The time now is 06:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration