LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 03-30-2006, 07:49 AM   #1
marozsas
Senior Member
 
Registered: Dec 2005
Location: Campinas/SP - Brazil
Distribution: SuSE, RHEL, Fedora, Ubuntu
Posts: 1,393
Blog Entries: 1

Rep: Reputation: 64
FC5 SELinux question


Hi,

I am trying to install Macromedia Flashplayer in my FC5 box.
The macromedia files are in /usr/lib/firefox-1.5.0.1/plugins but aboutlugins in browser only shows the Default null plugins and Helix DNA Plugin.

I am suspected the culprid is SELinux.
Code:
# ls -Z /usr/lib/firefox-1.5.0.1/plugins/
-rwxr-xr-x  root     root     user_u:object_r:lib_t            flashplayer.xpt
-rwxr-xr-x  root     root     user_u:object_r:lib_t            libflashplayer.so
-rwxr-xr-x  root     root     system_u:object_r:textrel_shlib_t libnullplugin.so
-rwxr-xr-x  root     root     system_u:object_r:textrel_shlib_t libunixprintplugin.so
#
How do I change the SELinux attributes (is that the correct term?) to match with libnullplugin.so attributes ?

Or I am o wrong and this is not the problem at all ?

thanks,

Last edited by marozsas; 03-30-2006 at 07:52 AM.
 
Old 03-30-2006, 10:50 AM   #2
marozsas
Senior Member
 
Registered: Dec 2005
Location: Campinas/SP - Brazil
Distribution: SuSE, RHEL, Fedora, Ubuntu
Posts: 1,393
Blog Entries: 1

Original Poster
Rep: Reputation: 64
Solved !
It is trivial after I learned the chcon command:
Code:
[root@gold ~]# chcon system_u:object_r:lib_t flashplayer.xpt
[root@gold ~]# chcon  system_u:object_r:textrel_shlib_t libflashplayer.so
[root@gold ~]#
This don't mean I understand what I did I just apply the same SELinux properties from a working plugin to another one.
 
Old 03-30-2006, 02:04 PM   #3
hob
Senior Member
 
Registered: Mar 2004
Location: Wales, UK
Distribution: Debian, Ubuntu
Posts: 1,075

Rep: Reputation: 45
FWIW, Macromedia have approved a third-party yum repository for Flash on Fedora Core 5:

http://macromedia.mplug.org/

The packages from there will install the plugin with the correct SELinux labels.
 
Old 04-06-2006, 05:13 PM   #4
jeelliso
Member
 
Registered: Oct 2005
Location: Knoxville, Tn (USA)
Distribution: OpenSUSE, Ubuntu
Posts: 250

Rep: Reputation: 30
I had the same problem.

I tried using the recommended repository, but it did not install with the correct SELinux labels.

I tried what marozsas suggested and it works perfectly.

Just wanted to report back as to what worked for me and what didn't, in case someone else needs has a similar problem.
 
Old 04-18-2006, 02:32 AM   #5
groggo
LQ Newbie
 
Registered: Apr 2006
Distribution: Ubuntu Breezy 5.10
Posts: 7

Rep: Reputation: 0
i had the same problem wooo hoo thanks thats got it working cool
 
Old 04-18-2006, 12:59 PM   #6
erdichia
LQ Newbie
 
Registered: Mar 2005
Posts: 2

Rep: Reputation: 0
Another way around this is to simply turn off SELinux off when installing flash. I turned off SELinux and then just allowed Firefox to download and install its plugin. It worked fine.
 
Old 04-19-2006, 04:49 AM   #7
groggo
LQ Newbie
 
Registered: Apr 2006
Distribution: Ubuntu Breezy 5.10
Posts: 7

Rep: Reputation: 0
bugger me i have the fedora 5 stop booting again this morning so yep it sure does work if ya turn off firewall for the install

good stuff
 
Old 04-27-2006, 12:43 AM   #8
hferretluv
Member
 
Registered: Sep 2005
Location: Washington state
Distribution: fedora core 9 i386 - x86
Posts: 44
Blog Entries: 1

Rep: Reputation: 15
Fedora 5 and Flashplayer

Quote:
Originally Posted by marozsas
Solved !
It is trivial after I learned the chcon command:
Code:
[root@gold ~]# chcon system_u:object_r:lib_t flashplayer.xpt
[root@gold ~]# chcon  system_u:object_r:textrel_shlib_t libflashplayer.so
[root@gold ~]#
This don't mean I understand what I did I just apply the same SELinux properties from a working plugin to another one.

It didn't work for me. All I got was:

chcon: libflashplayer.so: No such file or directory
chcon: flashplayer.xpt: No such file or directory

So I must be doing something wrong, but I don't know what.

Well, I did want to lean linux, but I can't even find a darn book on bash, even.
 
Old 04-27-2006, 07:07 AM   #9
marozsas
Senior Member
 
Registered: Dec 2005
Location: Campinas/SP - Brazil
Distribution: SuSE, RHEL, Fedora, Ubuntu
Posts: 1,393
Blog Entries: 1

Original Poster
Rep: Reputation: 64
Quote:
Originally Posted by hferretluv
It didn't work for me. All I got was:

chcon: libflashplayer.so: No such file or directory
chcon: flashplayer.xpt: No such file or directory
You need to specify the full path or to be in the directory where the plugins was installed.

Code:
[root@gold /]# cd /usr/lib/mozilla/plugins/
[root@gold plugins]# ls flashplayer.xpt
flashplayer.xpt
[root@gold plugins]# chcon system_u:object_r:lib_t flashplayer.xpt

or 

[root@gold /]# chcon system_u:object_r:lib_t /usr/lib/mozilla/plugins/flashplayer.xpt
Check the right path for your plugins. It is the same path the flash installer asked you.

Last edited by marozsas; 04-27-2006 at 07:09 AM.
 
Old 07-18-2006, 08:01 AM   #10
kissme1
LQ Newbie
 
Registered: Dec 2005
Posts: 29

Rep: Reputation: 15
u saved me a load of hard work mate many thanks it solved my problem on fedora core 5 amazing post
 
Old 09-30-2006, 05:26 AM   #11
wlaw
Member
 
Registered: Jun 2004
Location: HK
Distribution: Ubuntu
Posts: 242

Rep: Reputation: 30
Quote:
Originally Posted by erdichia
Another way around this is to simply turn off SELinux off when installing flash. I turned off SELinux and then just allowed Firefox to download and install its plugin. It worked fine.
Can anyone tell me how to turn off SElinux ? I am a newbie !
 
Old 09-30-2006, 06:47 AM   #12
hob
Senior Member
 
Registered: Mar 2004
Location: Wales, UK
Distribution: Debian, Ubuntu
Posts: 1,075

Rep: Reputation: 45
wlaw:

Turning off SELinux is usually the wrong thing to do: you can modify how it works with the system-config-securitylevel: System > Administration > Security Level and Firewall.

You can also disable SELinux with this, if it's necessary to do so.

FWIW, it's generally best to post new questions to new threads, as this makes the question more visible.
 
Old 10-15-2006, 09:30 PM   #13
Pirate96
LQ Newbie
 
Registered: Apr 2006
Posts: 10

Rep: Reputation: 0
Worked For Me great post

I was getting a file accessed denied on an apache directory. The following :chcon -t httpd_sys_content_t
Worked great.
 
  


Reply

Tags
wlaw


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Boot failure after upgrading FC5 TR3 to FC5 Official Release fsb1284 Fedora 3 03-25-2006 10:12 AM
FC5-test3 --> FC5-release - Anyone tried it? GL1800 Fedora 5 03-22-2006 05:16 PM
FC5 development release and FC5 official release- where is the DVD iso? smiley_lauf Fedora 11 03-13-2006 02:38 PM
selinux question stopmotion24 Fedora 2 03-26-2005 11:58 PM
selinux question ronin4601 Linux - Newbie 0 04-18-2004 02:59 PM


All times are GMT -5. The time now is 12:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration