LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   FC5 SELinux question (http://www.linuxquestions.org/questions/fedora-35/fc5-selinux-question-429961/)

marozsas 03-30-2006 06:49 AM

FC5 SELinux question
 
Hi,

I am trying to install Macromedia Flashplayer in my FC5 box.
The macromedia files are in /usr/lib/firefox-1.5.0.1/plugins but about:plugins in browser only shows the Default null plugins and Helix DNA Plugin.

I am suspected the culprid is SELinux.
Code:

# ls -Z /usr/lib/firefox-1.5.0.1/plugins/
-rwxr-xr-x  root    root    user_u:object_r:lib_t            flashplayer.xpt
-rwxr-xr-x  root    root    user_u:object_r:lib_t            libflashplayer.so
-rwxr-xr-x  root    root    system_u:object_r:textrel_shlib_t libnullplugin.so
-rwxr-xr-x  root    root    system_u:object_r:textrel_shlib_t libunixprintplugin.so
#

How do I change the SELinux attributes (is that the correct term?) to match with libnullplugin.so attributes ?

Or I am o wrong and this is not the problem at all ?

thanks,

marozsas 03-30-2006 09:50 AM

Solved !
It is trivial after I learned the chcon command:
Code:

[root@gold ~]# chcon system_u:object_r:lib_t flashplayer.xpt
[root@gold ~]# chcon  system_u:object_r:textrel_shlib_t libflashplayer.so
[root@gold ~]#

This don't mean I understand what I did :) I just apply the same SELinux properties from a working plugin to another one.

hob 03-30-2006 01:04 PM

FWIW, Macromedia have approved a third-party yum repository for Flash on Fedora Core 5:

http://macromedia.mplug.org/

The packages from there will install the plugin with the correct SELinux labels.

jeelliso 04-06-2006 04:13 PM

I had the same problem.

I tried using the recommended repository, but it did not install with the correct SELinux labels.

I tried what marozsas suggested and it works perfectly.

Just wanted to report back as to what worked for me and what didn't, in case someone else needs has a similar problem.

groggo 04-18-2006 01:32 AM

i had the same problem wooo hoo thanks thats got it working cool

erdichia 04-18-2006 11:59 AM

Another way around this is to simply turn off SELinux off when installing flash. I turned off SELinux and then just allowed Firefox to download and install its plugin. It worked fine.

groggo 04-19-2006 03:49 AM

bugger me i have the fedora 5 stop booting again this morning so yep it sure does work if ya turn off firewall for the install

good stuff

hferretluv 04-26-2006 11:43 PM

Fedora 5 and Flashplayer
 
Quote:

Originally Posted by marozsas
Solved !
It is trivial after I learned the chcon command:
Code:

[root@gold ~]# chcon system_u:object_r:lib_t flashplayer.xpt
[root@gold ~]# chcon  system_u:object_r:textrel_shlib_t libflashplayer.so
[root@gold ~]#

This don't mean I understand what I did :) I just apply the same SELinux properties from a working plugin to another one.


It didn't work for me. All I got was:

chcon: libflashplayer.so: No such file or directory
chcon: flashplayer.xpt: No such file or directory

So I must be doing something wrong, but I don't know what.

Well, I did want to lean linux, but I can't even find a darn book on bash, even.

marozsas 04-27-2006 06:07 AM

Quote:

Originally Posted by hferretluv
It didn't work for me. All I got was:

chcon: libflashplayer.so: No such file or directory
chcon: flashplayer.xpt: No such file or directory

You need to specify the full path or to be in the directory where the plugins was installed.

Code:

[root@gold /]# cd /usr/lib/mozilla/plugins/
[root@gold plugins]# ls flashplayer.xpt
flashplayer.xpt
[root@gold plugins]# chcon system_u:object_r:lib_t flashplayer.xpt

or

[root@gold /]# chcon system_u:object_r:lib_t /usr/lib/mozilla/plugins/flashplayer.xpt

Check the right path for your plugins. It is the same path the flash installer asked you.

kissme1 07-18-2006 07:01 AM

u saved me a load of hard work mate many thanks it solved my problem on fedora core 5 amazing post

wlaw 09-30-2006 04:26 AM

Quote:

Originally Posted by erdichia
Another way around this is to simply turn off SELinux off when installing flash. I turned off SELinux and then just allowed Firefox to download and install its plugin. It worked fine.

Can anyone tell me how to turn off SElinux ? I am a newbie ! :newbie:

hob 09-30-2006 05:47 AM

wlaw:

Turning off SELinux is usually the wrong thing to do: you can modify how it works with the system-config-securitylevel: System > Administration > Security Level and Firewall.

You can also disable SELinux with this, if it's necessary to do so.

FWIW, it's generally best to post new questions to new threads, as this makes the question more visible.

Pirate96 10-15-2006 08:30 PM

Worked For Me great post
 
I was getting a file accessed denied on an apache directory. The following :chcon -t httpd_sys_content_t
Worked great.


All times are GMT -5. The time now is 02:40 PM.