LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 05-19-2006, 09:30 AM   #1
Crito
Senior Member
 
Registered: Nov 2003
Location: Knoxville, TN
Distribution: Kubuntu 9.04
Posts: 1,168

Rep: Reputation: 53
FC5 locks when DNS goes down


When my ISP's DNS servers go down FC5 hangs for long periods during bootup and Gnome won't even open a terminal window if already logged in when it happens. Ctrl-Alt-F1 then ifdown eth0 is only way to make system responsive again.

Isn't there some kind of default DNS lookup timeout value? Doesn't appear to be IMHO.
 
Old 05-20-2006, 09:35 PM   #2
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 326Reputation: 326Reputation: 326Reputation: 326
There is a timeout for each DNS, so if you specify three, that's three timeouts. If you are using DHCP, then DHCP retries several times, each time going through the timeout cycle.

If your ISP DNS is that unreliable (very strange), you can specify a public DNS server as your secondary or tertiary DNS.
 
Old 05-21-2006, 08:21 AM   #3
Crito
Senior Member
 
Registered: Nov 2003
Location: Knoxville, TN
Distribution: Kubuntu 9.04
Posts: 1,168

Original Poster
Rep: Reputation: 53
Well, then whatever the timeout value is it's way too high. How can I adjust it?
 
Old 05-21-2006, 09:23 AM   #4
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 326Reputation: 326Reputation: 326Reputation: 326
There are a few things you can do to reduce timeouts.

1- If you are not using IPv6, in /etc/modprobe.conf add:

alias net-pf-10 off
alias ipv6 off

2- in /etc/resolv.conf, add:

option timeout:1

3- Edit /etc/sysconfig/network, and add:

DHCP_TIMEOUT=2

Note that by setting these values low, slow servers may timeout instead of having an opportunity to respond.
 
Old 08-16-2006, 11:30 AM   #5
teknasutra
LQ Newbie
 
Registered: Aug 2006
Posts: 1

Rep: Reputation: 0
FC5 hangs when DNS server not available.

In your /etc/hosts file make sure you have added the real host name for the local box. This allows the local box to resolve it's own name and may help eleviate the problem. Otherwise you can run a local DNS server that syncs with a public server. When your DSL goes down you.
 
  


Reply

Tags
dhcp, dns, ipv6, network, public, resolvconf, timeout, timeouts


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Squid DNS issue in FC5 paulqwinn Linux - Networking 3 02-02-2007 12:33 PM
FC5 GUI installer locks up sidebuster Linux - Newbie 3 03-27-2006 05:04 PM
Boot failure after upgrading FC5 TR3 to FC5 Official Release fsb1284 Fedora 3 03-25-2006 09:12 AM
FC5-test3 --> FC5-release - Anyone tried it? GL1800 Fedora 5 03-22-2006 04:16 PM
FC5 development release and FC5 official release- where is the DVD iso? smiley_lauf Fedora 11 03-13-2006 01:38 PM


All times are GMT -5. The time now is 01:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration