LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 11-01-2008, 10:39 PM   #1
TBennettcc
LQ Newbie
 
Registered: Sep 2004
Location: Fort Myers, FL, USA
Distribution: Fedora Core 4
Posts: 22

Rep: Reputation: 15
Unhappy FC4 - /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.6' not found


First of all, I realize this is now an unsupported version. I am a student at Florida Gulf Coast University. We happen to be running FC4 on a student project server (http://csidc.fgcu.edu). Aside from hosting the CSIDC 2005 website, this server is also used for other student projects. After I figure out this problem, my next project is to get Java EE (which I think I have successfully installed), Apache ANT (working on that now...), and Apache Tomcat running for a fellow student. He needs Tomcat to (I think) run JSP, JavaDB, and perhaps other software. He is attempting to control a robot via a web interface.

I admit, I am a Linux n00b, however, I ama quick study, and learn fast. I also try to RTFM and Google as much as possible before posting.

Any help is appreciated.

So, here's sort of where I am so far. Tried to install synaptic via yum. It appeared to go well. However, when I enter the command 'synaptic' in the terminal, this is what comes up:

Code:
[root@localhost bin]# synaptic
synaptic: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.6' not found (required by synaptic)
synaptic: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.6' not found (required by /usr/lib/libapt-pkg-libc6.3-6.so.2)
[root@localhost bin]#
When I enter 'yum provides libstdc++.so.6':

Code:
[root@localhost bin]# yum provides libstdc++.so.6
Yum Version: 2.4.1
COMMAND: yum
Installroot: /
Ext Commands:
   libstdc++.so.6
Searching Packages:
Setting up repositories
Baseurl(s) for repo: ['http://archives.fedoraproject.org/pub/archive/fedora/linux/core/4/i386/os/']
Reading repository metadata in from local files
Setting up Package Sacks
Excluding Packages in global exclude list
Finished
Excluding Incompatible Archs
Finished
Reading Local RPMDB
Matched libstdc++ - 4.0.0-8.i386 to require for libstdc++.so.6


libstdc++.i386                           4.0.0-8                fedora-archives
Matched from:
libstdc++.so.6
Importing Additional filelist information for packages


libstdc++.i386                           4.0.0-8                fedora-archives
Matched from:
/usr/lib/libstdc++.so.6
libstdc++.so.6


libstdc++.i386                           4.0.0-8                fedora-archives
Matched from:
/usr/lib/libstdc++.so.6
libstdc++.so.6


libstdc++.i386                           4.0.0-8                installed
Matched from:
/usr/lib/libstdc++.so.6
libstdc++.so.6


AdobeReader_enu.i486                     8.1.2_SU1-1            installed
Matched from:
/opt/Adobe/Reader8/Reader/intellinux/lib/libstdc++.so.6
libstdc++.so.6
[root@localhost bin]#
When I run 'yum provides GLIBCXX_3.4.6':

Code:
[root@localhost bin]# yum provides GLIBCXX_3.4.6
Yum Version: 2.4.1
COMMAND: yum
Installroot: /
Ext Commands:
   GLIBCXX_3.4.6
Searching Packages:
Setting up repositories
Baseurl(s) for repo: ['http://archives.fedoraproject.org/pub/archive/fedora/linux/core/4/i386/os/']
Reading repository metadata in from local files
Setting up Package Sacks
Excluding Packages in global exclude list
Finished
Excluding Incompatible Archs
Finished
Reading Local RPMDB
Importing Additional filelist information for packages


AdobeReader_enu.i486                     8.1.2_SU1-1            installed
Matched from:
libstdc++.so.6(GLIBCXX_3.4.6)
[root@localhost bin]#
When I run 'locate libstdc++.so.6':

Code:
[root@localhost bin]# locate libstdc++.so.6
/usr/lib/libstdc++.so.6.0.4
/usr/lib/libstdc++.so.6
/opt/Adobe/Reader8/Reader/intellinux/lib/libstdc++.so.6.0.7
/opt/Adobe/Reader8/Reader/intellinux/lib/libstdc++.so.6
[root@localhost bin]#
When I run 'ldd synaptic':

Code:
[root@localhost bin]# ldd synaptic
        linux-gate.so.1 =>  (0x009b8000)
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x001ec000)
        libselinux.so.1 => /lib/libselinux.so.1 (0x00456000)
        libattr.so.1 => /lib/libattr.so.1 (0x00d5c000)
        libc.so.6 => /lib/libc.so.6 (0x009f7000)
        /lib/ld-linux.so.2 (0x009d5000)
[root@localhost bin]#
Output of 'rpm -q -i --provides -l libstdc++':

Code:
[root@localhost mail]# rpm -q -i --provides -l libstdc++
Name        : libstdc++                    Relocations: (not relocatable)
Version     : 4.0.0                             Vendor: Red Hat, Inc.
Release     : 8                             Build Date: Thu 19 May 2005 08:54:41 PM EDT
Install Date: Wed 22 Oct 2008 12:22:47 AM EDT      Build Host: tweety.build.redhat.com
Group       : System Environment/Libraries   Source RPM: gcc-4.0.0-8.src.rpm
Size        : 919548                           License: GPL
Signature   : DSA/SHA1, Fri 20 May 2005 01:18:37 PM EDT, Key ID b44269d04f2a6fd2Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://gcc.gnu.org
Summary     : The GNU Standard C++ Library v3.
Description :
The libstdc++ package contains a snapshot of the GNU Standard C++
Library v3, an ongoing project to implement the ISO 14882 Standard C++
library.
libstdc++.so.6
libstdc++.so.6(CXXABI_1.3)
libstdc++.so.6(CXXABI_1.3.1)
libstdc++.so.6(GLIBCXX_3.4)
libstdc++.so.6(GLIBCXX_3.4.1)
libstdc++.so.6(GLIBCXX_3.4.2)
libstdc++.so.6(GLIBCXX_3.4.3)
libstdc++.so.6(GLIBCXX_3.4.4)
libstdc++34
libstdc++ = 4.0.0-8
/usr/lib/libstdc++.so.6
/usr/lib/libstdc++.so.6.0.4
[root@localhost mail]#
Code:
[root@localhost bin]# ls -al /usr/lib/libstdc++.so.6
lrwxrwxrwx  1 root root 18 Oct 22 00:22 /usr/lib/libstdc++.so.6 -> libstdc++.so.6.0.4
[root@localhost bin]#
Code:
[root@localhost bin]# ls -al /opt/Adobe/Reader8/Reader/intellinux/lib/libstdc++.so.6
lrwxrwxrwx  1 root root 18 Oct 24 11:56 /opt/Adobe/Reader8/Reader/intellinux/lib/libstdc++.so.6 -> libstdc++.so.6.0.7
[root@localhost bin]#
Code:
[root@localhost bin]# rpm -q glibc
glibc-2.3.5-10
[root@localhost bin]#
Code:
[root@localhost bin]# rpm -qa | grep glibc
glibc-devel-2.3.5-10
glibc-common-2.3.5-10
glibc-kernheaders-2.4-9.1.94
glibc-headers-2.3.5-10
glibc-2.3.5-10
glibc-utils-2.3.5-10
glibc-profile-2.3.5-10
[root@localhost bin]#
Code:
[root@localhost bin]# rpm -qa | grep libstdc++
compat-libstdc++-33-3.2.3-47.fc4
libstdc++-4.0.0-8
libstdc++-devel-4.0.0-8
compat-libstdc++-296-2.96-132.fc4
[root@localhost bin]#
Any ideas?

And, on another note, I was wondering whether anyone knows of any repositories that still carry packages for FC4? (In case something like this comes up again...)

So far, I have found:

Code:
http://www.muug.mb.ca/mirror/fedoralegacy/fedora/$releasever/os/$basearch/
and

Code:
http://www.muug.mb.ca/mirror/fedoralegacy/fedora/$releasever/updates/$basearch/
However, there seems to be a problem when yum tries to download the /repodata/primary.xml.gz file from the above two mirror sites. (I did manage to finally download this file manually... is there somewhere I can put it to save yum the work (and failed attempts to download it)? )

Also, managed to find:

Code:
http://archives.fedoraproject.org/pub/archive/fedora/linux/core/$releasever/$basearch/os/
which at least doesn't error out, however, it doesn't seem to be much help as of yet.

Thank you so much for your help. It is greatly appreciated.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by ./example1) babu198649 Linux - Newbie 24 12-02-2010 05:09 AM
libstdc++.so.6: version `GLIBCXX_3.4.9' Please Help orbit Slackware 6 06-03-2008 12:45 AM
"/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found" worked but stil confused babu198649 Linux - Newbie 2 03-24-2008 02:18 AM
libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/bin/../lib/libstdc++.s hferretluv Linux - Software 4 12-18-2006 01:31 PM
/usr/lib/libstdc++.so.5: version 'GLIBCPP_3.2.2' not found vidi Linux - Software 1 06-10-2004 10:26 AM


All times are GMT -5. The time now is 03:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration